aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-05-31 20:09:49 +0800
committertijl <tijl@FreeBSD.org>2016-05-31 20:09:49 +0800
commit15fbacb7c69693e22f2e39753ace4003a9cd278c (patch)
tree0db8b4fd7b4219eab18db74adb78de2ca763eae3 /devel
parent93977387a5eb2fc923f021f6c37c3b8df1eb3179 (diff)
downloadfreebsd-ports-gnome-15fbacb7c69693e22f2e39753ace4003a9cd278c.tar.gz
freebsd-ports-gnome-15fbacb7c69693e22f2e39753ace4003a9cd278c.tar.zst
freebsd-ports-gnome-15fbacb7c69693e22f2e39753ace4003a9cd278c.zip
Fix autoscan script with newer versions of Perl (escape left brace in regex)
PR: 209768 Submitted by: mat
Diffstat (limited to 'devel')
-rw-r--r--devel/autoconf/Makefile1
-rw-r--r--devel/autoconf/files/patch-bin-autoscan.in11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
index 09cb64088c84..da2b8dde268b 100644
--- a/devel/autoconf/Makefile
+++ b/devel/autoconf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= autoconf
PORTVERSION= 2.69
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= GNU
DISTNAME= autoconf-${PORTVERSION}
diff --git a/devel/autoconf/files/patch-bin-autoscan.in b/devel/autoconf/files/patch-bin-autoscan.in
new file mode 100644
index 000000000000..a55345cc5593
--- /dev/null
+++ b/devel/autoconf/files/patch-bin-autoscan.in
@@ -0,0 +1,11 @@
+--- bin/autoscan.in.orig 2012-04-25 02:37:26 UTC
++++ bin/autoscan.in
+@@ -358,7 +358,7 @@ sub scan_sh_file ($)
+ {
+ # Strip out comments and variable references.
+ s/#.*//;
+- s/\${[^\}]*}//g;
++ s/\$\{[^\}]*}//g;
+ s/@[^@]*@//g;
+
+ # Tokens in the code.