aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-07-16 01:23:48 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-07-16 01:23:48 +0800
commit180328938d9d47c7e9e04533e5e02f0d0fd4cbd2 (patch)
treee55d86682fff9c6e6e71d82d0f8464fd783918bd /devel
parentc0aa9a54bc50bec98989bf9dcce41597fea07ef1 (diff)
downloadfreebsd-ports-gnome-180328938d9d47c7e9e04533e5e02f0d0fd4cbd2.tar.gz
freebsd-ports-gnome-180328938d9d47c7e9e04533e5e02f0d0fd4cbd2.tar.zst
freebsd-ports-gnome-180328938d9d47c7e9e04533e5e02f0d0fd4cbd2.zip
Update to 6.513
- Remove BROKEN for Perl 5.22 Changes: http://search.cpan.org/dist/Coro/Changes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Coro/Makefile11
-rw-r--r--devel/p5-Coro/distinfo6
-rw-r--r--devel/p5-Coro/files/patch-Coro-State.xs25
3 files changed, 5 insertions, 37 deletions
diff --git a/devel/p5-Coro/Makefile b/devel/p5-Coro/Makefile
index d8cddd4393c2..acfec8a44140 100644
--- a/devel/p5-Coro/Makefile
+++ b/devel/p5-Coro/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= Coro
-PORTVERSION= 6.51.1
+PORTVERSION= 6.51.3
PORTEPOCH= 1
-PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -36,12 +35,6 @@ PORTEXAMPLES= *
SHEBANG_FILES= Coro/*.pl eg/*
perl_OLD_CMD= /.*/bin/perl
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502200 && ${PERL_LEVEL} < 502400
-BROKEN= Perl >= 5.22 and < 5.24 is not supported
-.endif
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Coro/EV/EV.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Coro/Event/Event.so
@@ -55,4 +48,4 @@ post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
${INSTALL_SCRIPT} ${WRKSRC}/eg/* ${STAGEDIR}${EXAMPLESDIR}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Coro/distinfo b/devel/p5-Coro/distinfo
index 2229d95ff023..12db3ef2fc0c 100644
--- a/devel/p5-Coro/distinfo
+++ b/devel/p5-Coro/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1467056137
-SHA256 (Coro-6.511.tar.gz) = 7e3ed48cdb3f3742d94ae3ab3d088c3ab818c521f8681da6c5f656bd49ac53ea
-SIZE (Coro-6.511.tar.gz) = 195173
+TIMESTAMP = 1500125547
+SHA256 (Coro-6.513.tar.gz) = 3448b99c62142d1b204bf87269600d53328daf9de5a68cc995bd056a04f2696d
+SIZE (Coro-6.513.tar.gz) = 195455
diff --git a/devel/p5-Coro/files/patch-Coro-State.xs b/devel/p5-Coro/files/patch-Coro-State.xs
deleted file mode 100644
index 7a9a67e698e5..000000000000
--- a/devel/p5-Coro/files/patch-Coro-State.xs
+++ /dev/null
@@ -1,25 +0,0 @@
---- Coro/State.xs.orig 2016-06-26 21:44:30 UTC
-+++ Coro/State.xs
-@@ -102,6 +102,10 @@ static int cctx_max_idle = 4;
- #include "CoroAPI.h"
- #define GCoroAPI (&coroapi) /* very sneaky */
-
-+#ifndef PERL_MAGIC_ext
-+# define PERL_MAGIC_ext '~'
-+#endif
-+
- #ifdef USE_ITHREADS
- # if CORO_PTHREAD
- static void *coro_thx;
-@@ -1412,7 +1416,11 @@ runops_trace (pTHX)
- PUSHMARK (SP);
- PUSHs (&PL_sv_yes);
- PUSHs (fullname);
-+#if PERL_VERSION_ATLEAST(5,24,0)
-+ PUSHs (CxHASARGS (cx) ? sv_2mortal (newRV_inc (PL_curpad[0])) : &PL_sv_undef);
-+#else
- PUSHs (CxHASARGS (cx) ? sv_2mortal (newRV_inc ((SV *)cx->blk_sub.argarray)) : &PL_sv_undef);
-+#endif
- PUTBACK;
- cb = hv_fetch ((HV *)SvRV (coro_current), "_trace_sub_cb", sizeof ("_trace_sub_cb") - 1, 0);
- if (cb) call_sv (*cb, G_KEEPERR | G_EVAL | G_VOID | G_DISCARD);