aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-06-29 20:32:41 +0800
committermat <mat@FreeBSD.org>2015-06-29 20:32:41 +0800
commit189e18dbe0053a0983c3e0ed6ebc059e93a73a6a (patch)
tree5478437b587c349cb249d39ff5c9d4649429dc41 /devel
parent50b75a8385ae69d8590cbaa2c6772145a13c365a (diff)
downloadfreebsd-ports-gnome-189e18dbe0053a0983c3e0ed6ebc059e93a73a6a.tar.gz
freebsd-ports-gnome-189e18dbe0053a0983c3e0ed6ebc059e93a73a6a.tar.zst
freebsd-ports-gnome-189e18dbe0053a0983c3e0ed6ebc059e93a73a6a.zip
Make Perl behave nicely, and install files 644 and not 444.
With hat: perl@ Sponsored by: Absolight
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-ExtUtils-Install/Makefile2
-rw-r--r--devel/p5-ExtUtils-Install/files/patch-lib_ExtUtils_Install.pm11
2 files changed, 12 insertions, 1 deletions
diff --git a/devel/p5-ExtUtils-Install/Makefile b/devel/p5-ExtUtils-Install/Makefile
index ad3e609bb270..a2f9ad39563b 100644
--- a/devel/p5-ExtUtils-Install/Makefile
+++ b/devel/p5-ExtUtils-Install/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ExtUtils-Install
PORTVERSION= 2.04
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/devel/p5-ExtUtils-Install/files/patch-lib_ExtUtils_Install.pm b/devel/p5-ExtUtils-Install/files/patch-lib_ExtUtils_Install.pm
new file mode 100644
index 000000000000..946f7cfcce1c
--- /dev/null
+++ b/devel/p5-ExtUtils-Install/files/patch-lib_ExtUtils_Install.pm
@@ -0,0 +1,11 @@
+--- lib/ExtUtils/Install.pm.orig 2015-06-19 12:08:32 UTC
++++ lib/ExtUtils/Install.pm
+@@ -809,7 +809,7 @@ sub install { #XXX OS-SPECIFIC
+ utime($atime,$mtime + $Is_VMS,$targetfile) unless $dry_run>1;
+
+
+- $mode = 0444 | ( $mode & 0111 ? 0111 : 0 );
++ $mode = 0644 | ( $mode & 0111 ? 0111 : 0 );
+ $mode = $mode | 0222
+ if $realtarget ne $targetfile;
+ _chmod( $mode, $targetfile, $verbose );