aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-28 09:42:30 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-28 09:42:30 +0800
commit19c7397033ce2e1357a03e47e1e02e36c4e8846d (patch)
tree4bcc406896488d66df12ae8d93a36a4982246190 /devel
parentd5d5bcf1363e6e9304258d9d58bd3bd8f6d31e6f (diff)
downloadfreebsd-ports-gnome-19c7397033ce2e1357a03e47e1e02e36c4e8846d.tar.gz
freebsd-ports-gnome-19c7397033ce2e1357a03e47e1e02e36c4e8846d.tar.zst
freebsd-ports-gnome-19c7397033ce2e1357a03e47e1e02e36c4e8846d.zip
- use new hook USE_GNUSTEP in bsd.port.mk
Diffstat (limited to 'devel')
-rw-r--r--devel/gnustep-make/Makefile7
-rw-r--r--devel/gorm/Makefile11
-rw-r--r--devel/projectcenter.app/Makefile13
3 files changed, 11 insertions, 20 deletions
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index b921ae2f6e03..f17b4774644f 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -33,6 +33,7 @@ CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c" \
CFLAGS="${CFLAGS} -D_THREAD_SAFE"
CONFIGURE_TARGET=
USE_GMAKE= yes
+USE_GNUSTEP= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
@@ -42,13 +43,9 @@ PLIST_SUB+= NOFLAT2=""
PLIST_SUB+= NOFLAT2="${GNU_ARCH}/${OPSYS:L}/"
.endif
-.include <bsd.port.pre.mk>
-
-.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
-
post-configure:
${MV} ${WRKSRC}/config.make ${WRKSRC}/config.make.sed
${SED} -e "s|\(objc_threaded:=\).*|\1 ${PTHREAD_LIBS}|" \
< ${WRKSRC}/config.make.sed > ${WRKSRC}/config.make
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/gorm/Makefile b/devel/gorm/Makefile
index abd020de13ae..80d4668a99cb 100644
--- a/devel/gorm/Makefile
+++ b/devel/gorm/Makefile
@@ -19,15 +19,12 @@ COMMENT= Graphical Object Relationship Modeller
PREFIX= ${LOCALBASE}/GNUstep
NO_MTREE= yes
USE_GMAKE= yes
-MAKEFILE=
-ALL_TARGET=
-
-.include <bsd.port.pre.mk>
-
+USE_GNUSTEP= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
+MAKEFILE=
+ALL_TARGET=
.if defined(WITH_GNUSTEP_DEVEL)
PLIST_SUB+= PALETTES=System/Applications/Gorm.app/Resources
@@ -35,4 +32,4 @@ PLIST_SUB+= PALETTES=System/Applications/Gorm.app/Resources
PLIST_SUB+= PALETTES=System/Developer/Palettes
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/projectcenter.app/Makefile b/devel/projectcenter.app/Makefile
index 24f9598a660d..803697d55083 100644
--- a/devel/projectcenter.app/Makefile
+++ b/devel/projectcenter.app/Makefile
@@ -20,6 +20,10 @@ PREFIX= ${LOCALBASE}/GNUstep
NO_MTREE= yes
WRKSRC= ${WRKDIR}/ProjectCenter
USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
MAKEFILE= GNUmakefile
MAKE_ENV+= ADDITIONAL_INCLUDE_DIRS="-I${WRKSRC}"
MAKE_ENV+= ADDITIONAL_LIB_DIRS="-L${WRKSRC}/PCLib/shared_obj/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu"
@@ -27,13 +31,6 @@ MAKE_ENV+= ADDITIONAL_LIB_DIRS="-L${WRKSRC}/PCLib/shared_obj/${GNU_ARCH}/${OPSYS
FIXME= GNUmakefile.bundles GNUmakefile.preamble \
PCLib/GNUmakefile.preamble
-.include <bsd.port.pre.mk>
-
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
-
# Quick workaround until I find out how to set the real path in the code
post-patch:
.for file in PCLib/PCBundleLoader.m PCAppController.m
@@ -47,4 +44,4 @@ post-patch:
${WRKSRC}/${file}.sed > ${WRKSRC}/${file}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>