aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2003-06-24 05:03:26 +0800
committerobraun <obraun@FreeBSD.org>2003-06-24 05:03:26 +0800
commit1ac792b234f3df71c583487d061f8c013b57959e (patch)
treee332d4bd9ac249f685a72448e9b80a67ab984fb7 /devel
parent8f338917ce4edc0ff190167594c6298a3d093c70 (diff)
downloadfreebsd-ports-gnome-1ac792b234f3df71c583487d061f8c013b57959e.tar.gz
freebsd-ports-gnome-1ac792b234f3df71c583487d061f8c013b57959e.tar.zst
freebsd-ports-gnome-1ac792b234f3df71c583487d061f8c013b57959e.zip
Haskell Cryptographic Library
WWW: http://www.haskell.org/crypto/ReadMe.html
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-crypto/Makefile46
-rw-r--r--devel/hs-crypto/distinfo1
-rw-r--r--devel/hs-crypto/pkg-descr20
-rw-r--r--devel/hs-crypto/pkg-plist27
5 files changed, 95 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 967fc659ce68..c931513d6a47 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -246,6 +246,7 @@
SUBDIR += hs-alex
SUBDIR += hs-buddha
SUBDIR += hs-c2hs
+ SUBDIR += hs-crypto
SUBDIR += hs-drift
SUBDIR += hs-green-card
SUBDIR += hs-haddock
diff --git a/devel/hs-crypto/Makefile b/devel/hs-crypto/Makefile
new file mode 100644
index 000000000000..69aec390af17
--- /dev/null
+++ b/devel/hs-crypto/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: crypto
+# Date created: 23 June 2003
+# Whom: Oliver Braun <obraun@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crypto
+PORTVERSION= 0.2.0
+CATEGORIES= devel haskell
+MASTER_SITES= http://haskell.cs.yale.edu/packages/downloads/
+PKGNAMEPREFIX= hs-
+EXTRACT_SUFX= .tar
+
+MAINTAINER= obraun@FreeBSD.org
+COMMENT= A Haskell Cryptographic Library
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+
+WRKSRC= ${WRKDIR}
+USE_REINPLACE= yes
+USE_GMAKE= yes
+ALL_TARGET= # empty
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' \
+ ${WRKSRC}/Makefile ${WRKSRC}/package.conf
+
+do-configure:
+ @(cd ${WRKSRC} && ${GMAKE} depend)
+
+.if !defined(NOPORTDOCS)
+post-build:
+ @(cd ${WRKSRC} && ${GMAKE} doc)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC} && \
+ ${INSTALL_DATA} *.html ReadMe.* haddock.css haskell_icon.gif ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/hs-crypto/distinfo b/devel/hs-crypto/distinfo
new file mode 100644
index 000000000000..9e5298dd5e5d
--- /dev/null
+++ b/devel/hs-crypto/distinfo
@@ -0,0 +1 @@
+MD5 (crypto-0.2.0.tar) = db08c4f9555b8332f3b683942e14fd8e
diff --git a/devel/hs-crypto/pkg-descr b/devel/hs-crypto/pkg-descr
new file mode 100644
index 000000000000..b676f86e5207
--- /dev/null
+++ b/devel/hs-crypto/pkg-descr
@@ -0,0 +1,20 @@
+Haskell Cryptographic Library
+
+This library collects together existing Haskell cryptographic functions and
+augments them so that they:
+
+* Have common type signatures.
+* Can be used with the standard mode and padding algorithms (in the case of
+ block mode ciphers).
+
+This very initial release contains:
+
+* DES
+* Blowfish
+* Cipher Block Chaining (CBC) mode
+* PKCS#5 and nulls padding
+
+WWW: http://www.haskell.org/crypto/ReadMe.html
+
+- Oliver Braun
+obraun@FreeBSD.org
diff --git a/devel/hs-crypto/pkg-plist b/devel/hs-crypto/pkg-plist
new file mode 100644
index 000000000000..246473a7c3e4
--- /dev/null
+++ b/devel/hs-crypto/pkg-plist
@@ -0,0 +1,27 @@
+lib/HScrypto.o
+lib/libHScrypto.a
+lib/imports/HScrypto/Codec/Encryption/Blowfish.hi
+lib/imports/HScrypto/Codec/Encryption/BlowfishAux.hi
+lib/imports/HScrypto/Codec/Encryption/DES.hi
+lib/imports/HScrypto/Codec/Encryption/DESAux.hi
+lib/imports/HScrypto/Codec/Encryption/Modes.hi
+lib/imports/HScrypto/Codec/Encryption/Padding.hi
+lib/imports/HScrypto/Codec/Encryption/Utils.hi
+%%PORTDOCS%%share/doc/crypto/Codec.Encryption.Blowfish.html
+%%PORTDOCS%%share/doc/crypto/Codec.Encryption.BlowfishAux.html
+%%PORTDOCS%%share/doc/crypto/Codec.Encryption.DES.html
+%%PORTDOCS%%share/doc/crypto/Codec.Encryption.DESAux.html
+%%PORTDOCS%%share/doc/crypto/Codec.Encryption.Modes.html
+%%PORTDOCS%%share/doc/crypto/Codec.Encryption.Padding.html
+%%PORTDOCS%%share/doc/crypto/Codec.Encryption.Utils.html
+%%PORTDOCS%%share/doc/crypto/ReadMe.html
+%%PORTDOCS%%share/doc/crypto/ReadMe.txt
+%%PORTDOCS%%share/doc/crypto/doc-index.html
+%%PORTDOCS%%share/doc/crypto/haddock.css
+%%PORTDOCS%%share/doc/crypto/haskell_icon.gif
+%%PORTDOCS%%share/doc/crypto/index.html
+%%PORTDOCS%%@dirrm share/doc/crypto
+@dirrm lib/imports/HScrypto/Codec/Encryption
+@dirrm lib/imports/HScrypto/Codec
+@dirrm lib/imports/HScrypto
+@dirrm lib/imports