aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-09-17 00:36:59 +0800
committerPietro Cerutti <gahr@FreeBSD.org>2013-09-17 00:36:59 +0800
commit1f7b0d3e1b562bcd76f89ebdbd346571511c07c0 (patch)
treebf0d38c880c8a0db0b2c0894782065bac5dff2ec /devel
parentef5a8cdc9097247c916b524211957d60b1109400 (diff)
downloadfreebsd-ports-gnome-1f7b0d3e1b562bcd76f89ebdbd346571511c07c0.tar.gz
freebsd-ports-gnome-1f7b0d3e1b562bcd76f89ebdbd346571511c07c0.tar.zst
freebsd-ports-gnome-1f7b0d3e1b562bcd76f89ebdbd346571511c07c0.zip
- Update to 6.0.7
- Fix build with libc++ [1] - Switch build type to CMake Change log: from ucommon 6.0.6 to 6.0.7 - error state in fsys open fixed - fsys error reset inline added from ucommon 6.0.5 to 6.0.6 - small cleanup of useless validator assignments - fix gnutls casting and warnings - modernized automake support from ucommon 6.0.4 to 6.0.5 - additional constructors to pass pre-allocated memory from ucommon 6.0.3 to 6.0.4 - fix for address list comparison issue Reported by: pkg-fallout [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/ucommon/Makefile21
-rw-r--r--devel/ucommon/distinfo4
-rw-r--r--devel/ucommon/files/patch-CMakeLists.txt36
-rw-r--r--devel/ucommon/files/patch-commoncpp_address.cpp20
-rw-r--r--devel/ucommon/pkg-plist9
5 files changed, 68 insertions, 22 deletions
diff --git a/devel/ucommon/Makefile b/devel/ucommon/Makefile
index 6440a19fef71..4cb99190827f 100644
--- a/devel/ucommon/Makefile
+++ b/devel/ucommon/Makefile
@@ -2,34 +2,27 @@
# $FreeBSD$
PORTNAME= ucommon
-PORTVERSION= 6.0.3
+PORTVERSION= 6.0.7
CATEGORIES= devel
-MASTER_SITES= http://www.gnutelephony.org/dist/tarballs/ \
- http://www.da3m0n8t3r.com/gnutelephony/www.gnutelephony.org/dist/tarballs/
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= commoncpp
MAINTAINER= gahr@FreeBSD.org
COMMENT= Very lightweight C++ design pattern library
LICENSE= LGPL3
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig cmake:outsource
+CMAKE_ARGS+= -DBUILD_TESTING:BOOL=ON \
+ -DINSTALL_BINDIR:STRING=bin/${PORTNAME}
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--bindir=${PREFIX}/bin/${PORTNAME}
MAN1= args.1 car.1 commoncpp-config.1 mdsum.1 pdetach.1 \
scrub-files.1 sockaddr.1 ucommon-config.1 zerofill.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 1000000
-post-patch:
- ${REINPLACE_CMD} -e '/HAVE_OPENSSL_FIPS_H/s/define/undef/' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
-
-.endif
-
regression-test: build
- cd ${WRKSRC}/test && ${MAKE} check
+ cd ${BUILD_WRKSRC}/test && ${MAKE} test
.include <bsd.port.post.mk>
diff --git a/devel/ucommon/distinfo b/devel/ucommon/distinfo
index 7ef7ff84f27d..0debeaed3253 100644
--- a/devel/ucommon/distinfo
+++ b/devel/ucommon/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ucommon-6.0.3.tar.gz) = 228f3a0fa78173e9fa43e154250a7ed4f1e5be720a81fd2768506c088190c432
-SIZE (ucommon-6.0.3.tar.gz) = 806841
+SHA256 (ucommon-6.0.7.tar.gz) = 7d5cc5385c4d04e092c4e159522bc42d44cc0105fb499c0e960863f32a649be6
+SIZE (ucommon-6.0.7.tar.gz) = 826102
diff --git a/devel/ucommon/files/patch-CMakeLists.txt b/devel/ucommon/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..0c8e7b49b3df
--- /dev/null
+++ b/devel/ucommon/files/patch-CMakeLists.txt
@@ -0,0 +1,36 @@
+--- CMakeLists.txt.orig 2013-07-28 12:32:06.000000000 +0200
++++ CMakeLists.txt 2013-09-16 18:29:12.000000000 +0200
+@@ -30,7 +30,9 @@
+ # when we override default install prefix, assume full path is used...
+
+ set(INSTALL_INCLUDEDIR include)
+-set(INSTALL_BINDIR bin)
++if (NOT INSTALL_BINDIR)
++ set(INSTALL_BINDIR bin)
++endif ()
+
+ if(WIN32)
+ set(INSTALL_MANDIR man)
+@@ -50,7 +52,7 @@
+ endif()
+ endif()
+ set(INSTALL_SBINDIR sbin)
+- set(INSTALL_MANDIR share/man)
++ set(INSTALL_MANDIR man)
+ set(INSTALL_LOCALE share/locale)
+ set(INSTALL_DOCDIR share/doc/${PROJECT_NAME})
+ set(INSTALL_INFODIR share/info)
+@@ -566,11 +568,11 @@
+ endif()
+
+ if(NOT WIN32)
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.pc DESTINATION libdata/pkgconfig)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ucommon-config DESTINATION ${INSTALL_BINDIR})
+ if(BUILD_STDLIB)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/commoncpp-config DESTINATION ${INSTALL_BINDIR})
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/commoncpp.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/commoncpp.pc DESTINATION libdata/pkgconfig)
+ endif()
+ endif(NOT WIN32)
+
diff --git a/devel/ucommon/files/patch-commoncpp_address.cpp b/devel/ucommon/files/patch-commoncpp_address.cpp
new file mode 100644
index 000000000000..d9a79068dce4
--- /dev/null
+++ b/devel/ucommon/files/patch-commoncpp_address.cpp
@@ -0,0 +1,20 @@
+--- commoncpp/address.cpp.orig 2013-09-16 17:58:54.000000000 +0200
++++ commoncpp/address.cpp 2013-09-16 17:59:55.000000000 +0200
+@@ -1062,7 +1062,7 @@
+ #endif
+
+ memset(&netmask, 0, sizeof(netmask));
+- bitset((bit_t *)&netmask, getMask(cp));
++ ::bitset((bit_t *)&netmask, getMask(cp));
+ setString(cbuf, sizeof(cbuf), cp);
+
+ ep = (char *)strchr(cp, '/');
+@@ -1192,7 +1192,7 @@
+ char *ep;
+
+ memset(&netmask, 0, sizeof(netmask));
+- bitset((bit_t *)&netmask, getMask(cp));
++ ::bitset((bit_t *)&netmask, getMask(cp));
+ setString(cbuf, sizeof(cbuf), cp);
+ ep = (char *)strchr(cp, '/');
+ if(ep)
diff --git a/devel/ucommon/pkg-plist b/devel/ucommon/pkg-plist
index 7b7c597d3e7b..446bdaf76596 100644
--- a/devel/ucommon/pkg-plist
+++ b/devel/ucommon/pkg-plist
@@ -61,18 +61,15 @@ include/ucommon/ucommon.h
include/ucommon/unicode.h
include/ucommon/vector.h
include/ucommon/xml.h
-lib/libcommoncpp.a
-lib/libcommoncpp.la
lib/libcommoncpp.so
lib/libcommoncpp.so.6
-lib/libucommon.a
-lib/libucommon.la
+lib/libcommoncpp.so.6.0.7
lib/libucommon.so
lib/libucommon.so.6
-lib/libusecure.a
-lib/libusecure.la
+lib/libucommon.so.6.0.7
lib/libusecure.so
lib/libusecure.so.6
+lib/libusecure.so.6.0.7
libdata/pkgconfig/commoncpp.pc
libdata/pkgconfig/ucommon.pc
@dirrm include/ucommon