aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-06 10:41:10 +0800
committermiwi <miwi@FreeBSD.org>2014-02-06 10:41:10 +0800
commit21790928e1b7fc73ebf15116561d96a1da92956d (patch)
treed7c89d663fa981bc19d636b8a4b4620a925118b7 /devel
parent3694744e80267556fd9be514b7f8105e13c02bb9 (diff)
downloadfreebsd-ports-gnome-21790928e1b7fc73ebf15116561d96a1da92956d.tar.gz
freebsd-ports-gnome-21790928e1b7fc73ebf15116561d96a1da92956d.tar.zst
freebsd-ports-gnome-21790928e1b7fc73ebf15116561d96a1da92956d.zip
- Stage support
Diffstat (limited to 'devel')
-rw-r--r--devel/gob2/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/devel/gob2/Makefile b/devel/gob2/Makefile
index 17b4541076f3..e379c377a56f 100644
--- a/devel/gob2/Makefile
+++ b/devel/gob2/Makefile
@@ -10,18 +10,16 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A preprocessor for making GObjects with inline C
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= glib20
-USES= pkgconfig
+USES= pkgconfig gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= bin/gob2 share/aclocal/gob2.m4 ${EXAMPLES:S/^/%%EXAMPLESDIR%%\//}
+PLIST_FILES= bin/gob2 share/aclocal/gob2.m4 ${EXAMPLES:S/^/%%EXAMPLESDIR%%\//} \
+ man/man1/gob2.1.gz
PLIST_DIRS= %%EXAMPLESDIR%%
-MAN1= gob2.1
-
EXAMPLES= GNOME_Foo_SomeInterface.idl \
README \
foo-some-interface.gob \
@@ -31,11 +29,10 @@ EXAMPLES= GNOME_Foo_SomeInterface.idl \
my-glade.gob \
my-person.gob
-NO_STAGE= yes
post-install:
- ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/examples/${f} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${f} ${STAGEDIR}${EXAMPLESDIR}
.endfor
.include <bsd.port.mk>