aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-05-25 15:12:32 +0800
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-05-25 15:12:32 +0800
commit22158a2c1ee40d66cf753ce82414821a88f707f9 (patch)
tree1816c9e63921ac06f43c655aa444ca558fe795e3 /devel
parent4caffba231574ab66ac5259040910ef5175eb5d9 (diff)
downloadfreebsd-ports-gnome-22158a2c1ee40d66cf753ce82414821a88f707f9.tar.gz
freebsd-ports-gnome-22158a2c1ee40d66cf753ce82414821a88f707f9.tar.zst
freebsd-ports-gnome-22158a2c1ee40d66cf753ce82414821a88f707f9.zip
Method::Alias is designed to be used as a pragma, to which you provide a
set of pairs of method names. Only very minimal checking is done, if you wish to create infinite loops or what have you, you are more than welcome to shoot yourself in the foot. # Add a single method alias use Method::Alias 'foo' => 'bar'; # Add several method aliases use Method::Alias 'a' => 'b', 'c' => 'd', 'e' => 'f'; WWW: http://search.cpan.org/dist/Method-Alias
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Method-Alias/Makefile22
-rw-r--r--devel/p5-Method-Alias/distinfo3
-rw-r--r--devel/p5-Method-Alias/pkg-descr14
-rw-r--r--devel/p5-Method-Alias/pkg-plist5
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 88803a4d3c70..ca9f783cfef7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1293,6 +1293,7 @@
SUBDIR += p5-Make-Cache
SUBDIR += p5-Memoize
SUBDIR += p5-Memoize-ExpireLRU
+ SUBDIR += p5-Method-Alias
SUBDIR += p5-Mknod
SUBDIR += p5-Module-Build
SUBDIR += p5-Module-Build-Convert
diff --git a/devel/p5-Method-Alias/Makefile b/devel/p5-Method-Alias/Makefile
new file mode 100644
index 000000000000..7b59aa7e55d2
--- /dev/null
+++ b/devel/p5-Method-Alias/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Method-Alias
+# Date created: 24 May 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Method-Alias
+PORTVERSION= 1.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/A/AD/ADAMK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Create method aliases (and do it safely)
+
+MAN3= Method::Alias.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Method-Alias/distinfo b/devel/p5-Method-Alias/distinfo
new file mode 100644
index 000000000000..c6f8f4b0a7e1
--- /dev/null
+++ b/devel/p5-Method-Alias/distinfo
@@ -0,0 +1,3 @@
+MD5 (Method-Alias-1.03.tar.gz) = f3c0e6e93c639316b5c1cd05c02d6954
+SHA256 (Method-Alias-1.03.tar.gz) = d3737e0feda7c7aebd880ee378ac009ab3aa6da44a7e885c2f8d31d3a13e1a53
+SIZE (Method-Alias-1.03.tar.gz) = 21253
diff --git a/devel/p5-Method-Alias/pkg-descr b/devel/p5-Method-Alias/pkg-descr
new file mode 100644
index 000000000000..a138a170cc64
--- /dev/null
+++ b/devel/p5-Method-Alias/pkg-descr
@@ -0,0 +1,14 @@
+Method::Alias is designed to be used as a pragma, to which you provide a
+set of pairs of method names. Only very minimal checking is done, if you
+wish to create infinite loops or what have you, you are more than
+welcome to shoot yourself in the foot.
+
+# Add a single method alias
+ use Method::Alias 'foo' => 'bar';
+
+# Add several method aliases
+ use Method::Alias 'a' => 'b',
+ 'c' => 'd',
+ 'e' => 'f';
+
+WWW: http://search.cpan.org/dist/Method-Alias
diff --git a/devel/p5-Method-Alias/pkg-plist b/devel/p5-Method-Alias/pkg-plist
new file mode 100644
index 000000000000..ba167d06d249
--- /dev/null
+++ b/devel/p5-Method-Alias/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Method/Alias.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Method/Alias/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Method/Alias
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Method
+@dirrmtry %%SITE_PERL%%/Method