aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-04-18 04:12:48 +0800
committermiwi <miwi@FreeBSD.org>2007-04-18 04:12:48 +0800
commit23a6e8fbd9408cec9a4c7b59497f48eba5d1552e (patch)
tree71a4cc22aedd84bd27105267f7af4da386ba662f /devel
parent9107f58f14526096b2fbbd0006606f99737a98d3 (diff)
downloadfreebsd-ports-gnome-23a6e8fbd9408cec9a4c7b59497f48eba5d1552e.tar.gz
freebsd-ports-gnome-23a6e8fbd9408cec9a4c7b59497f48eba5d1552e.tar.zst
freebsd-ports-gnome-23a6e8fbd9408cec9a4c7b59497f48eba5d1552e.zip
- Update to 4.2
PR: Danny Pansters <danny@ricin.com> (maintainer via privat mail)
Diffstat (limited to 'devel')
-rw-r--r--devel/py-qt4-test/Makefile6
-rw-r--r--devel/py-qt4-test/distinfo6
-rw-r--r--devel/py-qt4-test/files/patch-configure.py63
3 files changed, 51 insertions, 24 deletions
diff --git a/devel/py-qt4-test/Makefile b/devel/py-qt4-test/Makefile
index 52d668709df5..fb368949d479 100644
--- a/devel/py-qt4-test/Makefile
+++ b/devel/py-qt4-test/Makefile
@@ -5,12 +5,12 @@
# $FreeBSD$
PORTNAME= test
-PORTVERSION= 20070318
+PORTVERSION= 4.2
CATEGORIES= devel python
-MASTER_SITES= http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt4/ \
+MASTER_SITES= http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/ \
http://freebsd.ricin.com/ports/distfiles/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
-DISTNAME= PyQt-x11-gpl-4-snapshot-${PORTVERSION}
+DISTNAME= PyQt-x11-gpl-${PORTVERSION}
MAINTAINER= danny@ricin.com
COMMENT= Python bindings for the Qt4 toolkit, QtTest module
diff --git a/devel/py-qt4-test/distinfo b/devel/py-qt4-test/distinfo
index b42fc45ded6f..3317bc659e04 100644
--- a/devel/py-qt4-test/distinfo
+++ b/devel/py-qt4-test/distinfo
@@ -1,3 +1,3 @@
-MD5 (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = 538cd5167ccb14a6b6a3ee687432617a
-SHA256 (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = d98516e20b02194264c199deddda2562845efca64315608522cc05a36c9210c7
-SIZE (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = 1076275
+MD5 (PyQt-x11-gpl-4.2.tar.gz) = af4baa7f7441914f9a527ef3cf788fef
+SHA256 (PyQt-x11-gpl-4.2.tar.gz) = 6fa8a853a66ae500f36629793e7d4c54896c7ccf6337c2b90ea0175b28aa7ae6
+SIZE (PyQt-x11-gpl-4.2.tar.gz) = 5661258
diff --git a/devel/py-qt4-test/files/patch-configure.py b/devel/py-qt4-test/files/patch-configure.py
index b7e848997eda..b6dd30effcfe 100644
--- a/devel/py-qt4-test/files/patch-configure.py
+++ b/devel/py-qt4-test/files/patch-configure.py
@@ -1,6 +1,6 @@
---- configure.py.orig Wed Feb 21 04:39:11 2007
-+++ configure.py Wed Feb 21 18:13:36 2007
-@@ -133,21 +133,21 @@
+--- configure.py.orig Tue Apr 10 17:59:52 2007
++++ configure.py Thu Apr 12 21:51:43 2007
+@@ -138,26 +138,26 @@
}
def check_modules(self):
@@ -20,11 +20,19 @@
check_module("QtTest", "QtTest", "QTest::qSleep(0)")
- check_module("QtXml", "qdom.h", "new QDomDocument()")
- check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
-- check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
-- check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
+ #check_module("QtXml", "qdom.h", "new QDomDocument()")
+ #check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
-+ #check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
+
+- if sipcfg.universal:
+- sipconfig.inform("QtDesigner module disabled with universal binaries")
+- else:
+- check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
++ #if sipcfg.universal:
++ # sipconfig.inform("QtDesigner module disabled with universal binaries")
++ #else:
++ # check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
+
+- check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
+ #check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
- if os.path.isdir("dbus"):
@@ -34,7 +42,7 @@
def code(self):
# Note that the order of the dependent modules is important.
-@@ -201,31 +201,31 @@
+@@ -211,31 +211,31 @@
generate_code("QAxContainer", ["QAxContainer", "QtGui", "QtCore"])
# Generate the consolidated module.
@@ -81,7 +89,7 @@
def qpylibs(self):
# See which QPy libraries to build.
-@@ -278,7 +278,7 @@
+@@ -308,7 +308,7 @@
tool.append("dbus")
# Only include ElementTree for older versions of Python.
@@ -90,7 +98,7 @@
sipconfig.inform("Creating elementtree Makefile...")
makefile = sipconfig.PythonModuleMakefile(
-@@ -309,7 +309,7 @@
+@@ -339,7 +339,7 @@
)
makefile.generate()
@@ -99,7 +107,26 @@
if "QtXml" in pyqt_modules:
sipconfig.inform("Creating pylupdate4 Makefile...")
-@@ -428,7 +428,7 @@
+@@ -376,7 +376,8 @@
+ makefile.generate()
+ tool.append("pyrcc")
+ else:
+- sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
++ #sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
++ pass
+
+ if "QtDesigner" in pyqt_modules:
+ enabled = True
+@@ -460,7 +461,7 @@
+ sipconfig.inform("The Qt mkspecs directory is in %s." % qt_datadir)
+ sipconfig.inform("These PyQt modules will be built: %s." % string.join(pyqt_modules))
+ sipconfig.inform("The PyQt modules will be installed in %s." % opt_pyqtmoddir)
+- sipconfig.inform("The Designer plugin will be installed in %s." % os.path.join(opt_plugindir, "designer"))
++ #sipconfig.inform("The Designer plugin will be installed in %s." % os.path.join(opt_plugindir, "designer"))
+
+ if opt_api:
+ sipconfig.inform("The QScintilla API file will be installed in %s." % os.path.join(opt_qscidir, "api", "python"))
+@@ -470,7 +471,7 @@
sipconfig.inform("The PyQt .sip files will be installed in %s." % opt_pyqtsipdir)
@@ -108,7 +135,7 @@
if opt_vendorcheck:
sipconfig.inform("PyQt will only be usable with signed interpreters.")
-@@ -761,7 +761,8 @@
+@@ -808,7 +809,8 @@
sipfiles = []
for s in glob.glob("sip/" + mname + "/*.sip"):
@@ -118,7 +145,7 @@
installs.append([sipfiles, os.path.join(opt_pyqtsipdir, mname)])
-@@ -825,7 +826,7 @@
+@@ -873,7 +875,7 @@
sipconfig.error("This version of PyQt and the %s edition of Qt have incompatible licenses." % qted)
# Confirm the license.
@@ -127,7 +154,7 @@
print "Type 'L' to view the license."
print "Type 'yes' to accept the terms of the license."
print "Type 'no' to decline the terms of the license."
-@@ -847,7 +848,7 @@
+@@ -895,7 +897,7 @@
if resp == "l":
os.system("more LICENSE")
@@ -136,12 +163,12 @@
# If there should be a license file then check it is where it should be.
if lfile:
if os.access(os.path.join("sip", lfile), os.F_OK):
-@@ -1367,16 +1368,18 @@
- scidir = os.path.join(qt_datadir, "qsci")
+@@ -1434,16 +1436,18 @@
+ installs=[(pyqt.module_installs(), opt_pyqtmoddir)]
- if opt_api or os.path.isdir(scidir):
-- installs.append(("PyQt4.api", os.path.join(scidir, "api", "python")))
-+ installs.append(("QtTest.api", os.path.join(scidir, "api", "python")))
+ if opt_api:
+- installs.append(("PyQt4.api", os.path.join(opt_qscidir, "api", "python")))
++ installs.append(("QtTest.api", os.path.join(opt_qscidir, "api", "python")))
+
+ pyqt_modules = ["QtTest"]