aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorfernape <fernape@FreeBSD.org>2019-01-08 02:51:22 +0800
committerfernape <fernape@FreeBSD.org>2019-01-08 02:51:22 +0800
commit23b10c9c0ba9bbd4ac8f15b313e57537a3981964 (patch)
tree5662475e443b53252e8ad122aa2286654f1339c8 /devel
parente6764f895a45195182a7fbc94aba7a6ad93be2a1 (diff)
downloadfreebsd-ports-gnome-23b10c9c0ba9bbd4ac8f15b313e57537a3981964.tar.gz
freebsd-ports-gnome-23b10c9c0ba9bbd4ac8f15b313e57537a3981964.tar.zst
freebsd-ports-gnome-23b10c9c0ba9bbd4ac8f15b313e57537a3981964.zip
devel/cpptest: update to 2.0.0
* Move to USES_GITHUB * The port now USES autoreconf * Reorder some variables * Bump PORTREVISION for dependent port From the ChangeLog: https://github.com/cpptest/cpptest/blob/2.0.0/NEWS - Move to C++11 (GitHub issue #9): - Replace deprecated auto_ptr by unique_ptr - Remove deprecated dynamic exception specification (e.g. "throw ()") - Note: soname bumped to 1:8:0
Diffstat (limited to 'devel')
-rw-r--r--devel/cpptest/Makefile12
-rw-r--r--devel/cpptest/distinfo5
-rw-r--r--devel/cpptest/pkg-plist4
3 files changed, 13 insertions, 8 deletions
diff --git a/devel/cpptest/Makefile b/devel/cpptest/Makefile
index 7238e6e2c6bd..8d1acc282845 100644
--- a/devel/cpptest/Makefile
+++ b/devel/cpptest/Makefile
@@ -1,19 +1,23 @@
# $FreeBSD$
PORTNAME= cpptest
-PORTVERSION= 1.1.2
+PORTVERSION= 2.0.0
CATEGORIES= devel
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= fernape@FreeBSD.org
COMMENT= Unit testing framework for handling automated tests in C++
LICENSE= LGPL3
+USES= autoreconf gmake libtool pathfix
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix
INSTALL_TARGET= install-strip
-USE_LDCONFIG= yes
MAKE_ARGS= CC=${CC} CCC=${CXX}
+#pre-configure:
+# @cd ${WRKSRC} && ./autogen.sh
+
.include <bsd.port.mk>
diff --git a/devel/cpptest/distinfo b/devel/cpptest/distinfo
index 8dbe781f8235..e64159dd0c19 100644
--- a/devel/cpptest/distinfo
+++ b/devel/cpptest/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cpptest-1.1.2.tar.gz) = 9e4fdf156b709397308536eb6b921e3aea1f463c6613f9a0c1dfec9614386027
-SIZE (cpptest-1.1.2.tar.gz) = 458982
+TIMESTAMP = 1546875145
+SHA256 (cpptest-cpptest-2.0.0_GH0.tar.gz) = 09d35d6ecc0e801925579b18efa0adfaa18e8fed19b2f4f743ec7a53f510e409
+SIZE (cpptest-cpptest-2.0.0_GH0.tar.gz) = 141505
diff --git a/devel/cpptest/pkg-plist b/devel/cpptest/pkg-plist
index 7fbc891cf875..7ba6e1d105d8 100644
--- a/devel/cpptest/pkg-plist
+++ b/devel/cpptest/pkg-plist
@@ -10,6 +10,6 @@ include/cpptest-time.h
include/cpptest.h
lib/libcpptest.a
lib/libcpptest.so
-lib/libcpptest.so.0
-lib/libcpptest.so.0.0.7
+lib/libcpptest.so.1
+lib/libcpptest.so.1.0.8
libdata/pkgconfig/libcpptest.pc