aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-07 17:12:58 +0800
committermarcus <marcus@FreeBSD.org>2003-11-07 17:12:58 +0800
commit264cdcd7a6bead083ad3106f86fb0744dedb57f5 (patch)
tree1a018b24ee2f215bd6917d868f44c8f904dda8bf /devel
parent8ea77b67d66da4a3b085568e881b2aab1f559c32 (diff)
downloadfreebsd-ports-gnome-264cdcd7a6bead083ad3106f86fb0744dedb57f5.tar.gz
freebsd-ports-gnome-264cdcd7a6bead083ad3106f86fb0744dedb57f5.tar.zst
freebsd-ports-gnome-264cdcd7a6bead083ad3106f86fb0744dedb57f5.zip
Use the new Apache bits from bsd.port.mk.
Submitted by: dinoex
Diffstat (limited to 'devel')
-rw-r--r--devel/subversion-devel/Makefile7
-rw-r--r--devel/subversion-freebsd/Makefile7
-rw-r--r--devel/subversion/Makefile7
-rw-r--r--devel/subversion16/Makefile7
4 files changed, 12 insertions, 16 deletions
diff --git a/devel/subversion-devel/Makefile b/devel/subversion-devel/Makefile
index 70f816d31f53..38d186d09a34 100644
--- a/devel/subversion-devel/Makefile
+++ b/devel/subversion-devel/Makefile
@@ -33,7 +33,6 @@ MANCOMPRESSED= no
.include <bsd.port.pre.mk>
SVNREPOS?= /home/svn/repos
-APXS= ${LOCALBASE}/sbin/apxs
.if defined(WITH_MOD_DAV_SVN)
WITH_APACHE2_APR= yes
@@ -48,9 +47,9 @@ SVNGROUP?= svn
.endif
.if defined(WITH_APACHE2_APR)
-APACHE2_PORT?= ${PORTSDIR}/www/apache2
-BUILD_DEPENDS+= ${APXS}:${APACHE2_PORT}
-RUN_DEPENDS+= ${APXS}:${APACHE2_PORT}
+APACHE2_PORT?= www/apache2
+BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE2_PORT}
+RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE2_PORT}
CONFIGURE_ARGS+=--with-apr=${LOCALBASE}/lib/apache2/apr-config \
--with-apr-util=${LOCALBASE}/lib/apache2/apu-config
.else
diff --git a/devel/subversion-freebsd/Makefile b/devel/subversion-freebsd/Makefile
index 70f816d31f53..38d186d09a34 100644
--- a/devel/subversion-freebsd/Makefile
+++ b/devel/subversion-freebsd/Makefile
@@ -33,7 +33,6 @@ MANCOMPRESSED= no
.include <bsd.port.pre.mk>
SVNREPOS?= /home/svn/repos
-APXS= ${LOCALBASE}/sbin/apxs
.if defined(WITH_MOD_DAV_SVN)
WITH_APACHE2_APR= yes
@@ -48,9 +47,9 @@ SVNGROUP?= svn
.endif
.if defined(WITH_APACHE2_APR)
-APACHE2_PORT?= ${PORTSDIR}/www/apache2
-BUILD_DEPENDS+= ${APXS}:${APACHE2_PORT}
-RUN_DEPENDS+= ${APXS}:${APACHE2_PORT}
+APACHE2_PORT?= www/apache2
+BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE2_PORT}
+RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE2_PORT}
CONFIGURE_ARGS+=--with-apr=${LOCALBASE}/lib/apache2/apr-config \
--with-apr-util=${LOCALBASE}/lib/apache2/apu-config
.else
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index 70f816d31f53..38d186d09a34 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -33,7 +33,6 @@ MANCOMPRESSED= no
.include <bsd.port.pre.mk>
SVNREPOS?= /home/svn/repos
-APXS= ${LOCALBASE}/sbin/apxs
.if defined(WITH_MOD_DAV_SVN)
WITH_APACHE2_APR= yes
@@ -48,9 +47,9 @@ SVNGROUP?= svn
.endif
.if defined(WITH_APACHE2_APR)
-APACHE2_PORT?= ${PORTSDIR}/www/apache2
-BUILD_DEPENDS+= ${APXS}:${APACHE2_PORT}
-RUN_DEPENDS+= ${APXS}:${APACHE2_PORT}
+APACHE2_PORT?= www/apache2
+BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE2_PORT}
+RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE2_PORT}
CONFIGURE_ARGS+=--with-apr=${LOCALBASE}/lib/apache2/apr-config \
--with-apr-util=${LOCALBASE}/lib/apache2/apu-config
.else
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index 70f816d31f53..38d186d09a34 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -33,7 +33,6 @@ MANCOMPRESSED= no
.include <bsd.port.pre.mk>
SVNREPOS?= /home/svn/repos
-APXS= ${LOCALBASE}/sbin/apxs
.if defined(WITH_MOD_DAV_SVN)
WITH_APACHE2_APR= yes
@@ -48,9 +47,9 @@ SVNGROUP?= svn
.endif
.if defined(WITH_APACHE2_APR)
-APACHE2_PORT?= ${PORTSDIR}/www/apache2
-BUILD_DEPENDS+= ${APXS}:${APACHE2_PORT}
-RUN_DEPENDS+= ${APXS}:${APACHE2_PORT}
+APACHE2_PORT?= www/apache2
+BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE2_PORT}
+RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE2_PORT}
CONFIGURE_ARGS+=--with-apr=${LOCALBASE}/lib/apache2/apr-config \
--with-apr-util=${LOCALBASE}/lib/apache2/apu-config
.else