aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-10-04 05:55:00 +0800
committerbapt <bapt@FreeBSD.org>2017-10-04 05:55:00 +0800
commit29be6e7a83fca4982bb6f8303226f2c5b0f84e8f (patch)
tree0a15b3cf253014692da1fee382f094d27b910fb4 /devel
parent936d885b57c6a9f2957f51d18a0aff5e72568aa1 (diff)
downloadfreebsd-ports-gnome-29be6e7a83fca4982bb6f8303226f2c5b0f84e8f.tar.gz
freebsd-ports-gnome-29be6e7a83fca4982bb6f8303226f2c5b0f84e8f.tar.zst
freebsd-ports-gnome-29be6e7a83fca4982bb6f8303226f2c5b0f84e8f.zip
Fix configure with clang avoiding nested function
The detection of those issues was made by openbsd people (ajacoutot and rnagy) See http://www.undeadly.org/cgi?action=article;sid=20170930133438 For this port our fix is slightly different than what they did, still the idea is the same Reported by: ajacoutot@openbsd, rnagy@openbsd
Diffstat (limited to 'devel')
-rw-r--r--devel/argp-standalone/Makefile2
-rw-r--r--devel/argp-standalone/files/patch-acinclude.m420
2 files changed, 21 insertions, 1 deletions
diff --git a/devel/argp-standalone/Makefile b/devel/argp-standalone/Makefile
index dfc0c3656c49..044d32015868 100644
--- a/devel/argp-standalone/Makefile
+++ b/devel/argp-standalone/Makefile
@@ -3,7 +3,7 @@
PORTNAME= argp-standalone
PORTVERSION= 1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= http://www.lysator.liu.se/~nisse/misc/ \
LOCAL/sem
diff --git a/devel/argp-standalone/files/patch-acinclude.m4 b/devel/argp-standalone/files/patch-acinclude.m4
new file mode 100644
index 000000000000..bee3da7d2ae5
--- /dev/null
+++ b/devel/argp-standalone/files/patch-acinclude.m4
@@ -0,0 +1,20 @@
+--- acinclude.m4.orig 2004-02-07 17:15:46 UTC
++++ acinclude.m4
+@@ -284,8 +284,6 @@ AC_DEFUN([LSH_GCC_ATTRIBUTES],
+ lsh_cv_c_attribute,
+ [ AC_TRY_COMPILE([
+ #include <stdlib.h>
+-],
+-[
+ static void foo(void) __attribute__ ((noreturn));
+
+ static void __attribute__ ((noreturn))
+@@ -293,6 +291,8 @@ foo(void)
+ {
+ exit(1);
+ }
++],
++[
+ ],
+ lsh_cv_c_attribute=yes,
+ lsh_cv_c_attribute=no)])