aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorKlaus Aehlig <aehlig@linta.de>2021-05-23 02:01:44 +0800
committerNeel Chauhan <nc@FreeBSD.org>2021-05-23 02:01:44 +0800
commit29fd4633f5c7f564719efa54afe46c8c3d8b7026 (patch)
tree4b0cbec715188378b93cf301de30c7926bb18a01 /devel
parentd7635b9294e8edbfbe7edc0c299b50cf7fd29acb (diff)
downloadfreebsd-ports-gnome-29fd4633f5c7f564719efa54afe46c8c3d8b7026.tar.gz
freebsd-ports-gnome-29fd4633f5c7f564719efa54afe46c8c3d8b7026.tar.zst
freebsd-ports-gnome-29fd4633f5c7f564719efa54afe46c8c3d8b7026.zip
devel/bazel: Update to 4.1.0
PR: 256074
Diffstat (limited to 'devel')
-rw-r--r--devel/bazel/Makefile4
-rw-r--r--devel/bazel/distinfo6
-rw-r--r--devel/bazel/files/patch-tools__jdk__default_java_toolchain.bzl12
3 files changed, 12 insertions, 10 deletions
diff --git a/devel/bazel/Makefile b/devel/bazel/Makefile
index 5d582b9433fa..fffa380aa6e7 100644
--- a/devel/bazel/Makefile
+++ b/devel/bazel/Makefile
@@ -1,7 +1,7 @@
# Created by: Klaus Aehlig <aehlig@linta.de>
PORTNAME= bazel
-DISTVERSION= 4.0.0
+DISTVERSION= 4.1.0
CATEGORIES= devel java
MASTER_SITES= https://storage.googleapis.com/bazel/${PORTVERSION}/rc${FINALRC}/
DISTNAME= bazel-${PORTVERSION}rc${FINALRC}-dist
@@ -28,7 +28,7 @@ CONFLICTS_INSTALL= bazel029
# In bazel, a release is always code-wise identical to the final release candidate.
# Hence we can also download that one and so have a simple way to also test earlier release
# candidates.
-FINALRC= 10
+FINALRC= 5
SHEBANG_REGEX= .*(sh|txt|_stub|stub_.*|bazel|get_workspace_status|protobuf_support|_so)
USE_JAVA= yes
diff --git a/devel/bazel/distinfo b/devel/bazel/distinfo
index e890c74b431c..a58b2687fe62 100644
--- a/devel/bazel/distinfo
+++ b/devel/bazel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1610563376
-SHA256 (bazel-4.0.0rc10-dist.zip) = 0c0be85b23dcb83cc42eed0477a765a9de6ba16f85b643ea9e29206767efcd65
-SIZE (bazel-4.0.0rc10-dist.zip) = 274501737
+TIMESTAMP = 1621625779
+SHA256 (bazel-4.1.0rc5-dist.zip) = 11a44e5dcf48307ad1c75de36339541a7b2e49f43407929d0d789eda79f3a6d4
+SIZE (bazel-4.1.0rc5-dist.zip) = 277017508
diff --git a/devel/bazel/files/patch-tools__jdk__default_java_toolchain.bzl b/devel/bazel/files/patch-tools__jdk__default_java_toolchain.bzl
index 70f9eb61ef37..9f6ee5fef2d4 100644
--- a/devel/bazel/files/patch-tools__jdk__default_java_toolchain.bzl
+++ b/devel/bazel/files/patch-tools__jdk__default_java_toolchain.bzl
@@ -1,17 +1,19 @@
--- tools/jdk/default_java_toolchain.bzl.orig 1979-12-31 23:00:00 UTC
+++ tools/jdk/default_java_toolchain.bzl
-@@ -21,25 +21,6 @@ JDK8_JVM_OPTS = [
+@@ -21,27 +21,6 @@ JDK8_JVM_OPTS = [
]
JDK9_JVM_OPTS = [
- # Allow JavaBuilder to access internal javac APIs.
- "--add-exports=jdk.compiler/com.sun.tools.javac.api=ALL-UNNAMED",
-- "--add-exports=jdk.compiler/com.sun.tools.javac.code=ALL-UNNAMED",
-- "--add-exports=jdk.compiler/com.sun.tools.javac.comp=ALL-UNNAMED",
-- "--add-exports=jdk.compiler/com.sun.tools.javac.file=ALL-UNNAMED",
- "--add-exports=jdk.compiler/com.sun.tools.javac.main=ALL-UNNAMED",
+- "--add-exports=jdk.compiler/com.sun.tools.javac.model=ALL-UNNAMED",
+- "--add-exports=jdk.compiler/com.sun.tools.javac.parser=ALL-UNNAMED",
+- "--add-exports=jdk.compiler/com.sun.tools.javac.processing=ALL-UNNAMED",
- "--add-exports=jdk.compiler/com.sun.tools.javac.tree=ALL-UNNAMED",
- "--add-exports=jdk.compiler/com.sun.tools.javac.util=ALL-UNNAMED",
+- "--add-opens=jdk.compiler/com.sun.tools.javac.code=ALL-UNNAMED",
+- "--add-opens=jdk.compiler/com.sun.tools.javac.comp=ALL-UNNAMED",
- "--add-opens=jdk.compiler/com.sun.tools.javac.file=ALL-UNNAMED",
-
- # override the javac in the JDK.
@@ -26,7 +28,7 @@
]
DEFAULT_JAVACOPTS = [
-@@ -63,7 +44,7 @@ DEFAULT_TOOLCHAIN_CONFIGURATION = {
+@@ -67,7 +46,7 @@ DEFAULT_TOOLCHAIN_CONFIGURATION = {
"javac_supports_workers": 1,
"jvm_opts": select({
"@bazel_tools//src/conditions:openbsd": JDK8_JVM_OPTS,