aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-11-02 23:06:44 +0800
committermarino <marino@FreeBSD.org>2014-11-02 23:06:44 +0800
commit2c5b9b80c2b480f81e85d8a9d7dd5bb263637c2b (patch)
treed60a25094326dece25303f9179c20ab69ab375bb /devel
parenta0fb70084d55bc6387c08844d98203482c465dd8 (diff)
downloadfreebsd-ports-gnome-2c5b9b80c2b480f81e85d8a9d7dd5bb263637c2b.tar.gz
freebsd-ports-gnome-2c5b9b80c2b480f81e85d8a9d7dd5bb263637c2b.tar.zst
freebsd-ports-gnome-2c5b9b80c2b480f81e85d8a9d7dd5bb263637c2b.zip
Add new port devel/libsearpc
PR: 193132 Submitted by: JingFeng Yan Searpc is a simple C language RPC framework based on GObject system. Searpc handles the serialization/deserialization part of RPC, the transport part is left to users. The serialization/deserialization uses JSON format via json-glib library. A serialized json object is returned from server to client after executing the RPC function. Each RPC function defined in the server side should take an extra GError argument to report error.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libsearpc/Makefile28
-rw-r--r--devel/libsearpc/distinfo2
-rw-r--r--devel/libsearpc/files/patch-Makefile.am15
-rw-r--r--devel/libsearpc/pkg-descr10
-rw-r--r--devel/libsearpc/pkg-plist22
6 files changed, 78 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ac85006f4fa9..f64bb19f52a5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1127,6 +1127,7 @@
SUBDIR += librevisa-vxi
SUBDIR += libruin
SUBDIR += libs11n
+ SUBDIR += libsearpc
SUBDIR += libserialport
SUBDIR += libserver
SUBDIR += libshbuf
diff --git a/devel/libsearpc/Makefile b/devel/libsearpc/Makefile
new file mode 100644
index 000000000000..04b270d2a586
--- /dev/null
+++ b/devel/libsearpc/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= libsearpc
+PORTVERSION= 3.0.0
+CATEGORIES= devel
+
+MAINTAINER= yan_jingfeng@yahoo.com
+COMMENT= Simple RPC framework based on GObject System in C
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson \
+ libgobject-2.0.so:${PORTSDIR}/devel/glib20
+
+USE_GITHUB= yes
+GH_ACCOUNT= haiwen
+GH_TAGNAME= v3.0-latest
+GH_COMMIT= 8998e7b
+
+USES= autoreconf libtool pathfix pkgconfig python:2
+USE_LDCONFIG= yes
+PATHFIX_MAKEFILEIN= Makefile.am
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/devel/libsearpc/distinfo b/devel/libsearpc/distinfo
new file mode 100644
index 000000000000..1ee2476bffc9
--- /dev/null
+++ b/devel/libsearpc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libsearpc-3.0.0.tar.gz) = cf563519d593be83d05192397ef56b33c6f2c5a105e7d469cc48e465ffdfc010
+SIZE (libsearpc-3.0.0.tar.gz) = 43293
diff --git a/devel/libsearpc/files/patch-Makefile.am b/devel/libsearpc/files/patch-Makefile.am
new file mode 100644
index 000000000000..441909a75e6e
--- /dev/null
+++ b/devel/libsearpc/files/patch-Makefile.am
@@ -0,0 +1,15 @@
+--- Makefile.am.orig 2014-08-14 11:48:58.000000000 -0400
++++ Makefile.am 2014-09-06 03:15:27.906790580 -0400
+@@ -19,11 +19,7 @@
+ SUBDIRS = lib pysearpc ${MAKE_DEMO} tests
+
+ install-data-local:
+-if MACOS
+- sed -i '' -e "s|(DESTDIR)|${DESTDIR}|g" $(pcfiles)
+-else
+- ${SED} -i "s|(DESTDIR)|${DESTDIR}|g" $(pcfiles)
+-endif
++ ${SED} -i '' "s|(DESTDIR)||g" $(pcfiles)
+
+ dist-hook:
+ git log -1 > $(distdir)/latest_commit
diff --git a/devel/libsearpc/pkg-descr b/devel/libsearpc/pkg-descr
new file mode 100644
index 000000000000..ffbe4e0a3dc7
--- /dev/null
+++ b/devel/libsearpc/pkg-descr
@@ -0,0 +1,10 @@
+Searpc is a simple C language RPC framework based on GObject system.
+Searpc handles the serialization/deserialization part of RPC, the
+transport part is left to users.
+
+The serialization/deserialization uses JSON format via json-glib
+library. A serialized json object is returned from server to client
+after executing the RPC function. Each RPC function defined in the
+server side should take an extra GError argument to report error.
+
+WWW: https://github.com/haiwen/libsearpc
diff --git a/devel/libsearpc/pkg-plist b/devel/libsearpc/pkg-plist
new file mode 100644
index 000000000000..d2a9cec6d6d2
--- /dev/null
+++ b/devel/libsearpc/pkg-plist
@@ -0,0 +1,22 @@
+bin/searpc-codegen.py
+include/searpc-client.h
+include/searpc-server.h
+include/searpc-utils.h
+include/searpc.h
+lib/libsearpc.a
+lib/libsearpc.so
+lib/libsearpc.so.1
+lib/libsearpc.so.1.0.2
+%%PYTHON_SITELIBDIR%%/pysearpc/__init__.py
+%%PYTHON_SITELIBDIR%%/pysearpc/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pysearpc/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pysearpc/client.py
+%%PYTHON_SITELIBDIR%%/pysearpc/client.pyc
+%%PYTHON_SITELIBDIR%%/pysearpc/client.pyo
+%%PYTHON_SITELIBDIR%%/pysearpc/common.py
+%%PYTHON_SITELIBDIR%%/pysearpc/common.pyc
+%%PYTHON_SITELIBDIR%%/pysearpc/common.pyo
+%%PYTHON_SITELIBDIR%%/pysearpc/server.py
+%%PYTHON_SITELIBDIR%%/pysearpc/server.pyc
+%%PYTHON_SITELIBDIR%%/pysearpc/server.pyo
+libdata/pkgconfig/libsearpc.pc