aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2008-06-13 00:16:42 +0800
committerbrooks <brooks@FreeBSD.org>2008-06-13 00:16:42 +0800
commit2dfa6e940b0eb3eb1a01b39295f02229bdcb90a3 (patch)
tree6f4077e002730e535b4374370157976e0b7dd81b /devel
parent6cee46f239730025502230b94baaa3bedfdfe9cf (diff)
downloadfreebsd-ports-gnome-2dfa6e940b0eb3eb1a01b39295f02229bdcb90a3.tar.gz
freebsd-ports-gnome-2dfa6e940b0eb3eb1a01b39295f02229bdcb90a3.tar.zst
freebsd-ports-gnome-2dfa6e940b0eb3eb1a01b39295f02229bdcb90a3.zip
Upgrade LLVM to release 2.3.
In theory this should build on every architecture so remove the no-sparc64 bit. Add a MAINTAINER_MODE option to allow debug (very slow) versions to be built and a regression-test target. [1] Submitted by: Pedro Giffuni <pfgshield dash freebsd at yahoo dot com> [1] PR: ports/124068
Diffstat (limited to 'devel')
-rw-r--r--devel/llvm/Makefile35
-rw-r--r--devel/llvm/distinfo6
-rw-r--r--devel/llvm/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp16
-rw-r--r--devel/llvm/pkg-plist53
-rw-r--r--devel/llvm29/Makefile35
-rw-r--r--devel/llvm29/distinfo6
-rw-r--r--devel/llvm29/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp16
-rw-r--r--devel/llvm29/pkg-plist53
8 files changed, 108 insertions, 112 deletions
diff --git a/devel/llvm/Makefile b/devel/llvm/Makefile
index 9f6da8631064..99f01c34d966 100644
--- a/devel/llvm/Makefile
+++ b/devel/llvm/Makefile
@@ -6,37 +6,35 @@
#
PORTNAME= llvm
-PORTVERSION= 2.2
+PORTVERSION= 2.3
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= brooks@FreeBSD.org
COMMENT= Low Level Virtual Machine
+.if defined(MAINTAINER_MODE)
+BUILD_DEPENDS= f2c:${PORTSDIR}/lang/f2c \
+ runtest:${PORTSDIR}/misc/dejagnu
+.endif
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
-USE_GCC= 3.3+
+.if defined(MAINTAINER_MODE)
+CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
+.else
CONFIGURE_FLAGS+= --enable-optimized
+.endif
MAN1= bugpoint.1 llc.1 lli.1 llvm-ar.1 \
llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-db.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
- llvm-prof.1 llvm-ranlib.1 llvm-upgrade.1 \
- llvm2cpp.1 llvmc.1 llvmgcc.1 \
+ llvm-prof.1 llvm-ranlib.1 llvmgcc.1 \
llvmgxx.1 opt.1 stkrc.1 tblgen.1
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64" && ${OSVERSION} >= 700042
-BROKEN= does not build on sparc64
-.endif
-
-.if ${PERL_LEVEL} < 500800
-BROKEN= does not compile with perl ${PERL_VERSION}
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's,\(PROJ_docsdir.*:=\).*$$,\1${DOCSDIR},g' \
${WRKSRC}/Makefile.config.in
@@ -45,7 +43,10 @@ post-patch:
post-install:
@${RM} ${PREFIX}/bin/.dir \
- ${PREFIX}/etc/llvm/.dir \
- ${PREFIX}/lib/.dir
+ ${PREFIX}/lib/.dir
+
+regression-test:
+ (cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check)
+
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/llvm/distinfo b/devel/llvm/distinfo
index 40dd8315677e..af8c72c26da2 100644
--- a/devel/llvm/distinfo
+++ b/devel/llvm/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-2.2.tar.gz) = c16f89f0f28b66db0b776dfb2997cc40
-SHA256 (llvm-2.2.tar.gz) = 788d871aec139e0c61d49533d0252b21c4cd030e91405491ee8cb9b2d0311072
-SIZE (llvm-2.2.tar.gz) = 5702420
+MD5 (llvm-2.3.tar.gz) = 17254d72863b7fa005f3fb327aea3439
+SHA256 (llvm-2.3.tar.gz) = 8214380642684bbe49337728f40ecb945d12abcfd88c4e657c6eb38d6fbb9f93
+SIZE (llvm-2.3.tar.gz) = 5868865
diff --git a/devel/llvm/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp b/devel/llvm/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp
deleted file mode 100644
index a2ea96188a30..000000000000
--- a/devel/llvm/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- lib/Transforms/Scalar/LoopUnroll.cpp.orig
-+++ lib/Transforms/Scalar/LoopUnroll.cpp
-@@ -365,8 +365,9 @@
- // be updated specially after unrolling all the way.
- if (*BB != LatchBlock)
- for (Value::use_iterator UI = (*BB)->use_begin(), UE = (*BB)->use_end();
-- UI != UE; ++UI) {
-+ UI != UE;) {
- Instruction *UseInst = cast<Instruction>(*UI);
-+ ++UI;
- if (isa<PHINode>(UseInst) && !L->contains(UseInst->getParent())) {
- PHINode *phi = cast<PHINode>(UseInst);
- Value *Incoming = phi->getIncomingValueForBlock(*BB);
diff --git a/devel/llvm/pkg-plist b/devel/llvm/pkg-plist
index e8c75d87abb0..5d51aa4ce9e9 100644
--- a/devel/llvm/pkg-plist
+++ b/devel/llvm/pkg-plist
@@ -3,6 +3,7 @@ bin/gccas
bin/gccld
bin/llc
bin/lli
+bin/llvmc2
bin/llvm-ar
bin/llvm-as
bin/llvm-bcanalyzer
@@ -16,22 +17,16 @@ bin/llvm-nm
bin/llvm-prof
bin/llvm-ranlib
bin/llvm-stub
-bin/llvm-upgrade
-bin/llvm2cpp
-bin/llvmc
bin/opt
-etc/llvm/c
-etc/llvm/c++
-etc/llvm/cpp
-etc/llvm/cxx
-etc/llvm/ll
-etc/llvm/st
include/llvm-c/Analysis.h
include/llvm-c/BitReader.h
include/llvm-c/BitWriter.h
include/llvm-c/Core.h
include/llvm-c/ExecutionEngine.h
include/llvm-c/LinkTimeOptimizer.h
+include/llvm-c/Transforms/Scalar.h
+include/llvm-c/Target.h
+include/llvm-c/lto.h
include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
@@ -46,6 +41,7 @@ include/llvm/ADT/HashExtras.h
include/llvm/ADT/ImmutableMap.h
include/llvm/ADT/ImmutableSet.h
include/llvm/ADT/IndexedMap.h
+include/llvm/ADT/IntrusiveRefCntPtr.h
include/llvm/ADT/OwningPtr.h
include/llvm/ADT/PostOrderIterator.h
include/llvm/ADT/SCCIterator.h
@@ -81,6 +77,7 @@ include/llvm/Analysis/FindUsedTypes.h
include/llvm/Analysis/Interval.h
include/llvm/Analysis/IntervalIterator.h
include/llvm/Analysis/IntervalPartition.h
+include/llvm/Analysis/LibCallSemantics.h
include/llvm/Analysis/LoadValueNumbering.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopPass.h
@@ -142,12 +139,14 @@ include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLocation.h
include/llvm/CodeGen/MachineLoopInfo.h
+include/llvm/CodeGen/MachineMemOperand.h
include/llvm/CodeGen/MachineModuleInfo.h
include/llvm/CodeGen/MachineOperand.h
include/llvm/CodeGen/MachinePassRegistry.h
include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/Passes.h
+include/llvm/CodeGen/PseudoSourceValue.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterCoalescer.h
include/llvm/CodeGen/RegisterScavenging.h
@@ -216,6 +215,7 @@ include/llvm/Support/CommandLine.h
include/llvm/Support/Compiler.h
include/llvm/Support/ConstantRange.h
include/llvm/Support/DOTGraphTraits.h
+include/llvm/Support/DataFlow.h
include/llvm/Support/DataTypes.h
include/llvm/Support/Debug.h
include/llvm/Support/Dwarf.h
@@ -224,9 +224,9 @@ include/llvm/Support/ELF.h
include/llvm/Support/FileUtilities.h
include/llvm/Support/GetElementPtrTypeIterator.h
include/llvm/Support/GraphWriter.h
+include/llvm/Support/IRBuilder.h
include/llvm/Support/InstIterator.h
include/llvm/Support/InstVisitor.h
-include/llvm/Support/LLVMBuilder.h
include/llvm/Support/LeakDetector.h
include/llvm/Support/ManagedStatic.h
include/llvm/Support/Mangler.h
@@ -252,7 +252,6 @@ include/llvm/System/DynamicLibrary.h
include/llvm/System/Host.h
include/llvm/System/IncludeFile.h
include/llvm/System/LICENSE.TXT
-include/llvm/System/MappedFile.h
include/llvm/System/Memory.h
include/llvm/System/Mutex.h
include/llvm/System/Path.h
@@ -260,7 +259,6 @@ include/llvm/System/Process.h
include/llvm/System/Program.h
include/llvm/System/Signals.h
include/llvm/System/TimeValue.h
-include/llvm/Target/MRegisterInfo.h
include/llvm/Target/SubtargetFeature.h
include/llvm/Target/TargetAsmInfo.h
include/llvm/Target/TargetData.h
@@ -275,6 +273,7 @@ include/llvm/Target/TargetMachOWriterInfo.h
include/llvm/Target/TargetMachine.h
include/llvm/Target/TargetMachineRegistry.h
include/llvm/Target/TargetOptions.h
+include/llvm/Target/TargetRegisterInfo.h
include/llvm/Target/TargetSubtarget.h
include/llvm/Transforms/IPO.h
include/llvm/Transforms/IPO/InlinerPass.h
@@ -300,6 +299,7 @@ lib/LLVMARM.o
lib/LLVMAlpha.o
lib/LLVMCBackend.o
lib/LLVMCellSPU.o
+lib/LLVMCppBackend.o
lib/LLVMExecutionEngine.o
lib/LLVMHello.a
lib/LLVMHello.la
@@ -331,7 +331,6 @@ lib/libLLVMTarget.a
lib/libLLVMTransformUtils.a
lib/libLLVMipa.a
lib/libLLVMipo.a
-lib/libLLVMlto.a
%%DOCSDIR%%/html.tar.gz
%%DOCSDIR%%/html/AliasAnalysis.html
%%DOCSDIR%%/html/BitCodeFormat.html
@@ -355,9 +354,6 @@ lib/libLLVMlto.a
%%DOCSDIR%%/html/CommandGuide/llvm-nm.html
%%DOCSDIR%%/html/CommandGuide/llvm-prof.html
%%DOCSDIR%%/html/CommandGuide/llvm-ranlib.html
-%%DOCSDIR%%/html/CommandGuide/llvm-upgrade.html
-%%DOCSDIR%%/html/CommandGuide/llvm2cpp.html
-%%DOCSDIR%%/html/CommandGuide/llvmc.html
%%DOCSDIR%%/html/CommandGuide/llvmgcc.html
%%DOCSDIR%%/html/CommandGuide/llvmgxx.html
%%DOCSDIR%%/html/CommandGuide/manpage.css
@@ -371,6 +367,7 @@ lib/libLLVMlto.a
%%DOCSDIR%%/html/ExceptionHandling.html
%%DOCSDIR%%/html/ExtendingLLVM.html
%%DOCSDIR%%/html/FAQ.html
+%%DOCSDIR%%/html/GCCFEBuildInstrs.html
%%DOCSDIR%%/html/GarbageCollection.html
%%DOCSDIR%%/html/GetElementPtr.html
%%DOCSDIR%%/html/GettingStarted.html
@@ -401,6 +398,24 @@ lib/libLLVMlto.a
%%DOCSDIR%%/html/img/venusflytrap.jpg
%%DOCSDIR%%/html/index.html
%%DOCSDIR%%/html/llvm.css
+%%DOCSDIR%%/html/tutorial/JITTutorial1.html
+%%DOCSDIR%%/html/tutorial/JITTutorial2.html
+%%DOCSDIR%%/html/tutorial/LangImpl1.html
+%%DOCSDIR%%/html/tutorial/LangImpl2.html
+%%DOCSDIR%%/html/tutorial/LangImpl3.html
+%%DOCSDIR%%/html/tutorial/LangImpl4.html
+%%DOCSDIR%%/html/tutorial/LangImpl5.html
+%%DOCSDIR%%/html/tutorial/LangImpl6.html
+%%DOCSDIR%%/html/tutorial/LangImpl7.html
+%%DOCSDIR%%/html/tutorial/LangImpl8.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl1.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl2.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl3.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl4.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl5.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl6.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl7.html
+%%DOCSDIR%%/html/tutorial/index.html
%%DOCSDIR%%/ps/bugpoint.ps
%%DOCSDIR%%/ps/llc.ps
%%DOCSDIR%%/ps/lli.ps
@@ -416,9 +431,6 @@ lib/libLLVMlto.a
%%DOCSDIR%%/ps/llvm-nm.ps
%%DOCSDIR%%/ps/llvm-prof.ps
%%DOCSDIR%%/ps/llvm-ranlib.ps
-%%DOCSDIR%%/ps/llvm-upgrade.ps
-%%DOCSDIR%%/ps/llvm2cpp.ps
-%%DOCSDIR%%/ps/llvmc.ps
%%DOCSDIR%%/ps/llvmgcc.ps
%%DOCSDIR%%/ps/llvmgxx.ps
%%DOCSDIR%%/ps/opt.ps
@@ -439,10 +451,11 @@ lib/libLLVMlto.a
@dirrm include/llvm/Analysis
@dirrm include/llvm/ADT
@dirrm include/llvm-c
+@dirrm include/llvm-c/Transforms
@dirrm include/llvm
-@dirrm etc/llvm
@dirrm %%DOCSDIR%%/ps
@dirrm %%DOCSDIR%%/html/img
+@dirrm %%DOCSDIR%%/html/tutorial
@dirrm %%DOCSDIR%%/html/CommandGuide
@dirrm %%DOCSDIR%%/html
@dirrm %%DOCSDIR%%
diff --git a/devel/llvm29/Makefile b/devel/llvm29/Makefile
index 9f6da8631064..99f01c34d966 100644
--- a/devel/llvm29/Makefile
+++ b/devel/llvm29/Makefile
@@ -6,37 +6,35 @@
#
PORTNAME= llvm
-PORTVERSION= 2.2
+PORTVERSION= 2.3
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= brooks@FreeBSD.org
COMMENT= Low Level Virtual Machine
+.if defined(MAINTAINER_MODE)
+BUILD_DEPENDS= f2c:${PORTSDIR}/lang/f2c \
+ runtest:${PORTSDIR}/misc/dejagnu
+.endif
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
-USE_GCC= 3.3+
+.if defined(MAINTAINER_MODE)
+CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
+.else
CONFIGURE_FLAGS+= --enable-optimized
+.endif
MAN1= bugpoint.1 llc.1 lli.1 llvm-ar.1 \
llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-db.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
- llvm-prof.1 llvm-ranlib.1 llvm-upgrade.1 \
- llvm2cpp.1 llvmc.1 llvmgcc.1 \
+ llvm-prof.1 llvm-ranlib.1 llvmgcc.1 \
llvmgxx.1 opt.1 stkrc.1 tblgen.1
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64" && ${OSVERSION} >= 700042
-BROKEN= does not build on sparc64
-.endif
-
-.if ${PERL_LEVEL} < 500800
-BROKEN= does not compile with perl ${PERL_VERSION}
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's,\(PROJ_docsdir.*:=\).*$$,\1${DOCSDIR},g' \
${WRKSRC}/Makefile.config.in
@@ -45,7 +43,10 @@ post-patch:
post-install:
@${RM} ${PREFIX}/bin/.dir \
- ${PREFIX}/etc/llvm/.dir \
- ${PREFIX}/lib/.dir
+ ${PREFIX}/lib/.dir
+
+regression-test:
+ (cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check)
+
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/llvm29/distinfo b/devel/llvm29/distinfo
index 40dd8315677e..af8c72c26da2 100644
--- a/devel/llvm29/distinfo
+++ b/devel/llvm29/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-2.2.tar.gz) = c16f89f0f28b66db0b776dfb2997cc40
-SHA256 (llvm-2.2.tar.gz) = 788d871aec139e0c61d49533d0252b21c4cd030e91405491ee8cb9b2d0311072
-SIZE (llvm-2.2.tar.gz) = 5702420
+MD5 (llvm-2.3.tar.gz) = 17254d72863b7fa005f3fb327aea3439
+SHA256 (llvm-2.3.tar.gz) = 8214380642684bbe49337728f40ecb945d12abcfd88c4e657c6eb38d6fbb9f93
+SIZE (llvm-2.3.tar.gz) = 5868865
diff --git a/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp b/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp
deleted file mode 100644
index a2ea96188a30..000000000000
--- a/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- lib/Transforms/Scalar/LoopUnroll.cpp.orig
-+++ lib/Transforms/Scalar/LoopUnroll.cpp
-@@ -365,8 +365,9 @@
- // be updated specially after unrolling all the way.
- if (*BB != LatchBlock)
- for (Value::use_iterator UI = (*BB)->use_begin(), UE = (*BB)->use_end();
-- UI != UE; ++UI) {
-+ UI != UE;) {
- Instruction *UseInst = cast<Instruction>(*UI);
-+ ++UI;
- if (isa<PHINode>(UseInst) && !L->contains(UseInst->getParent())) {
- PHINode *phi = cast<PHINode>(UseInst);
- Value *Incoming = phi->getIncomingValueForBlock(*BB);
diff --git a/devel/llvm29/pkg-plist b/devel/llvm29/pkg-plist
index e8c75d87abb0..5d51aa4ce9e9 100644
--- a/devel/llvm29/pkg-plist
+++ b/devel/llvm29/pkg-plist
@@ -3,6 +3,7 @@ bin/gccas
bin/gccld
bin/llc
bin/lli
+bin/llvmc2
bin/llvm-ar
bin/llvm-as
bin/llvm-bcanalyzer
@@ -16,22 +17,16 @@ bin/llvm-nm
bin/llvm-prof
bin/llvm-ranlib
bin/llvm-stub
-bin/llvm-upgrade
-bin/llvm2cpp
-bin/llvmc
bin/opt
-etc/llvm/c
-etc/llvm/c++
-etc/llvm/cpp
-etc/llvm/cxx
-etc/llvm/ll
-etc/llvm/st
include/llvm-c/Analysis.h
include/llvm-c/BitReader.h
include/llvm-c/BitWriter.h
include/llvm-c/Core.h
include/llvm-c/ExecutionEngine.h
include/llvm-c/LinkTimeOptimizer.h
+include/llvm-c/Transforms/Scalar.h
+include/llvm-c/Target.h
+include/llvm-c/lto.h
include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
@@ -46,6 +41,7 @@ include/llvm/ADT/HashExtras.h
include/llvm/ADT/ImmutableMap.h
include/llvm/ADT/ImmutableSet.h
include/llvm/ADT/IndexedMap.h
+include/llvm/ADT/IntrusiveRefCntPtr.h
include/llvm/ADT/OwningPtr.h
include/llvm/ADT/PostOrderIterator.h
include/llvm/ADT/SCCIterator.h
@@ -81,6 +77,7 @@ include/llvm/Analysis/FindUsedTypes.h
include/llvm/Analysis/Interval.h
include/llvm/Analysis/IntervalIterator.h
include/llvm/Analysis/IntervalPartition.h
+include/llvm/Analysis/LibCallSemantics.h
include/llvm/Analysis/LoadValueNumbering.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopPass.h
@@ -142,12 +139,14 @@ include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLocation.h
include/llvm/CodeGen/MachineLoopInfo.h
+include/llvm/CodeGen/MachineMemOperand.h
include/llvm/CodeGen/MachineModuleInfo.h
include/llvm/CodeGen/MachineOperand.h
include/llvm/CodeGen/MachinePassRegistry.h
include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/Passes.h
+include/llvm/CodeGen/PseudoSourceValue.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterCoalescer.h
include/llvm/CodeGen/RegisterScavenging.h
@@ -216,6 +215,7 @@ include/llvm/Support/CommandLine.h
include/llvm/Support/Compiler.h
include/llvm/Support/ConstantRange.h
include/llvm/Support/DOTGraphTraits.h
+include/llvm/Support/DataFlow.h
include/llvm/Support/DataTypes.h
include/llvm/Support/Debug.h
include/llvm/Support/Dwarf.h
@@ -224,9 +224,9 @@ include/llvm/Support/ELF.h
include/llvm/Support/FileUtilities.h
include/llvm/Support/GetElementPtrTypeIterator.h
include/llvm/Support/GraphWriter.h
+include/llvm/Support/IRBuilder.h
include/llvm/Support/InstIterator.h
include/llvm/Support/InstVisitor.h
-include/llvm/Support/LLVMBuilder.h
include/llvm/Support/LeakDetector.h
include/llvm/Support/ManagedStatic.h
include/llvm/Support/Mangler.h
@@ -252,7 +252,6 @@ include/llvm/System/DynamicLibrary.h
include/llvm/System/Host.h
include/llvm/System/IncludeFile.h
include/llvm/System/LICENSE.TXT
-include/llvm/System/MappedFile.h
include/llvm/System/Memory.h
include/llvm/System/Mutex.h
include/llvm/System/Path.h
@@ -260,7 +259,6 @@ include/llvm/System/Process.h
include/llvm/System/Program.h
include/llvm/System/Signals.h
include/llvm/System/TimeValue.h
-include/llvm/Target/MRegisterInfo.h
include/llvm/Target/SubtargetFeature.h
include/llvm/Target/TargetAsmInfo.h
include/llvm/Target/TargetData.h
@@ -275,6 +273,7 @@ include/llvm/Target/TargetMachOWriterInfo.h
include/llvm/Target/TargetMachine.h
include/llvm/Target/TargetMachineRegistry.h
include/llvm/Target/TargetOptions.h
+include/llvm/Target/TargetRegisterInfo.h
include/llvm/Target/TargetSubtarget.h
include/llvm/Transforms/IPO.h
include/llvm/Transforms/IPO/InlinerPass.h
@@ -300,6 +299,7 @@ lib/LLVMARM.o
lib/LLVMAlpha.o
lib/LLVMCBackend.o
lib/LLVMCellSPU.o
+lib/LLVMCppBackend.o
lib/LLVMExecutionEngine.o
lib/LLVMHello.a
lib/LLVMHello.la
@@ -331,7 +331,6 @@ lib/libLLVMTarget.a
lib/libLLVMTransformUtils.a
lib/libLLVMipa.a
lib/libLLVMipo.a
-lib/libLLVMlto.a
%%DOCSDIR%%/html.tar.gz
%%DOCSDIR%%/html/AliasAnalysis.html
%%DOCSDIR%%/html/BitCodeFormat.html
@@ -355,9 +354,6 @@ lib/libLLVMlto.a
%%DOCSDIR%%/html/CommandGuide/llvm-nm.html
%%DOCSDIR%%/html/CommandGuide/llvm-prof.html
%%DOCSDIR%%/html/CommandGuide/llvm-ranlib.html
-%%DOCSDIR%%/html/CommandGuide/llvm-upgrade.html
-%%DOCSDIR%%/html/CommandGuide/llvm2cpp.html
-%%DOCSDIR%%/html/CommandGuide/llvmc.html
%%DOCSDIR%%/html/CommandGuide/llvmgcc.html
%%DOCSDIR%%/html/CommandGuide/llvmgxx.html
%%DOCSDIR%%/html/CommandGuide/manpage.css
@@ -371,6 +367,7 @@ lib/libLLVMlto.a
%%DOCSDIR%%/html/ExceptionHandling.html
%%DOCSDIR%%/html/ExtendingLLVM.html
%%DOCSDIR%%/html/FAQ.html
+%%DOCSDIR%%/html/GCCFEBuildInstrs.html
%%DOCSDIR%%/html/GarbageCollection.html
%%DOCSDIR%%/html/GetElementPtr.html
%%DOCSDIR%%/html/GettingStarted.html
@@ -401,6 +398,24 @@ lib/libLLVMlto.a
%%DOCSDIR%%/html/img/venusflytrap.jpg
%%DOCSDIR%%/html/index.html
%%DOCSDIR%%/html/llvm.css
+%%DOCSDIR%%/html/tutorial/JITTutorial1.html
+%%DOCSDIR%%/html/tutorial/JITTutorial2.html
+%%DOCSDIR%%/html/tutorial/LangImpl1.html
+%%DOCSDIR%%/html/tutorial/LangImpl2.html
+%%DOCSDIR%%/html/tutorial/LangImpl3.html
+%%DOCSDIR%%/html/tutorial/LangImpl4.html
+%%DOCSDIR%%/html/tutorial/LangImpl5.html
+%%DOCSDIR%%/html/tutorial/LangImpl6.html
+%%DOCSDIR%%/html/tutorial/LangImpl7.html
+%%DOCSDIR%%/html/tutorial/LangImpl8.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl1.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl2.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl3.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl4.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl5.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl6.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl7.html
+%%DOCSDIR%%/html/tutorial/index.html
%%DOCSDIR%%/ps/bugpoint.ps
%%DOCSDIR%%/ps/llc.ps
%%DOCSDIR%%/ps/lli.ps
@@ -416,9 +431,6 @@ lib/libLLVMlto.a
%%DOCSDIR%%/ps/llvm-nm.ps
%%DOCSDIR%%/ps/llvm-prof.ps
%%DOCSDIR%%/ps/llvm-ranlib.ps
-%%DOCSDIR%%/ps/llvm-upgrade.ps
-%%DOCSDIR%%/ps/llvm2cpp.ps
-%%DOCSDIR%%/ps/llvmc.ps
%%DOCSDIR%%/ps/llvmgcc.ps
%%DOCSDIR%%/ps/llvmgxx.ps
%%DOCSDIR%%/ps/opt.ps
@@ -439,10 +451,11 @@ lib/libLLVMlto.a
@dirrm include/llvm/Analysis
@dirrm include/llvm/ADT
@dirrm include/llvm-c
+@dirrm include/llvm-c/Transforms
@dirrm include/llvm
-@dirrm etc/llvm
@dirrm %%DOCSDIR%%/ps
@dirrm %%DOCSDIR%%/html/img
+@dirrm %%DOCSDIR%%/html/tutorial
@dirrm %%DOCSDIR%%/html/CommandGuide
@dirrm %%DOCSDIR%%/html
@dirrm %%DOCSDIR%%