aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-09-07 23:11:15 +0800
committermiwi <miwi@FreeBSD.org>2007-09-07 23:11:15 +0800
commit2ec2cedcaee171a76577cf6a3de654da7cddddc7 (patch)
treee82ba232c069b17335a3123316fb38796e80ebf5 /devel
parentbee723e96a6294c6351ccc76f07aac3159d8e4ef (diff)
downloadfreebsd-ports-gnome-2ec2cedcaee171a76577cf6a3de654da7cddddc7.tar.gz
freebsd-ports-gnome-2ec2cedcaee171a76577cf6a3de654da7cddddc7.tar.zst
freebsd-ports-gnome-2ec2cedcaee171a76577cf6a3de654da7cddddc7.zip
pty is a tool to help debug console programs which take the terminal out of
canonical mode, by allowing the program being debugged and the debugger to run on separate terminal devices. To use pty, the programmer changes to the terminal device where he or she wishes to interact with the program to be debugged, and at the shell prompt, runs pty with no arguments. Pty will print out the filename of the slave side of the pseudo-terminal it has opened. Inside the debugger, running in another terminal device, one then redirects the program to be debugged's IO to the slave (tty command of gdb). When you are finished using pty, you must manually kill it. When pty starts it prints out its pid. WWW: http://www.mammothcheese.ca/munger.html -- James Bailie <jimmy@mammothcheese.ca> PR: ports/116179 Submitted by: James Bailie <jimmy at mammothcheese.ca>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pty/Makefile18
-rw-r--r--devel/pty/distinfo3
-rw-r--r--devel/pty/pkg-descr17
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e5938da5a6fb..594d1e8b6d37 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1846,6 +1846,7 @@
SUBDIR += pth
SUBDIR += pth-hard
SUBDIR += ptmalloc
+ SUBDIR += pty
SUBDIR += ptypes
SUBDIR += publib
SUBDIR += pushmi
diff --git a/devel/pty/Makefile b/devel/pty/Makefile
new file mode 100644
index 000000000000..77b8fa9cc0e2
--- /dev/null
+++ b/devel/pty/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: pty
+# Date created: Fri, 07 Sep 2007 22:47:06 EDT
+# Whom: James Bailie <jimmy@mammothcheese.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pty
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= http://www.mammothcheese.ca/
+
+MAINTAINER= jimmy@mammothcheese.ca
+COMMENT= helps debug programs which fiddle with their tty settings
+
+PLIST_FILES= bin/pty
+
+.include <bsd.port.mk>
diff --git a/devel/pty/distinfo b/devel/pty/distinfo
new file mode 100644
index 000000000000..5dcd6995b536
--- /dev/null
+++ b/devel/pty/distinfo
@@ -0,0 +1,3 @@
+MD5 (pty-1.0.tar.gz) = fcec8df3c710b73e1569448b07cdcf7c
+SHA256 (pty-1.0.tar.gz) = 964b686867175f05e244233111b633537301265f51588aceb0786207990ff7fa
+SIZE (pty-1.0.tar.gz) = 3861
diff --git a/devel/pty/pkg-descr b/devel/pty/pkg-descr
new file mode 100644
index 000000000000..c896b07233c8
--- /dev/null
+++ b/devel/pty/pkg-descr
@@ -0,0 +1,17 @@
+pty is a tool to help debug console programs which take the terminal out of
+canonical mode, by allowing the program being debugged and the debugger to run
+on separate terminal devices.
+
+To use pty, the programmer changes to the terminal device where he or she
+wishes to interact with the program to be debugged, and at the shell
+prompt, runs pty with no arguments. Pty will print out the filename of the
+slave side of the pseudo-terminal it has opened. Inside the debugger,
+running in another terminal device, one then redirects the program to be
+debugged's IO to the slave (tty command of gdb). When you are finished
+using pty, you must manually kill it. When pty starts it prints out its
+pid.
+
+WWW: http://www.mammothcheese.ca/munger.html
+
+--
+James Bailie <jimmy@mammothcheese.ca>