aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2010-09-11 12:24:31 +0800
committersahil <sahil@FreeBSD.org>2010-09-11 12:24:31 +0800
commit2f62413940b1476a8918b2cae1a63f8111efe9c1 (patch)
tree21f6f5d07bca3cd9c89771d7d403ad19e5c2c921 /devel
parent39e8433f22af3b75728d3f78cc28001e545c1982 (diff)
downloadfreebsd-ports-gnome-2f62413940b1476a8918b2cae1a63f8111efe9c1.tar.gz
freebsd-ports-gnome-2f62413940b1476a8918b2cae1a63f8111efe9c1.tar.zst
freebsd-ports-gnome-2f62413940b1476a8918b2cae1a63f8111efe9c1.zip
Tie::Hash::MultiValue allows you to have hashes which store their values
in anonymous arrays, appending any new value to the already-existing ones. This means that you can store as many items as you like under a single key, and access them all at once by accessing the value stored under the key. WWW: http://search.cpan.org/dist/Tie-Hash-MultiValue/ PR: ports/150473 Submitted by: Frederic Culot <frederic@ culot.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Tie-Hash-MultiValue/Makefile21
-rw-r--r--devel/p5-Tie-Hash-MultiValue/distinfo3
-rw-r--r--devel/p5-Tie-Hash-MultiValue/pkg-descr6
-rw-r--r--devel/p5-Tie-Hash-MultiValue/pkg-plist7
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 54f8a93e4cc1..1a43d84e6a94 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2282,6 +2282,7 @@
SUBDIR += p5-Tie-File-AsHash
SUBDIR += p5-Tie-FileLRUCache
SUBDIR += p5-Tie-Hash-Indexed
+ SUBDIR += p5-Tie-Hash-MultiValue
SUBDIR += p5-Tie-Hash-Regex
SUBDIR += p5-Tie-Hash-Sorted
SUBDIR += p5-Tie-Hash-TwoWay
diff --git a/devel/p5-Tie-Hash-MultiValue/Makefile b/devel/p5-Tie-Hash-MultiValue/Makefile
new file mode 100644
index 000000000000..3a595f7af9d8
--- /dev/null
+++ b/devel/p5-Tie-Hash-MultiValue/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Tie-Hash-MultiValue
+# Date created: 2010-09-10
+# Whom: Frederic Culot <frederic@culot.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-Hash-MultiValue
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= frederic@culot.org
+COMMENT= Store multiple values per key
+
+PERL_CONFIGURE= yes
+
+MAN3= Tie::Hash::MultiValue.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Tie-Hash-MultiValue/distinfo b/devel/p5-Tie-Hash-MultiValue/distinfo
new file mode 100644
index 000000000000..2864044471c0
--- /dev/null
+++ b/devel/p5-Tie-Hash-MultiValue/distinfo
@@ -0,0 +1,3 @@
+MD5 (Tie-Hash-MultiValue-1.02.tar.gz) = 6de9168014c17a4cbe304e4daf6ff794
+SHA256 (Tie-Hash-MultiValue-1.02.tar.gz) = 7f05a9a3f96fb581ef5f37e61d49e648d785e231a4cf2d0f25891c1866dabfc9
+SIZE (Tie-Hash-MultiValue-1.02.tar.gz) = 13564
diff --git a/devel/p5-Tie-Hash-MultiValue/pkg-descr b/devel/p5-Tie-Hash-MultiValue/pkg-descr
new file mode 100644
index 000000000000..911718a9f664
--- /dev/null
+++ b/devel/p5-Tie-Hash-MultiValue/pkg-descr
@@ -0,0 +1,6 @@
+Tie::Hash::MultiValue allows you to have hashes which store their values
+in anonymous arrays, appending any new value to the already-existing ones.
+This means that you can store as many items as you like under a single key,
+and access them all at once by accessing the value stored under the key.
+
+WWW: http://search.cpan.org/dist/Tie-Hash-MultiValue/
diff --git a/devel/p5-Tie-Hash-MultiValue/pkg-plist b/devel/p5-Tie-Hash-MultiValue/pkg-plist
new file mode 100644
index 000000000000..23dbfa9b970d
--- /dev/null
+++ b/devel/p5-Tie-Hash-MultiValue/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Tie/Hash/MultiValue.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Hash/MultiValue/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Hash/MultiValue
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Hash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie
+@dirrmtry %%SITE_PERL%%/Tie/Hash
+@dirrmtry %%SITE_PERL%%/Tie