aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-07-01 17:02:52 +0800
committermiwi <miwi@FreeBSD.org>2009-07-01 17:02:52 +0800
commit2ffc60c4764f1a7eca8c8257d06d9b4f403f7879 (patch)
treec7461e99b96530a23c11b0bed41a85afe3a862ff /devel
parentd75030ead6089b93eba79d9763b441def2745cdb (diff)
downloadfreebsd-ports-gnome-2ffc60c4764f1a7eca8c8257d06d9b4f403f7879.tar.gz
freebsd-ports-gnome-2ffc60c4764f1a7eca8c8257d06d9b4f403f7879.tar.zst
freebsd-ports-gnome-2ffc60c4764f1a7eca8c8257d06d9b4f403f7879.zip
py-AddOn classes are like dynamic mixins, but with their own private attribute
and method namespaces. A concern implemented using add-ons can be added at runtime to any object that either has a writable __dict__ attribute, or is weak-referenceable. AddOn classes are also like adapters, but rather than creating a new instance each time you ask for one, an existing instance is returned if possible. In this way, add-ons can keep track of ongoing state. For example, a Persistence add-on might keep track of whether its subject has been saved to disk. WWW: http://www.python.org/pypi/AddOns PR: ports/135947 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-AddOns/Makefile27
-rw-r--r--devel/py-AddOns/distinfo3
-rw-r--r--devel/py-AddOns/pkg-descr11
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c1171698c6f9..9de0e5e61b63 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2271,6 +2271,7 @@
SUBDIR += publib
SUBDIR += pushmi
SUBDIR += pwlib
+ SUBDIR += py-AddOns
SUBDIR += py-Breve
SUBDIR += py-BytecodeAssembler
SUBDIR += py-EnthoughtBase
diff --git a/devel/py-AddOns/Makefile b/devel/py-AddOns/Makefile
new file mode 100644
index 000000000000..0a0cf5e0f2d2
--- /dev/null
+++ b/devel/py-AddOns/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-AddOns
+# Date created: 23 June, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AddOns
+PORTVERSION= 0.6
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP \
+ http://www.turbogears.org/2.0/downloads/2.0.1/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Dynamically extend other objects with AddOns
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}DecoratorTools>=1.7:${PORTSDIR}/devel/py-decoratortools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+USE_ZIP= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/devel/py-AddOns/distinfo b/devel/py-AddOns/distinfo
new file mode 100644
index 000000000000..48c68425bb79
--- /dev/null
+++ b/devel/py-AddOns/distinfo
@@ -0,0 +1,3 @@
+MD5 (AddOns-0.6.zip) = cce3b98e30aeee7e918649a18ba8f8b7
+SHA256 (AddOns-0.6.zip) = 65999ce99aaf4ba263be3d25f138eab2bd471a74c5f6a1c8022629a149e7099a
+SIZE (AddOns-0.6.zip) = 33893
diff --git a/devel/py-AddOns/pkg-descr b/devel/py-AddOns/pkg-descr
new file mode 100644
index 000000000000..7a88afd1f2b2
--- /dev/null
+++ b/devel/py-AddOns/pkg-descr
@@ -0,0 +1,11 @@
+py-AddOn classes are like dynamic mixins, but with their own private attribute
+and method namespaces. A concern implemented using add-ons can be added at
+runtime to any object that either has a writable __dict__ attribute, or is
+weak-referenceable.
+
+AddOn classes are also like adapters, but rather than creating a new instance
+each time you ask for one, an existing instance is returned if possible. In
+this way, add-ons can keep track of ongoing state. For example, a Persistence
+add-on might keep track of whether its subject has been saved to disk.
+
+WWW: http://www.python.org/pypi/AddOns