aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2013-10-22 03:24:14 +0800
committermi <mi@FreeBSD.org>2013-10-22 03:24:14 +0800
commit3020be3b3e09f0c5b3c7f1a54f3e49ef4c161cad (patch)
tree625b921e2ca17e1246d74134af8bb52d44e58e59 /devel
parentc40fa92be01f1a3638b2d5c8ea5cb2704745d8ff (diff)
downloadfreebsd-ports-gnome-3020be3b3e09f0c5b3c7f1a54f3e49ef4c161cad.tar.gz
freebsd-ports-gnome-3020be3b3e09f0c5b3c7f1a54f3e49ef4c161cad.tar.zst
freebsd-ports-gnome-3020be3b3e09f0c5b3c7f1a54f3e49ef4c161cad.zip
Attempt to unbreak by adding a few patches. The port could stand upgrading
to 1.6.7 (from the current 1.4.8), but that may require cooperation with the other ROS-ports.
Diffstat (limited to 'devel')
-rw-r--r--devel/ros_comm/Makefile9
-rw-r--r--devel/ros_comm/files/patch-TIME_UTC15
-rw-r--r--devel/ros_comm/files/patch-stdarg9
3 files changed, 26 insertions, 7 deletions
diff --git a/devel/ros_comm/Makefile b/devel/ros_comm/Makefile
index caa0a04fb351..7adbc15f2078 100644
--- a/devel/ros_comm/Makefile
+++ b/devel/ros_comm/Makefile
@@ -10,14 +10,9 @@ DIST_SUBDIR= ros
MAINTAINER= ports@FreeBSD.org
COMMENT= Robot Operating System - communication-related utilities
-DEPRECATED= Broken for more than 6 month
-EXPIRATION_DATE= 2013-11-18
+LICENSE= BSD
-#LICENSE= BSD LGPL #which?
-
-BROKEN= does not build
-
-STACKNAME= ${PORTNAME:S/ros-//}
+STACKNAME= ${PORTNAME}
CFLAGS+= -I${LOCALBASE}/include
LIB_DEPENDS= log4cxx.10:${PORTSDIR}/devel/log4cxx
diff --git a/devel/ros_comm/files/patch-TIME_UTC b/devel/ros_comm/files/patch-TIME_UTC
new file mode 100644
index 000000000000..56c7ea526a39
--- /dev/null
+++ b/devel/ros_comm/files/patch-TIME_UTC
@@ -0,0 +1,15 @@
+--- tools/rosbag/src/recorder.cpp 2011-09-02 13:55:20.000000000 -0400
++++ tools/rosbag/src/recorder.cpp 2013-10-21 14:22:48.000000000 -0400
+@@ -437,5 +437,11 @@
+ }
+ boost::xtime xt;
+- boost::xtime_get(&xt, boost::TIME_UTC);
++ boost::xtime_get(&xt, boost::
++#if BOOST_VERSION <= 105200
++ TIME_UTC_
++#else
++ TIME_UTC
++#endif
++ );
+ xt.nsec += 250000000;
+ queue_condition_.timed_wait(lock, xt);
diff --git a/devel/ros_comm/files/patch-stdarg b/devel/ros_comm/files/patch-stdarg
new file mode 100644
index 000000000000..25481408f81a
--- /dev/null
+++ b/devel/ros_comm/files/patch-stdarg
@@ -0,0 +1,9 @@
+--- tools/rosconsole/include/ros/console.h 2011-09-02 13:55:20.000000000 -0400
++++ tools/rosconsole/include/ros/console.h 2013-10-21 14:24:56.000000000 -0400
+@@ -37,4 +37,6 @@
+ #include <ros/time.h>
+
++#include <stdarg.h>
++
+ // TODO: this header is no longer needed to be included here, but removing it will break various code that incorrectly does not itself include log4cxx/logger.h
+ // We should vet all the code using log4cxx directly and make sure the includes/link flags are used in those packages, and then we can remove this include