aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-06-25 22:46:17 +0800
committerkoobs <koobs@FreeBSD.org>2015-06-25 22:46:17 +0800
commit3096e1161441c94b5c7d2eae63b7e74e431a07ca (patch)
tree98d8a68f8dc6604beabc83e46f606cfe6bd0d7e2 /devel
parentd6a4e042eca37df6a96048cee2682fb0610dfedc (diff)
downloadfreebsd-ports-gnome-3096e1161441c94b5c7d2eae63b7e74e431a07ca.tar.gz
freebsd-ports-gnome-3096e1161441c94b5c7d2eae63b7e74e431a07ca.tar.zst
freebsd-ports-gnome-3096e1161441c94b5c7d2eae63b7e74e431a07ca.zip
[NEW] devel/py-python-bugzilla: Bugzilla XMLRPC access module
This is a python module that provides a kinda pythonic interface to Bugzilla over XMLRPC. It was originally written specifically for Red Hat's Bugzilla instance, but it is intended to work with any Bugzilla instance. More usage the better, we would be happy to help get things working with the bugzilla instance you care about. It also includes a `bugzilla` command-line client which can be used for quick, ad-hoc bugzilla jiggery-pokery. WWW: https://fedorahosted.org/python-bugzilla/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-python-bugzilla/Makefile24
-rw-r--r--devel/py-python-bugzilla/distinfo2
-rw-r--r--devel/py-python-bugzilla/pkg-descr12
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4204a3a6fb5a..2a9f4a80701e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4062,6 +4062,7 @@
SUBDIR += py-pytest-runner
SUBDIR += py-pytest-timeout
SUBDIR += py-pytest-xdist
+ SUBDIR += py-python-bugzilla
SUBDIR += py-python-jenkins
SUBDIR += py-python-statsd
SUBDIR += py-python2-pythondialog
diff --git a/devel/py-python-bugzilla/Makefile b/devel/py-python-bugzilla/Makefile
new file mode 100644
index 000000000000..45457199bef4
--- /dev/null
+++ b/devel/py-python-bugzilla/Makefile
@@ -0,0 +1,24 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= python-bugzilla
+PORTVERSION= 1.2.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Bugzilla XMLRPC access module
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests
+
+USES= python zip
+USE_PYTHON= autoplist distutils
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/devel/py-python-bugzilla/distinfo b/devel/py-python-bugzilla/distinfo
new file mode 100644
index 000000000000..5a656926b4fc
--- /dev/null
+++ b/devel/py-python-bugzilla/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-bugzilla-1.2.1.zip) = 70a4da62fe4c90f374a86c5c93bde78bfce264026b709de1560a6984436c2d08
+SIZE (python-bugzilla-1.2.1.zip) = 89674
diff --git a/devel/py-python-bugzilla/pkg-descr b/devel/py-python-bugzilla/pkg-descr
new file mode 100644
index 000000000000..1aae9722563d
--- /dev/null
+++ b/devel/py-python-bugzilla/pkg-descr
@@ -0,0 +1,12 @@
+This is a python module that provides a kinda pythonic interface to Bugzilla
+over XMLRPC.
+
+It was originally written specifically for Red Hat's Bugzilla instance, but
+it is intended to work with any Bugzilla instance. More usage the better, we
+would be happy to help get things working with the bugzilla instance you care
+about.
+
+It also includes a `bugzilla` command-line client which can be used for quick,
+ad-hoc bugzilla jiggery-pokery.
+
+WWW: https://fedorahosted.org/python-bugzilla/