aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2008-04-28 15:23:20 +0800
committerleeym <leeym@FreeBSD.org>2008-04-28 15:23:20 +0800
commit31a139671ca69bd62be5002eac229800029072ee (patch)
treedde5f7ea2735061d8a5fcd0ef35dcd8402fba70f /devel
parent1827eafff156fb38f368204d7eda4cfdc8f9348a (diff)
downloadfreebsd-ports-gnome-31a139671ca69bd62be5002eac229800029072ee.tar.gz
freebsd-ports-gnome-31a139671ca69bd62be5002eac229800029072ee.tar.zst
freebsd-ports-gnome-31a139671ca69bd62be5002eac229800029072ee.zip
- add sdlconsole-2.1
SDL_Console is a drop down console that can be easily added to any SDL application. It is similar to Quake and other games consoles. A console gives you the ability to interact with your program in an easy way by executing predefined commands. You can also have more than one console at a time. WWW: http://wacha.ch/wiki/sdlconsole/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/sdl_console/Makefile32
-rw-r--r--devel/sdl_console/distinfo3
-rw-r--r--devel/sdl_console/pkg-descr7
-rw-r--r--devel/sdl_console/pkg-plist9
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b8412a63d02f..fc4e79feb16a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2289,6 +2289,7 @@
SUBDIR += scons
SUBDIR += scsh-install-lib
SUBDIR += sdl12
+ SUBDIR += sdl_console
SUBDIR += sdl_sge
SUBDIR += sdlmm
SUBDIR += sdts++
diff --git a/devel/sdl_console/Makefile b/devel/sdl_console/Makefile
new file mode 100644
index 000000000000..28d6aadd0b28
--- /dev/null
+++ b/devel/sdl_console/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: SDL Console
+# Date created: 2008-04-27
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl_console
+PORTVERSION= 2.1
+CATEGORIES= devel
+MASTER_SITES= SF
+DISTNAME= sdlconsole-${PORTVERSION}
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A drop down console that can be easily added to any SDL application
+
+USE_SDL= sdl
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+OPTIONS= SDL_IMAGE "SDL Image support" Off
+
+post-patch:
+ @${REINPLACE_CMD} -e '/objformat/s/aout/elf/' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SDL_IMAGE)
+USE_SDL+= image
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/sdl_console/distinfo b/devel/sdl_console/distinfo
new file mode 100644
index 000000000000..0015a1ada35f
--- /dev/null
+++ b/devel/sdl_console/distinfo
@@ -0,0 +1,3 @@
+MD5 (sdlconsole-2.1.tar.gz) = e2936117697a10a17f8e5a58653aed0f
+SHA256 (sdlconsole-2.1.tar.gz) = 08a8c1a4464df978102f0ca42125877dd474001d34566f9cd76e7caccb60382e
+SIZE (sdlconsole-2.1.tar.gz) = 292963
diff --git a/devel/sdl_console/pkg-descr b/devel/sdl_console/pkg-descr
new file mode 100644
index 000000000000..8c8f80d37b25
--- /dev/null
+++ b/devel/sdl_console/pkg-descr
@@ -0,0 +1,7 @@
+SDL_Console is a drop down console that can be easily added to any SDL
+application. It is similar to Quake and other games consoles. A console
+gives you the ability to interact with your program in an easy way by
+executing predefined commands. You can also have more than one console
+at a time.
+
+WWW: http://wacha.ch/wiki/sdlconsole/
diff --git a/devel/sdl_console/pkg-plist b/devel/sdl_console/pkg-plist
new file mode 100644
index 000000000000..d2224e2ebe8f
--- /dev/null
+++ b/devel/sdl_console/pkg-plist
@@ -0,0 +1,9 @@
+include/SDL_console/DT_drawtext.h
+include/SDL_console/SDL_console.h
+include/SDL_console/internal.h
+lib/libSDL_console-2.1.so
+lib/libSDL_console-2.1.so.0
+lib/libSDL_console.a
+lib/libSDL_console.la
+lib/libSDL_console.so
+@dirrmtry include/SDL_console