aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlbr <lbr@FreeBSD.org>2006-05-01 03:52:16 +0800
committerlbr <lbr@FreeBSD.org>2006-05-01 03:52:16 +0800
commit32dd8183fcacfcd5d23409c7869a7a8b80e1d15f (patch)
tree202aa998aa6ef7bc109ab1c4c30fdcbda732670d /devel
parentab555f7a45562a00074dfbedefdccce16d4da21e (diff)
downloadfreebsd-ports-gnome-32dd8183fcacfcd5d23409c7869a7a8b80e1d15f.tar.gz
freebsd-ports-gnome-32dd8183fcacfcd5d23409c7869a7a8b80e1d15f.tar.zst
freebsd-ports-gnome-32dd8183fcacfcd5d23409c7869a7a8b80e1d15f.zip
Add p5-Sub-Install, Install subroutines into packages easily
Approved by: erwin (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sub-Install/Makefile30
-rw-r--r--devel/p5-Sub-Install/distinfo3
-rw-r--r--devel/p5-Sub-Install/pkg-descr5
-rw-r--r--devel/p5-Sub-Install/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1bd50d38d58c..1d080c16cb79 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1201,6 +1201,7 @@
SUBDIR += p5-String-Random
SUBDIR += p5-String-RexxParse
SUBDIR += p5-String-Similarity
+ SUBDIR += p5-Sub-Install
SUBDIR += p5-Sub-Installer
SUBDIR += p5-Sub-Name
SUBDIR += p5-Sub-Override
diff --git a/devel/p5-Sub-Install/Makefile b/devel/p5-Sub-Install/Makefile
new file mode 100644
index 000000000000..71258622e283
--- /dev/null
+++ b/devel/p5-Sub-Install/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: devel/p5-Sub-Install
+# Date created: 30 Apr 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Install
+PORTVERSION= 0.91
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sub
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Install subroutines into packages easily
+
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+
+PERL_CONFIGURE= yes
+
+MAN3= Sub::Install.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Sub-Install/distinfo b/devel/p5-Sub-Install/distinfo
new file mode 100644
index 000000000000..1366e8c14f09
--- /dev/null
+++ b/devel/p5-Sub-Install/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sub-Install-0.91.tar.gz) = c0e7797a63ccd2349d334d540fc10f9b
+SHA256 (Sub-Install-0.91.tar.gz) = 6ed618d13a96dc13697a1e472002caef8b14d9cbab40448cd1c4273a33f5f6d6
+SIZE (Sub-Install-0.91.tar.gz) = 6526
diff --git a/devel/p5-Sub-Install/pkg-descr b/devel/p5-Sub-Install/pkg-descr
new file mode 100644
index 000000000000..94dbc0f91ff0
--- /dev/null
+++ b/devel/p5-Sub-Install/pkg-descr
@@ -0,0 +1,5 @@
+This module makes it easy to install subroutines into packages without
+the unslightly mess of no strict or typeglobs lying about where just
+anyone can see them.
+
+WWW: http://search.cpan.org/dist/Sub-Install/
diff --git a/devel/p5-Sub-Install/pkg-plist b/devel/p5-Sub-Install/pkg-plist
new file mode 100644
index 000000000000..9975ebd8a8b8
--- /dev/null
+++ b/devel/p5-Sub-Install/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Sub/Install.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Install/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Install
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub
+@dirrmtry %%SITE_PERL%%/Sub