aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2018-01-25 19:07:50 +0800
committermartymac <martymac@FreeBSD.org>2018-01-25 19:07:50 +0800
commit34183ec92f0b5dbd858176a8d7a5fb170101d211 (patch)
tree563a40b6ae1519cfbef58e63b360c073f2240e7b /devel
parentf5b40e00d62e1d653598ba2b81a474dae5540cfd (diff)
downloadfreebsd-ports-gnome-34183ec92f0b5dbd858176a8d7a5fb170101d211.tar.gz
freebsd-ports-gnome-34183ec92f0b5dbd858176a8d7a5fb170101d211.tar.zst
freebsd-ports-gnome-34183ec92f0b5dbd858176a8d7a5fb170101d211.zip
Make portlint happier with my ports (reorder variables)
Diffstat (limited to 'devel')
-rw-r--r--devel/raknet/Makefile7
-rw-r--r--devel/simgear/Makefile2
2 files changed, 5 insertions, 4 deletions
diff --git a/devel/raknet/Makefile b/devel/raknet/Makefile
index c4e909a2bf15..51ddb6e3ce1a 100644
--- a/devel/raknet/Makefile
+++ b/devel/raknet/Makefile
@@ -23,17 +23,18 @@ LICENSE_NAME_SpecialAuth= Special authorization from developer
LICENSE_FILE_SpecialAuth= ${FILESDIR}/SpecialAuth.mbox
LICENSE_PERMS_SpecialAuth= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-LEGAL_TEXT= Special authorization granted to distribute version 3.x under GPLv3
-
NOT_FOR_ARCHS= aarch64 mips mips64
NOT_FOR_ARCHS_REASON= fails to compile: error: Add your platform to the list
+LEGAL_TEXT= Special authorization granted to distribute version 3.x under GPLv3
+
NO_WRKSUBDIR= yes
+USES= dos2unix cmake zip
+
USE_LDCONFIG= yes
USE_GCC= any
-USES= dos2unix cmake zip
DOS2UNIX_REGEX= .*\.(cpp|h|txt)
# XXX Do not provide Samples for the following reason :
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 60205b1ed74a..f5a9a078a791 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -16,9 +16,9 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libosg.so:graphics/osg
+USES= alias cmake compiler:c++11-lib cpe jpeg openal:al,alut tar:bzip2
USE_XORG= ice sm x11 xext xi xmu xt
USE_GL= gl glu glut
-USES= alias cmake compiler:c++11-lib cpe jpeg openal:al,alut tar:bzip2
.include <bsd.port.pre.mk>