aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2013-10-10 08:58:16 +0800
committerjhale <jhale@FreeBSD.org>2013-10-10 08:58:16 +0800
commit345cdd322b2e1e2da952a0281ea4322968816e5a (patch)
treeea4dadeee93879945805ae3c93015dc5a0a04cee /devel
parentfbf2a19484c732287d95d26b98f705b05a5ebd13 (diff)
downloadfreebsd-ports-gnome-345cdd322b2e1e2da952a0281ea4322968816e5a.tar.gz
freebsd-ports-gnome-345cdd322b2e1e2da952a0281ea4322968816e5a.tar.zst
freebsd-ports-gnome-345cdd322b2e1e2da952a0281ea4322968816e5a.zip
- Support staging
- Use new LIB_DEPENDS syntax - Use options helpers
Diffstat (limited to 'devel')
-rw-r--r--devel/gwenhywfar-fox16/Makefile1
-rw-r--r--devel/gwenhywfar-gtk2/Makefile1
-rw-r--r--devel/gwenhywfar-qt4/Makefile1
-rw-r--r--devel/gwenhywfar/Makefile44
4 files changed, 19 insertions, 28 deletions
diff --git a/devel/gwenhywfar-fox16/Makefile b/devel/gwenhywfar-fox16/Makefile
index 147ba296858e..623fee02d69a 100644
--- a/devel/gwenhywfar-fox16/Makefile
+++ b/devel/gwenhywfar-fox16/Makefile
@@ -10,5 +10,4 @@ MASTERDIR= ${.CURDIR}/../../devel/gwenhywfar
SLAVEPORT= fox16
PLIST= ${.CURDIR}/pkg-plist
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/devel/gwenhywfar-gtk2/Makefile b/devel/gwenhywfar-gtk2/Makefile
index a5bc7f4e7a2b..2a0604b92ac2 100644
--- a/devel/gwenhywfar-gtk2/Makefile
+++ b/devel/gwenhywfar-gtk2/Makefile
@@ -10,5 +10,4 @@ MASTERDIR= ${.CURDIR}/../../devel/gwenhywfar
SLAVEPORT= gtk2
PLIST= ${.CURDIR}/pkg-plist
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/devel/gwenhywfar-qt4/Makefile b/devel/gwenhywfar-qt4/Makefile
index a0d182c7ed96..5083f5c8c5f3 100644
--- a/devel/gwenhywfar-qt4/Makefile
+++ b/devel/gwenhywfar-qt4/Makefile
@@ -10,5 +10,4 @@ MASTERDIR= ${.CURDIR}/../../devel/gwenhywfar
SLAVEPORT= qt4
PLIST= ${.CURDIR}/pkg-plist
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/devel/gwenhywfar/Makefile b/devel/gwenhywfar/Makefile
index 92a403ca3942..4bb1be81693d 100644
--- a/devel/gwenhywfar/Makefile
+++ b/devel/gwenhywfar/Makefile
@@ -11,14 +11,8 @@ COMMENT?= Multi-platform helper library for networking and security applications
LICENSE= LGPL21
-LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
- gnutls:${PORTSDIR}/security/gnutls
-
-.if !defined(SLAVEPORT)
-OPTIONS_DEFINE= DOXYGEN MEMDEBUG
-
-MEMDEBUG_DESC= Enable memory debugger statistic
-.endif
+LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgnutls.so:${PORTSDIR}/security/gnutls
USES= pathfix pkgconfig gettext gmake
USE_OPENSSL= yes
@@ -34,26 +28,26 @@ USE_LDCONFIG= yes
GWEN_SHLIB_VER= 60
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+.if !defined(SLAVEPORT)
+OPTIONS_DEFINE= DOXYGEN MEMDEBUG
-.if ${PORT_OPTIONS:MDOXYGEN}
-BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
- dot:${PORTSDIR}/graphics/graphviz
-CONFIGURE_ARGS+=--enable-full-doc
-.endif
+DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen \
+ dot:${PORTSDIR}/graphics/graphviz
+DOXYGEN_CONFIGURE_ENABLE= full-doc
-.if ${PORT_OPTIONS:MMEMDEBUG}
-CONFIGURE_ARGS+=--enable-memtrace
+MEMDEBUG_DESC= Enable memory debugger statistic
+MEMDEBUG_CONFIGURE_ENABLE= memtrace
.endif
+.include <bsd.port.options.mk>
+
.if defined(SLAVEPORT)
-LIB_DEPENDS+= gwenhywfar:${PORTSDIR}/devel/gwenhywfar
+LIB_DEPENDS+= libgwenhywfar.so:${PORTSDIR}/devel/gwenhywfar
BUILD_WRKSRC= ${WRKSRC}/gui
INSTALL_WRKSRC= ${WRKSRC}/gui/${SLAVEPORT}
.if ${SLAVEPORT}=="fox16"
-LIB_DEPENDS+= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16
+LIB_DEPENDS+= libFOX-1.6.so:${PORTSDIR}/x11-toolkits/fox16
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.endif
@@ -81,13 +75,13 @@ post-build:
post-install:
.if ${PORT_OPTIONS:MDOXYGEN}
- ${MKDIR} ${DOCSDIR}/apidoc
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/apidoc
cd ${WRKSRC}/apidoc && \
- ${COPYTREE_SHARE} \* ${DOCSDIR}/apidoc
- @${FIND} -P ${DOCSDIR} -type f 2>/dev/null | \
- ${SED} -ne 's,^${PREFIX}/,,p' >> ${TMPPLIST}
- @${FIND} -P -d ${DOCSDIR} -type d 2>/dev/null | \
- ${SED} -ne 's,^${PREFIX}/,@dirrm ,p' >> ${TMPPLIST}
+ ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}/apidoc
+ @${FIND} -P ${STAGEDIR}${DOCSDIR} -type f 2>/dev/null | \
+ ${SED} -ne 's|^${STAGEDIR}${PREFIX}/||p' >> ${TMPPLIST}
+ @${FIND} -P -d ${STAGEDIR}${DOCSDIR} -type d 2>/dev/null | \
+ ${SED} -ne 's|^${STAGEDIR}${PREFIX}/|@dirrm |p' >> ${TMPPLIST}
.endif
.include <bsd.port.mk>