aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-09-23 21:11:28 +0800
committermnag <mnag@FreeBSD.org>2005-09-23 21:11:28 +0800
commit34883e47eb0740928785929f829bd8758d30d222 (patch)
tree86fdb76015cf1cc0b30482aef832a8026842b7cc /devel
parentb3f8c70ceffd713c6f5c6939767892b1c68daa69 (diff)
downloadfreebsd-ports-gnome-34883e47eb0740928785929f829bd8758d30d222.tar.gz
freebsd-ports-gnome-34883e47eb0740928785929f829bd8758d30d222.tar.zst
freebsd-ports-gnome-34883e47eb0740928785929f829bd8758d30d222.zip
New port
"Minimal perfect hashing code generator" PR: ports/86479 Submitted by: Charles Swiger <chuck@pkix.net> Approved by: pav (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/mph/Makefile25
-rw-r--r--devel/mph/distinfo2
-rw-r--r--devel/mph/pkg-descr9
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 44a92cd215fc..365004af19bd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -598,6 +598,7 @@
SUBDIR += monotone
SUBDIR += motor
SUBDIR += mpatrol
+ SUBDIR += mph
SUBDIR += mprof
SUBDIR += msp430-binutils
SUBDIR += msp430-gcc
diff --git a/devel/mph/Makefile b/devel/mph/Makefile
new file mode 100644
index 000000000000..2f94238c4000
--- /dev/null
+++ b/devel/mph/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mph
+# Date created: 2005/9/22
+# Whom: Chuck Swiger <chuck@pkix.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mph
+PORTVERSION= 1.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= devel/lang/c
+
+MAINTAINER= chuck@pkix.net
+COMMENT= Minimal perfect hashing code generator
+
+BIN_FILES= emitc mph mphm
+PLIST_FILES= bin/emitc bin/mph bin/mphm
+
+do-install:
+.for i in ${BIN_FILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/bin/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/mph/distinfo b/devel/mph/distinfo
new file mode 100644
index 000000000000..57d5e6c2a0f3
--- /dev/null
+++ b/devel/mph/distinfo
@@ -0,0 +1,2 @@
+MD5 (mph-1.2.tar.gz) = 7ec447ccf11c40246d238b00a9dbb922
+SIZE (mph-1.2.tar.gz) = 22762
diff --git a/devel/mph/pkg-descr b/devel/mph/pkg-descr
new file mode 100644
index 000000000000..7cb19e4f8449
--- /dev/null
+++ b/devel/mph/pkg-descr
@@ -0,0 +1,9 @@
+The program mph tries to generate an order preserving minimal perfect
+hashing (MPH) function for the set of keys, one per line, on stdin.
+Each key can be at most 4095 characters long (see keys.h to increase
+this limit), and the keys must be unique. If mph terminates, it emits
+a language independent binary or text representation of the MPH
+function on stdout. To generate a usable hash function, this output
+should be fed to a language dependent filter, like emitc.
+
+WWW: http://www.ibiblio.org/pub/Linux/devel/lang/c