aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-01-15 06:29:30 +0800
committerpav <pav@FreeBSD.org>2006-01-15 06:29:30 +0800
commit35400ae251f892d3dfcf6a28c927b43d853f2807 (patch)
tree7c1629d22afd2ff84e4f42040de05a435f920d2d /devel
parenta105a15fdb74a8675f0f4effd8a931356345fee6 (diff)
downloadfreebsd-ports-gnome-35400ae251f892d3dfcf6a28c927b43d853f2807.tar.gz
freebsd-ports-gnome-35400ae251f892d3dfcf6a28c927b43d853f2807.tar.zst
freebsd-ports-gnome-35400ae251f892d3dfcf6a28c927b43d853f2807.zip
json-py is a simple, pure-python implementation of a JSON (http://json.org)
reader and writer. JSON is used to exchange data across systems written in various languages. It is particularly suited to dynamic languages like Python, Javascript, etc. JSON = Javascript Object Notation implies it is suitable for AJAX applications that exchange data from servers to Javascript applications running on web browser clients. Author: <patrickdlogan@stardecisions.com> WWW: http://sourceforge.net/projects/json-py/ PR: ports/91688 Submitted by: Nicola Vitale <nivit@email.it>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-json-py/Makefile37
-rw-r--r--devel/py-json-py/distinfo3
-rw-r--r--devel/py-json-py/pkg-descr9
-rw-r--r--devel/py-json-py/pkg-plist7
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f7cc45d58308..4bfce1a0f26c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1401,6 +1401,7 @@
SUBDIR += py-icalendar
SUBDIR += py-ice
SUBDIR += py-istring
+ SUBDIR += py-json-py
SUBDIR += py-kid
SUBDIR += py-kjbuckets
SUBDIR += py-kqueue
diff --git a/devel/py-json-py/Makefile b/devel/py-json-py/Makefile
new file mode 100644
index 000000000000..10eabf904261
--- /dev/null
+++ b/devel/py-json-py/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: py-json-py
+# Date created: 2006-01-11
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= json-py
+PORTVERSION= 3.4
+CATEGORIES= devel lang www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/}
+EXTRACT_SUFX= .zip
+
+MAINTAINER= nivit@email.it
+COMMENT= A python implementation of a JSON (http//:json.org) reader/writer
+
+NO_WRKSUBDIR= yes
+
+USE_PYTHON= 2.4
+USE_ZIP= yes
+
+do-build:
+ # compile python files
+ cd ${WRKDIR}; \
+ FILES=$$(${FIND} . -name "*.py" ); \
+ for FILE in $${FILES}; do \
+ ${ECHO} import `basename $${FILE} .py` | python; \
+ done; \
+
+do-install:
+ @cd ${WRKDIR}; \
+ ${FIND} . \( -name "*.py" -or -name "*.pyc" \) -exec ${INSTALL_SCRIPT} \{\} ${PYTHON_SITELIBDIR} \;
+
+.include <bsd.port.mk>
diff --git a/devel/py-json-py/distinfo b/devel/py-json-py/distinfo
new file mode 100644
index 000000000000..076e14e88642
--- /dev/null
+++ b/devel/py-json-py/distinfo
@@ -0,0 +1,3 @@
+MD5 (json-py-3_4.zip) = 921ebfede886a10ff32d6d4b4e216f8f
+SHA256 (json-py-3_4.zip) = 58da8ae96c973302e3cfc4c682d20d1a5c6a6284426a269bf2c3dc4b58a522a9
+SIZE (json-py-3_4.zip) = 20111
diff --git a/devel/py-json-py/pkg-descr b/devel/py-json-py/pkg-descr
new file mode 100644
index 000000000000..3bd1ca6a3750
--- /dev/null
+++ b/devel/py-json-py/pkg-descr
@@ -0,0 +1,9 @@
+json-py is a simple, pure-python implementation of a JSON (http://json.org)
+reader and writer. JSON is used to exchange data across systems written in
+various languages. It is particularly suited to dynamic languages like Python,
+Javascript, etc. JSON = Javascript Object Notation implies it is suitable for
+AJAX applications that exchange data from servers to Javascript applications
+running on web browser clients.
+
+Author: <patrickdlogan@stardecisions.com>
+WWW: http://sourceforge.net/projects/json-py/
diff --git a/devel/py-json-py/pkg-plist b/devel/py-json-py/pkg-plist
new file mode 100644
index 000000000000..9cc1ffe73a30
--- /dev/null
+++ b/devel/py-json-py/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/json.py
+%%PYTHON_SITELIBDIR%%/json.pyc
+%%PYTHON_SITELIBDIR%%/jsontest.py
+%%PYTHON_SITELIBDIR%%/jsontest.pyc
+%%PYTHON_SITELIBDIR%%/minjson.py
+%%PYTHON_SITELIBDIR%%/minjson.pyc