aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2016-12-23 08:41:12 +0800
committerbrooks <brooks@FreeBSD.org>2016-12-23 08:41:12 +0800
commit35a648d31b6a3605887d7b7201808a658f0b1f74 (patch)
tree8b041b478fb7e80a5d00dde0595df6fb67f8763b /devel
parentf36d3a00ae14e1b4f8e3c36a12405bfbff76afca (diff)
downloadfreebsd-ports-gnome-35a648d31b6a3605887d7b7201808a658f0b1f74.tar.gz
freebsd-ports-gnome-35a648d31b6a3605887d7b7201808a658f0b1f74.tar.zst
freebsd-ports-gnome-35a648d31b6a3605887d7b7201808a658f0b1f74.zip
Disable LLVM_LINK_LLVM_DYLIB for now.
The resulting llvm-nm binary has a command line parsing bug and is unusable which breaks chromium builds. Reported by: cpm
Diffstat (limited to 'devel')
-rw-r--r--devel/llvm39/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/llvm39/Makefile b/devel/llvm39/Makefile
index 1407e3231a46..16b237d0821f 100644
--- a/devel/llvm39/Makefile
+++ b/devel/llvm39/Makefile
@@ -2,6 +2,7 @@
PORTNAME= llvm
DISTVERSION= 3.9.1
+PORTREVISION= 1
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/${PRE_}releases/${LLVM_RELEASE}/${RCDIR}
PKGNAMESUFFIX= ${LLVM_SUFFIX}
@@ -37,7 +38,7 @@ SUB_FILES= llvm-wrapper.sh
SUB_LIST= LLVM_PREFIX="${LLVM_PREFIX}" LLVM_SUFFIX="${LLVM_SUFFIX}"
CMAKE_INSTALL_PREFIX= ${LLVM_PREFIX}
-CMAKE_ARGS= -DLLVM_BUILD_LLVM_DYLIB=ON -DLLVM_LINK_LLVM_DYLIB=ON
+CMAKE_ARGS= -DLLVM_BUILD_LLVM_DYLIB=ON
# Following commit https://github.com/kitware/cmake/commit/956054
# we need to either change the whole man-shuffle below, or simply
# redefine CMAKE_INSTALL_MANDIR