aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2006-02-01 04:56:24 +0800
committernetchild <netchild@FreeBSD.org>2006-02-01 04:56:24 +0800
commit3607f30859038034c63def862089507562d50529 (patch)
tree6b64a7f0c37ee53242765d81321f48251f8de752 /devel
parentc13a5f0e34c6a8216fd8f4dbe4ca92ba70618261 (diff)
downloadfreebsd-ports-gnome-3607f30859038034c63def862089507562d50529.tar.gz
freebsd-ports-gnome-3607f30859038034c63def862089507562d50529.tar.zst
freebsd-ports-gnome-3607f30859038034c63def862089507562d50529.zip
After repocopy from devel/pwlib:
- fix PORTNAME - remove PORTEPOCH - "chase" expat libversion bump (marcus won the race ;-) ) - use current autoconf (259) [1] - add patch to play nice (in preparation for the update of devel/pwlib) [1] PR: 83396 (parts of) [1] Submitted by: Steve Ames <steve@energistic.com> [1] Repocopy by: marcus
Diffstat (limited to 'devel')
-rw-r--r--devel/pwlib152/Makefile12
-rw-r--r--devel/pwlib152/files/patch-make-ptbuildopts.mak.in14
2 files changed, 20 insertions, 6 deletions
diff --git a/devel/pwlib152/Makefile b/devel/pwlib152/Makefile
index f9bee15d41c6..d8bb3569a939 100644
--- a/devel/pwlib152/Makefile
+++ b/devel/pwlib152/Makefile
@@ -5,26 +5,26 @@
# $FreeBSD$
#
-PORTNAME= pwlib
+PORTNAME= pwlib152
PORTVERSION= 1.5.2
-PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
http://www.gnomemeeting.org/downloads/0.98.0/sources/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+DISTNAME= ${NAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A cross platform C++ library, used by OpenH323
-LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${NAME}
+NAME= pwlib
USE_BISON= yes
USE_GMAKE= yes
USE_OPENLDAP= yes
-USE_AUTOTOOLS= autoconf:253
+USE_AUTOTOOLS= autoconf:259
CONFIGURE_ENV= OSRELEASE=${OSVERSION}
ALL_TARGET= optnoshared
MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib
diff --git a/devel/pwlib152/files/patch-make-ptbuildopts.mak.in b/devel/pwlib152/files/patch-make-ptbuildopts.mak.in
new file mode 100644
index 000000000000..0091a706d0c8
--- /dev/null
+++ b/devel/pwlib152/files/patch-make-ptbuildopts.mak.in
@@ -0,0 +1,14 @@
+--- make/ptbuildopts.mak.in.orig Thu Jul 7 14:17:24 2005
++++ make/ptbuildopts.mak.in Thu Jul 7 14:15:47 2005
+@@ -9,6 +9,11 @@
+ OSTYPE = @OSTYPE@
+ OSRELEASE = @OSRELEASE@
+
++# This line makes this port of pwlib play well with others... otherwise
++# /usr/local/include gets inserted first and causes the inclusion of
++# files from different versions of pwlib
++STDCCFLAGS += -I@PWLIBDIR@/include/ptlib/unix -I@PWLIBDIR@/include
++
+ STDCCFLAGS += @STDCCFLAGS@
+ OPTSTDCCFLAGS += @OPTSTDCCFLAGS@
+ LDFLAGS += @LDFLAGS@