aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-03-23 22:46:05 +0800
committermat <mat@FreeBSD.org>2016-03-23 22:46:05 +0800
commit361905799035a27bf0b215d9b6dc508a3b490d3c (patch)
tree3154bbde91feb3fa7763e15fe5bfd1501421960e /devel
parent04e8359c1a7bfe62884cd094eeb7e05996e7381e (diff)
downloadfreebsd-ports-gnome-361905799035a27bf0b215d9b6dc508a3b490d3c.tar.gz
freebsd-ports-gnome-361905799035a27bf0b215d9b6dc508a3b490d3c.tar.zst
freebsd-ports-gnome-361905799035a27bf0b215d9b6dc508a3b490d3c.zip
This builds fine on 9 with OpenSSL from ports with clang.
Sponsored by: Absolight
Diffstat (limited to 'devel')
-rw-r--r--devel/thrift-cpp/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index 7a425249a104..62fcb49c2e9e 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -18,11 +18,12 @@ DISTINFO_FILE= ${.CURDIR}/../thrift/distinfo
LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
libevent.so:${PORTSDIR}/devel/libevent2
-USES= autoreconf pkgconfig gmake compiler libtool
+USES= autoreconf pkgconfig gmake compiler:c++11-lang libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
PLIST_SUB= PORTVERSION="${THRIFT_PORTVERSION}"
+USE_OPENSSL= yes
OPTIONS_DEFINE= QT4
QT4_CONFIGURE_WITH= qt4
@@ -44,11 +45,14 @@ CONFIGURE_ARGS+= \
--without-ruby \
--without-go
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_OPENSSL_PORT) && \
+ ${OPSYS} == FreeBSD && ${OSVERSION} < 1000015
# src/thrift/transport/TSSLSocket.cpp:147: error: 'TLSv1_1_method' was not declared in this scope
# src/thrift/transport/TSSLSocket.cpp:149: error: 'TLSv1_2_method' was not declared in this scope
-BROKEN_FreeBSD_9= does not build with 9.x base OpenSSL
-
-.include <bsd.port.pre.mk>
+BROKEN= does not build with 9.x base OpenSSL
+.endif
.if ${COMPILER_TYPE} == clang
USE_CXXSTD= c++11