aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-10-07 16:40:06 +0800
committermiwi <miwi@FreeBSD.org>2006-10-07 16:40:06 +0800
commit36a28039da902b6ccde92d5be612b1b10c92ffe5 (patch)
treef4e0c06601980a2597c6cae32836d1b8386a5375 /devel
parent33c5376f6d90b917fd7dcccec78821dab2be175f (diff)
downloadfreebsd-ports-gnome-36a28039da902b6ccde92d5be612b1b10c92ffe5.tar.gz
freebsd-ports-gnome-36a28039da902b6ccde92d5be612b1b10c92ffe5.tar.zst
freebsd-ports-gnome-36a28039da902b6ccde92d5be612b1b10c92ffe5.zip
- Fixed bug in RTPIPv6Destination
PR: ports/103704 Submitted by: Yi-Huan Chan <yhchan@csie.nctu.edu.tw> Approved by: Petr Holub <hopet@ics.muni.cz> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/jrtplib/Makefile2
-rw-r--r--devel/jrtplib/files/patch-src-rtpipv6destination.h15
2 files changed, 16 insertions, 1 deletions
diff --git a/devel/jrtplib/Makefile b/devel/jrtplib/Makefile
index fd1bfc0c15ab..182561ad5be6 100644
--- a/devel/jrtplib/Makefile
+++ b/devel/jrtplib/Makefile
@@ -15,7 +15,7 @@ COMMENT= Object-oriented RTP library written in C++
GNU_CONFIGURE= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
NO_FILTER_SHLIBS= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-jthread
diff --git a/devel/jrtplib/files/patch-src-rtpipv6destination.h b/devel/jrtplib/files/patch-src-rtpipv6destination.h
new file mode 100644
index 000000000000..d9ecaf3790e0
--- /dev/null
+++ b/devel/jrtplib/files/patch-src-rtpipv6destination.h
@@ -0,0 +1,15 @@
+--- src/rtpipv6destination.h.orig Tue Sep 26 22:12:59 2006
++++ src/rtpipv6destination.h Tue Sep 26 22:13:16 2006
+@@ -65,9 +65,9 @@
+ rtpaddr.sin6_family = AF_INET6;
+ rtpaddr.sin6_port = htons(portbase);
+ rtpaddr.sin6_addr = ip;
+- rtpaddr.sin6_family = AF_INET6;
+- rtpaddr.sin6_port = htons(portbase+1);
+- rtpaddr.sin6_addr = ip;
++ rtcpaddr.sin6_family = AF_INET6;
++ rtcpaddr.sin6_port = htons(portbase+1);
++ rtcpaddr.sin6_addr = ip;
+ }
+ in6_addr GetIP() const { return rtpaddr.sin6_addr; }
+ bool operator==(const RTPIPv6Destination &src) const