aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-09-10 00:04:04 +0800
committerjylefort <jylefort@FreeBSD.org>2005-09-10 00:04:04 +0800
commit3a9fdef5f69cda441e4be818a049308fd37db183 (patch)
treeade56567efcf7b2f71fa19c54d1135d7c555f69a /devel
parent53b0f63bcb21c6db87a06fdf596e40c0fe7269ed (diff)
downloadfreebsd-ports-gnome-3a9fdef5f69cda441e4be818a049308fd37db183.tar.gz
freebsd-ports-gnome-3a9fdef5f69cda441e4be818a049308fd37db183.tar.zst
freebsd-ports-gnome-3a9fdef5f69cda441e4be818a049308fd37db183.zip
Fix file descriptor and memory leaks in bonobo-activation.
Reported by: pav
Diffstat (limited to 'devel')
-rw-r--r--devel/libbonobo/Makefile1
-rw-r--r--devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-fork-server.c21
2 files changed, 22 insertions, 0 deletions
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
index ae956f1a0c5e..5072b1e27fa8 100644
--- a/devel/libbonobo/Makefile
+++ b/devel/libbonobo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libbonobo
PORTVERSION= 2.10.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.10
diff --git a/devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-fork-server.c b/devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-fork-server.c
new file mode 100644
index 000000000000..ced10add3d34
--- /dev/null
+++ b/devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-fork-server.c
@@ -0,0 +1,21 @@
+--- bonobo-activation/bonobo-activation-fork-server.c.orig Fri Sep 9 17:20:15 2005
++++ bonobo-activation/bonobo-activation-fork-server.c Fri Sep 9 17:31:52 2005
+@@ -359,10 +359,18 @@
+ g_source_destroy (source);
+ g_source_unref (source);
+
++ g_io_channel_shutdown (ai.ioc, FALSE, NULL);
+ g_io_channel_unref (ai.ioc);
+
+ if (use_new_loop)
+ g_main_context_unref (context);
++
++ close (iopipes[1]);
++
++ g_strfreev(newenv);
++
++ if (fd_arg != 0)
++ g_free ((char *) cmd[fd_arg]);
+
+ return CORBA_OBJECT_NIL;
+ }