aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2012-10-21 21:47:50 +0800
committerrakuco <rakuco@FreeBSD.org>2012-10-21 21:47:50 +0800
commit3b872edd3e2e09d94448215650b7aec2664b05b2 (patch)
tree4d9af18c03b1746538787a749a35c74b7ccbf8c2 /devel
parente61470ef1e076cc64d0294230a7bc88665fb3df4 (diff)
downloadfreebsd-ports-gnome-3b872edd3e2e09d94448215650b7aec2664b05b2.tar.gz
freebsd-ports-gnome-3b872edd3e2e09d94448215650b7aec2664b05b2.tar.zst
freebsd-ports-gnome-3b872edd3e2e09d94448215650b7aec2664b05b2.zip
Add devel/hub.
hub is a command line tool that wraps git in order to extend it with extra features and commands that make working with GitHub easier. PR: ports/172214 Submitted by: Simon Olofsson <simon@olofsson.de> Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hub/Makefile39
-rw-r--r--devel/hub/distinfo2
-rw-r--r--devel/hub/pkg-descr4
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 189d2e53e33f..c4a2d7db3d1a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -779,6 +779,7 @@
SUBDIR += hs-vector-algorithms
SUBDIR += hs-void
SUBDIR += htable
+ SUBDIR += hub
SUBDIR += hwloc
SUBDIR += hyena
SUBDIR += hypersrc
diff --git a/devel/hub/Makefile b/devel/hub/Makefile
new file mode 100644
index 000000000000..320938f05d6e
--- /dev/null
+++ b/devel/hub/Makefile
@@ -0,0 +1,39 @@
+# Created by: Simon Olofsson <simon@olofsson.de>
+# $FreeBSD$
+
+PORTNAME= hub
+PORTVERSION= 1.10.2
+CATEGORIES= devel
+
+MAINTAINER= simon@olofsson.de
+COMMENT= Introduces git to GitHub
+
+USE_GITHUB= yes
+GH_ACCOUNT= defunkt
+GH_TAGNAME= v${DISTVERSION}
+GH_COMMIT= 16b388a
+
+USE_RUBY= yes
+USE_RAKE= yes
+
+PLIST_FILES= bin/hub \
+ etc/bash_completion.d/hub \
+ share/zsh/site-functions/_hub
+PLIST_DIRSTRY= etc/bash_completion.d \
+ share/zsh/site-functions share/zsh
+MAN1= hub.1
+
+do-build:
+ @cd ${WRKSRC} && ${RAKE_BIN} standalone
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/hub ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/hub.1 ${MAN1PREFIX}/man/man1
+
+post-install:
+ ${MKDIR} ${PREFIX}/etc/bash_completion.d
+ ${INSTALL_DATA} ${WRKSRC}/etc/hub.bash_completion.sh ${PREFIX}/etc/bash_completion.d/hub
+ ${MKDIR} ${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKSRC}/etc/hub.zsh_completion ${PREFIX}/share/zsh/site-functions/_hub
+
+.include <bsd.port.mk>
diff --git a/devel/hub/distinfo b/devel/hub/distinfo
new file mode 100644
index 000000000000..8fe47f48722e
--- /dev/null
+++ b/devel/hub/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hub-1.10.2.tar.gz) = 3bd8cf160062dac2dcdad176d14a88237fb4018522ef3a584a83c3f812d5b1c5
+SIZE (hub-1.10.2.tar.gz) = 54805
diff --git a/devel/hub/pkg-descr b/devel/hub/pkg-descr
new file mode 100644
index 000000000000..9992fe736871
--- /dev/null
+++ b/devel/hub/pkg-descr
@@ -0,0 +1,4 @@
+hub is a command line tool that wraps git in order to extend it with extra
+features and commands that make working with GitHub easier.
+
+WWW: http://defunkt.io/hub/