aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-12-24 07:17:19 +0800
committerbapt <bapt@FreeBSD.org>2014-12-24 07:17:19 +0800
commit3c6165666118ef5d2adbcb6e4af31ec965f7400a (patch)
treecb613dbc9cc1c6fa9f6d966c9bf439aff94ebd2d /devel
parent6486d8bc934ec3a5336cb13e26589d0cfec96e8f (diff)
downloadfreebsd-ports-gnome-3c6165666118ef5d2adbcb6e4af31ec965f7400a.tar.gz
freebsd-ports-gnome-3c6165666118ef5d2adbcb6e4af31ec965f7400a.tar.zst
freebsd-ports-gnome-3c6165666118ef5d2adbcb6e4af31ec965f7400a.zip
png public interface is enough to build those ports
Diffstat (limited to 'devel')
-rw-r--r--devel/clanlib1/Makefile4
-rw-r--r--devel/clanlib22/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/devel/clanlib1/Makefile b/devel/clanlib1/Makefile
index 87e25619696b..e4a7f75bd684 100644
--- a/devel/clanlib1/Makefile
+++ b/devel/clanlib1/Makefile
@@ -15,7 +15,7 @@ COMMENT= Cross-platform game SDK
LICENSE= ZLIB
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libmikmod.so:${PORTSDIR}/audio/libmikmod \
libvorbis.so:${PORTSDIR}/audio/libvorbis
@@ -25,7 +25,7 @@ USE_LDCONFIG= yes
USE_SDL= gfx
USE_GL= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-docs \
diff --git a/devel/clanlib22/Makefile b/devel/clanlib22/Makefile
index b63944974bea..e8f1e5f741fa 100644
--- a/devel/clanlib22/Makefile
+++ b/devel/clanlib22/Makefile
@@ -15,7 +15,7 @@ COMMENT= Cross-platform game SDK
LICENSE= ZLIB
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libmikmod.so:${PORTSDIR}/audio/libmikmod \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
@@ -27,7 +27,7 @@ USE_LDCONFIG= yes
USE_GL= yes
USE_SQLITE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-docs \