aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2004-06-15 02:28:55 +0800
committerobraun <obraun@FreeBSD.org>2004-06-15 02:28:55 +0800
commit3cb4ddfd61e536d6f913d70fcd342c45416d9c4f (patch)
tree6432a9cafc917d0e017fe4f3c01915e0f93c7344 /devel
parentea63887055991698739dd0ba43397b6599736745 (diff)
downloadfreebsd-ports-gnome-3cb4ddfd61e536d6f913d70fcd342c45416d9c4f.tar.gz
freebsd-ports-gnome-3cb4ddfd61e536d6f913d70fcd342c45416d9c4f.tar.zst
freebsd-ports-gnome-3cb4ddfd61e536d6f913d70fcd342c45416d9c4f.zip
Add cpphs, a simplified re-implementation of cpp, the C pre-processor, in
Haskell. WWW: http://www.cs.york.ac.uk/fp/cpphs/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-cpphs/Makefile27
-rw-r--r--devel/hs-cpphs/distinfo2
-rw-r--r--devel/hs-cpphs/pkg-descr10
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1d257500bee4..2450bc1a133b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -306,6 +306,7 @@
SUBDIR += hs-alex
SUBDIR += hs-buddha
SUBDIR += hs-c2hs
+ SUBDIR += hs-cpphs
SUBDIR += hs-crypto
SUBDIR += hs-drift
SUBDIR += hs-green-card
diff --git a/devel/hs-cpphs/Makefile b/devel/hs-cpphs/Makefile
new file mode 100644
index 000000000000..16dab8fb28c5
--- /dev/null
+++ b/devel/hs-cpphs/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cpphs
+# Date created: 14 June 2004
+# Whom: obraun@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpphs
+PORTVERSION= 0.5
+CATEGORIES= devel haskell
+MASTER_SITES= http://www.cs.york.ac.uk/fp/cpphs/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A simplified re-implementation of cpp in Haskell
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+
+PLIST_FILES= bin/cpphs
+
+do-build:
+ @(cd ${WRKSRC} && ghc -o cpphs --make cpphs)
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/cpphs ${PREFIX}/bin/cpphs
+
+.include <bsd.port.mk>
diff --git a/devel/hs-cpphs/distinfo b/devel/hs-cpphs/distinfo
new file mode 100644
index 000000000000..6e937783fb4b
--- /dev/null
+++ b/devel/hs-cpphs/distinfo
@@ -0,0 +1,2 @@
+MD5 (cpphs-0.5.tar.gz) = 33038f98da5604b95e439674bda77246
+SIZE (cpphs-0.5.tar.gz) = 32991
diff --git a/devel/hs-cpphs/pkg-descr b/devel/hs-cpphs/pkg-descr
new file mode 100644
index 000000000000..879cc1d606e8
--- /dev/null
+++ b/devel/hs-cpphs/pkg-descr
@@ -0,0 +1,10 @@
+cpphs is a simplified re-implementation of cpp, the C pre-processor, in
+Haskell.
+
+This version of the C pre-processor is pretty-much feature-complete, and
+compatible with the -traditional style. It has two modes:
+
+ * conditional compilation only (--nomacro),
+ * and full macro-expansion (default).
+
+WWW: http://www.cs.york.ac.uk/fp/cpphs/