aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-05-06 20:25:51 +0800
committermat <mat@FreeBSD.org>2004-05-06 20:25:51 +0800
commit3d90691baf725e47ddcd6c79b0d1e538c317f6e6 (patch)
treef99e1a6ee6118e60fc791c8c465da050db06a782 /devel
parent5686c5ffab1776d859017e580ce125f02756bd0b (diff)
downloadfreebsd-ports-gnome-3d90691baf725e47ddcd6c79b0d1e538c317f6e6.tar.gz
freebsd-ports-gnome-3d90691baf725e47ddcd6c79b0d1e538c317f6e6.tar.zst
freebsd-ports-gnome-3d90691baf725e47ddcd6c79b0d1e538c317f6e6.zip
Add p5-Proc-PID-File 1.24, a module to manage process id files.
PR: ports/65545 Submitted by: Lars Thegler <lars@thegler.dk>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Proc-PID-File/Makefile32
-rw-r--r--devel/p5-Proc-PID-File/distinfo2
-rw-r--r--devel/p5-Proc-PID-File/pkg-descr9
-rw-r--r--devel/p5-Proc-PID-File/pkg-plist7
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0592f955ddc3..03e84187df98 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -861,6 +861,7 @@
SUBDIR += p5-Pod-Coverage
SUBDIR += p5-Proc-Background
SUBDIR += p5-Proc-Daemon
+ SUBDIR += p5-Proc-PID-File
SUBDIR += p5-Proc-PIDFile
SUBDIR += p5-Proc-ProcessTable
SUBDIR += p5-Proc-Reliable
diff --git a/devel/p5-Proc-PID-File/Makefile b/devel/p5-Proc-PID-File/Makefile
new file mode 100644
index 000000000000..1fa3e740325c
--- /dev/null
+++ b/devel/p5-Proc-PID-File/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Proc-PID-File
+# Date created: Apr 13 2004
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+
+PORTNAME= Proc-PID-File
+PORTVERSION= 1.24
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Proc
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= A module to manage process id files
+
+PERL_CONFIGURE= yes
+
+MAN3= Proc::PID::File.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500503
+post-patch:
+ @${PERL} -pi -e '$$_ = "" if /no warnings/' ${WRKSRC}/File.pm
+
+# make PREFIX-clean under perl 5.005_03
+post-configure:
+ @${PERL} -pi -e 's,/usr/local/,\$$(PREFIX)/,g' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Proc-PID-File/distinfo b/devel/p5-Proc-PID-File/distinfo
new file mode 100644
index 000000000000..c3c70f7cb631
--- /dev/null
+++ b/devel/p5-Proc-PID-File/distinfo
@@ -0,0 +1,2 @@
+MD5 (Proc-PID-File-1.24.tar.gz) = 90b636492ae72def975a9ef9cac90fda
+SIZE (Proc-PID-File-1.24.tar.gz) = 12214
diff --git a/devel/p5-Proc-PID-File/pkg-descr b/devel/p5-Proc-PID-File/pkg-descr
new file mode 100644
index 000000000000..d9cd7c69bef3
--- /dev/null
+++ b/devel/p5-Proc-PID-File/pkg-descr
@@ -0,0 +1,9 @@
+This Perl module is useful for writers of daemons and other processes
+that need to tell whether they are already running, in order to
+prevent multiple process instances. The module accomplishes this
+via *nix-style pidfiles, which are files that store a process
+identifier.
+
+Inspired by Proc::PID_File, but with a much simpler interface.
+
+WWW: http://search.cpan.org/dist/Proc-PID-File/
diff --git a/devel/p5-Proc-PID-File/pkg-plist b/devel/p5-Proc-PID-File/pkg-plist
new file mode 100644
index 000000000000..28b9e847d88c
--- /dev/null
+++ b/devel/p5-Proc-PID-File/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Proc/PID/File.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/PID/File/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/PID/File
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/PID 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Proc/PID 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Proc 2>/dev/null || true