aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-05-27 03:51:26 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-05-27 03:51:26 +0800
commit3d9959bfe8a066d09fce320ef6e11383051e9c76 (patch)
tree512774c4c7ba806daa74747b3a8dd183e4050475 /devel
parent6c2e9bd71e10ed3baf72e47d693022257c9ceafc (diff)
downloadfreebsd-ports-gnome-3d9959bfe8a066d09fce320ef6e11383051e9c76.tar.gz
freebsd-ports-gnome-3d9959bfe8a066d09fce320ef6e11383051e9c76.tar.zst
freebsd-ports-gnome-3d9959bfe8a066d09fce320ef6e11383051e9c76.zip
- Add p5-IPC-MMA 0.81
IPC::MMA provides an interface to Ralf Engelschall's mm library, allowing memory to be shared between multiple processes in a relatively convenient way. IPC::MMA is a superset of Arthur Choung's IPC::MM module, adding arrays and allowing any Perl scalar to be used as a hash/BTree key rather than just C strings. IPC::MMA hashes are like IPC::MM BTrees in that they return keys in sorted order ineach, keys, and next operations. An IPC::MMA array can store data in any of six ways, including general-purpose scalars, signed or unsigned integers, floating-point numbers, fixed-length strings/records, and booleans at one bit per array element. WWW: http://search.cpan.org/dist/IPC-MMA/ PR: ports/157291 Submitted by: Peter Vereshagin <peter@vereshagin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-IPC-MMA/Makefile25
-rw-r--r--devel/p5-IPC-MMA/distinfo2
-rw-r--r--devel/p5-IPC-MMA/pkg-descr14
-rw-r--r--devel/p5-IPC-MMA/pkg-plist8
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3fabe27dd54f..4d54092f2b7c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1800,6 +1800,7 @@
SUBDIR += p5-IPC-DirQueue
SUBDIR += p5-IPC-Locker
SUBDIR += p5-IPC-MM
+ SUBDIR += p5-IPC-MMA
SUBDIR += p5-IPC-Mmap
SUBDIR += p5-IPC-Mmap-Share
SUBDIR += p5-IPC-Open3-Simple
diff --git a/devel/p5-IPC-MMA/Makefile b/devel/p5-IPC-MMA/Makefile
new file mode 100644
index 000000000000..f72043523e94
--- /dev/null
+++ b/devel/p5-IPC-MMA/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: IPC-MMA
+# Date created: 24 May 2011
+# Whom: Peter Vereshagin <peter@vereshagin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IPC-MMA
+PORTVERSION= 0.81
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= peter@vereshagin.org
+COMMENT= Improved Perl interface to Ralf Engelschall's mm library
+
+BUILD_DEPENDS= p5-Devel-CheckOS>=0:${PORTSDIR}/devel/p5-Devel-CheckOS
+RUN_DEPENDS= p5-Devel-CheckOS>=0:${PORTSDIR}/devel/p5-Devel-CheckOS
+LIB_DEPENDS= mm.14:${PORTSDIR}/devel/mm
+
+PERL_CONFIGURE= yes
+
+MAN3= IPC::MMA.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IPC-MMA/distinfo b/devel/p5-IPC-MMA/distinfo
new file mode 100644
index 000000000000..c4aab2ab7df8
--- /dev/null
+++ b/devel/p5-IPC-MMA/distinfo
@@ -0,0 +1,2 @@
+SHA256 (IPC-MMA-0.81.tar.gz) = 4f70fac1095daa7acae942a111e2df74e291405bebf3e2694ca719d56aa4bc7b
+SIZE (IPC-MMA-0.81.tar.gz) = 77642
diff --git a/devel/p5-IPC-MMA/pkg-descr b/devel/p5-IPC-MMA/pkg-descr
new file mode 100644
index 000000000000..7e87c5a6e21e
--- /dev/null
+++ b/devel/p5-IPC-MMA/pkg-descr
@@ -0,0 +1,14 @@
+IPC::MMA provides an interface to Ralf Engelschall's mm library, allowing
+memory to be shared between multiple processes in a relatively
+convenient way.
+
+IPC::MMA is a superset of Arthur Choung's IPC::MM module, adding arrays and
+allowing any Perl scalar to be used as a hash/BTree key rather than just C
+strings. IPC::MMA hashes are like IPC::MM BTrees in that they return keys in
+sorted order ineach, keys, and next operations.
+
+An IPC::MMA array can store data in any of six ways, including general-purpose
+scalars, signed or unsigned integers, floating-point numbers, fixed-length
+strings/records, and booleans at one bit per array element.
+
+WWW: http://search.cpan.org/dist/IPC-MMA/
diff --git a/devel/p5-IPC-MMA/pkg-plist b/devel/p5-IPC-MMA/pkg-plist
new file mode 100644
index 000000000000..ea437bf733a8
--- /dev/null
+++ b/devel/p5-IPC-MMA/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/IPC/MMA.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/IPC/MMA.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/MMA/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/MMA/MMA.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/MMA/MMA.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/MMA
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/IPC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC