aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2011-10-26 04:54:51 +0800
committereadler <eadler@FreeBSD.org>2011-10-26 04:54:51 +0800
commit40fc19d2ca40e8d8b92a8db4eb49e52262fc5fe1 (patch)
tree919e24360e844b0564c33a3cba32f7991cfd5cf2 /devel
parente8b7067e104a5ae2becd34be680ffe1a270b0ae3 (diff)
downloadfreebsd-ports-gnome-40fc19d2ca40e8d8b92a8db4eb49e52262fc5fe1.tar.gz
freebsd-ports-gnome-40fc19d2ca40e8d8b92a8db4eb49e52262fc5fe1.tar.zst
freebsd-ports-gnome-40fc19d2ca40e8d8b92a8db4eb49e52262fc5fe1.zip
Csmith is a tool that can generate random C programs that statically
and dynamically conform to the C99 standard. Thus, it is useful for stress-testing compilers, static analyzers, and other tools that process C code. Csmith has found bugs in every tool that it has tested, and over the last several years we have used it to find and report more than 350 previously-unknown compiler bugs. WWW: http://embed.cs.utah.edu/csmith/ Approved by: bapt (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/csmith/Makefile27
-rw-r--r--devel/csmith/distinfo2
-rw-r--r--devel/csmith/files/patch-runtime__Makefile.am11
-rw-r--r--devel/csmith/files/patch-runtime__Makefile.in11
-rw-r--r--devel/csmith/files/patch-src__Makefile.am11
-rw-r--r--devel/csmith/files/patch-src__Makefile.in11
-rw-r--r--devel/csmith/pkg-descr8
-rw-r--r--devel/csmith/pkg-plist30
9 files changed, 112 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d439f540dfb6..47e3a7f6bb9e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -235,6 +235,7 @@
SUBDIR += crossvc
SUBDIR += cscope
SUBDIR += cscout
+ SUBDIR += csmith
SUBDIR += csoap
SUBDIR += cssc
SUBDIR += cstringbuffer
diff --git a/devel/csmith/Makefile b/devel/csmith/Makefile
new file mode 100644
index 000000000000..dba0ab5fe62a
--- /dev/null
+++ b/devel/csmith/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: csmith
+# Date created: 2011-10-25
+# Whom: Eitan Adler <eadler@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= csmith
+PORTVERSION= 2.0.0
+CATEGORIES= devel
+MASTER_SITES= http://embed.cs.utah.edu/csmith/
+
+MAINTAINER= eadler@FreeBSD.org
+COMMENT= Generates random C programs that conform to the C99 standard
+
+LICENSE= BSD
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf
+CONFIGURE_ARGS= --docdir=${DOCSDIR}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/csmith/distinfo b/devel/csmith/distinfo
new file mode 100644
index 000000000000..af9cdeaf23b9
--- /dev/null
+++ b/devel/csmith/distinfo
@@ -0,0 +1,2 @@
+SHA256 (csmith-2.0.0.tar.gz) = 62dea40f4da98aed024fce14d3a0d07184a9f7388520607109ec87a6f27e1837
+SIZE (csmith-2.0.0.tar.gz) = 337806
diff --git a/devel/csmith/files/patch-runtime__Makefile.am b/devel/csmith/files/patch-runtime__Makefile.am
new file mode 100644
index 000000000000..5a11c2518b2e
--- /dev/null
+++ b/devel/csmith/files/patch-runtime__Makefile.am
@@ -0,0 +1,11 @@
+--- ./runtime/Makefile.am.orig 2011-04-12 21:39:51.000000000 -0400
++++ ./runtime/Makefile.am 2011-10-25 14:17:34.000000000 -0400
+@@ -39,7 +39,7 @@
+ libcsmith_a_SOURCES = \
+ volatile_runtime.c
+
+-SVN_FLAG = -DSVN_VERSION=\"`svnversion -n .`\"
++SVN_FLAG = -DSVN_VERSION=\"`exported`\"
+
+ ## ENE: The idea of stuffing the target CPU name (a string) into a CPP symbol
+ ## is kind of awful. What we should do instead is use the name to modify the
diff --git a/devel/csmith/files/patch-runtime__Makefile.in b/devel/csmith/files/patch-runtime__Makefile.in
new file mode 100644
index 000000000000..47fef49d1283
--- /dev/null
+++ b/devel/csmith/files/patch-runtime__Makefile.in
@@ -0,0 +1,11 @@
+--- ./runtime/Makefile.in.orig 2011-04-12 21:39:51.000000000 -0400
++++ ./runtime/Makefile.in 2011-10-25 14:17:34.000000000 -0400
+@@ -204,7 +204,7 @@
+ libcsmith_a_SOURCES = \
+ volatile_runtime.c
+
+-SVN_FLAG = -DSVN_VERSION=\"`svnversion -n .`\"
++SVN_FLAG = -DSVN_VERSION=\"`exported`\"
+ libcsmith_a_CPPFLAGS = \
+ -DTARGET_CPU_$(target_cpu)=1 \
+ $(SVN_FLAG)
diff --git a/devel/csmith/files/patch-src__Makefile.am b/devel/csmith/files/patch-src__Makefile.am
new file mode 100644
index 000000000000..4192c2af5543
--- /dev/null
+++ b/devel/csmith/files/patch-src__Makefile.am
@@ -0,0 +1,11 @@
+--- ./src/Makefile.am.orig 2011-04-12 21:39:51.000000000 -0400
++++ ./src/Makefile.am 2011-10-25 14:24:30.000000000 -0400
+@@ -191,7 +191,7 @@
+ csmith.vcproj \
+ csmith.vcxproj
+
+-SVN_FLAG = -DSVN_VERSION=\"`svnversion -n .`\"
++SVN_FLAG = -DSVN_VERSION=\"`exported`\"
+
+ ## ENE: The idea of stuffing the target CPU name (a string) into a CPP symbol
+ ## is kind of awful. What we should do instead is use the name to modify the
diff --git a/devel/csmith/files/patch-src__Makefile.in b/devel/csmith/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..6b2a60a98e93
--- /dev/null
+++ b/devel/csmith/files/patch-src__Makefile.in
@@ -0,0 +1,11 @@
+--- ./src/Makefile.in.orig 2011-04-12 21:39:51.000000000 -0400
++++ ./src/Makefile.in 2011-10-25 14:24:30.000000000 -0400
+@@ -384,7 +384,7 @@
+ csmith.vcproj \
+ csmith.vcxproj
+
+-SVN_FLAG = -DSVN_VERSION=\"`svnversion -n .`\"
++SVN_FLAG = -DSVN_VERSION=\"`exported`\"
+ csmith_CPPFLAGS = \
+ -DTARGET_CPU_$(target_cpu)=1 \
+ $(SVN_FLAG) \
diff --git a/devel/csmith/pkg-descr b/devel/csmith/pkg-descr
new file mode 100644
index 000000000000..d21f22b9dedf
--- /dev/null
+++ b/devel/csmith/pkg-descr
@@ -0,0 +1,8 @@
+Csmith is a tool that can generate random C programs that statically
+and dynamically conform to the C99 standard. Thus, it is useful for
+stress-testing compilers, static analyzers, and other tools that
+process C code. Csmith has found bugs in every tool that it has
+tested, and over the last several years we have used it to find
+and report more than 350 previously-unknown compiler bugs.
+
+WWW: http://embed.cs.utah.edu/csmith/
diff --git a/devel/csmith/pkg-plist b/devel/csmith/pkg-plist
new file mode 100644
index 000000000000..30894bf2c58a
--- /dev/null
+++ b/devel/csmith/pkg-plist
@@ -0,0 +1,30 @@
+bin/compiler_test.in
+bin/compiler_test.pl
+bin/crash_compilers.pl
+bin/launchn.pl
+bin/csmith
+include/csmith-2.0.0/windows/stdint.h
+include/csmith-2.0.0/csmith.h
+include/csmith-2.0.0/csmith_minimal.h
+include/csmith-2.0.0/custom_limits.h
+include/csmith-2.0.0/custom_stdint_x86.h
+include/csmith-2.0.0/platform_avr.h
+include/csmith-2.0.0/platform_generic.h
+include/csmith-2.0.0/platform_msp430.h
+include/csmith-2.0.0/random_inc.h
+include/csmith-2.0.0/safe_abbrev.h
+include/csmith-2.0.0/safe_math.m4
+include/csmith-2.0.0/safe_math_macros.m4
+include/csmith-2.0.0/safe_math_macros_notmp.m4
+include/csmith-2.0.0/stdint_avr.h
+include/csmith-2.0.0/stdint_ia32.h
+include/csmith-2.0.0/stdint_ia64.h
+include/csmith-2.0.0/stdint_msp430.h
+include/csmith-2.0.0/volatile_runtime.c
+include/csmith-2.0.0/volatile_runtime.h
+lib/libcsmith.a
+%%DOCSDIR%%/probabilities.txt
+
+@dirrm %%DOCSDIR%%
+@dirrm include/csmith-2.0.0/windows
+@dirrm include/csmith-2.0.0