aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-11-24 18:13:47 +0800
committersem <sem@FreeBSD.org>2004-11-24 18:13:47 +0800
commit418d918cdd0017bcfb2ebc5688dc6bac8bc4df1c (patch)
tree4b7f5cd12e6cd60ccd18d22b6e0aaf659d585a16 /devel
parente4e09ce78ff3cc8bb51ccc5ad1e2993fefa58b1f (diff)
downloadfreebsd-ports-gnome-418d918cdd0017bcfb2ebc5688dc6bac8bc4df1c.tar.gz
freebsd-ports-gnome-418d918cdd0017bcfb2ebc5688dc6bac8bc4df1c.tar.zst
freebsd-ports-gnome-418d918cdd0017bcfb2ebc5688dc6bac8bc4df1c.zip
New Port: devel/p5-Heap-Simple-Perl - A pure perl implementation
of the Heap::Simple interface PR: ports/73827 Submitted by: Aaron Dalton <aaron(at)daltons.ca>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Heap-Simple-Perl/Makefile31
-rw-r--r--devel/p5-Heap-Simple-Perl/distinfo2
-rw-r--r--devel/p5-Heap-Simple-Perl/pkg-descr8
-rw-r--r--devel/p5-Heap-Simple-Perl/pkg-plist43
5 files changed, 85 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6e0350378f80..c4a97fffd175 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -835,6 +835,7 @@
SUBDIR += p5-Glib2
SUBDIR += p5-Heap
SUBDIR += p5-Heap-Simple
+ SUBDIR += p5-Heap-Simple-Perl
SUBDIR += p5-Hook-LexWrap
SUBDIR += p5-IO
SUBDIR += p5-IO-All
diff --git a/devel/p5-Heap-Simple-Perl/Makefile b/devel/p5-Heap-Simple-Perl/Makefile
new file mode 100644
index 000000000000..288acfee0a1d
--- /dev/null
+++ b/devel/p5-Heap-Simple-Perl/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Heap-Simple-Perl
+# Date created: 11 November 2004
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Heap-Simple-Perl
+PORTVERSION= 0.09
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Heap
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= A pure perl implementation of the Heap::Simple interface
+
+BUILD_DEPENDS= ${SITE_PERL}/Heap/Simple.pm:${PORTSDIR}/devel/p5-Heap-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Heap::Simple::Perl.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Uses ??{} in regexps, which came with perl5.6, install lang/perl5 or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Heap-Simple-Perl/distinfo b/devel/p5-Heap-Simple-Perl/distinfo
new file mode 100644
index 000000000000..e20a92740e32
--- /dev/null
+++ b/devel/p5-Heap-Simple-Perl/distinfo
@@ -0,0 +1,2 @@
+MD5 (Heap-Simple-Perl-0.09.tar.gz) = f17c35819866b67efe4467660c052879
+SIZE (Heap-Simple-Perl-0.09.tar.gz) = 24551
diff --git a/devel/p5-Heap-Simple-Perl/pkg-descr b/devel/p5-Heap-Simple-Perl/pkg-descr
new file mode 100644
index 000000000000..df017159e1c1
--- /dev/null
+++ b/devel/p5-Heap-Simple-Perl/pkg-descr
@@ -0,0 +1,8 @@
+This module provides a pure perl implementation of the interface described
+in Heap::Simple. Look there for a description.
+
+WWW: http://search.cpan.org/dist/Heap-Simple-Perl/
+Author: Ton Hospel <cpan@ton.iguana.be>
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/devel/p5-Heap-Simple-Perl/pkg-plist b/devel/p5-Heap-Simple-Perl/pkg-plist
new file mode 100644
index 000000000000..0e07be6dbe23
--- /dev/null
+++ b/devel/p5-Heap-Simple-Perl/pkg-plist
@@ -0,0 +1,43 @@
+%%SITE_PERL%%/Heap/Simple/Any.pm
+%%SITE_PERL%%/Heap/Simple/Array.pm
+%%SITE_PERL%%/Heap/Simple/Function.pm
+%%SITE_PERL%%/Heap/Simple/Hash.pm
+%%SITE_PERL%%/Heap/Simple/Less.pm
+%%SITE_PERL%%/Heap/Simple/Method.pm
+%%SITE_PERL%%/Heap/Simple/Number.pm
+%%SITE_PERL%%/Heap/Simple/NumberReverse.pm
+%%SITE_PERL%%/Heap/Simple/Object.pm
+%%SITE_PERL%%/Heap/Simple/Perl.pm
+%%SITE_PERL%%/Heap/Simple/Scalar.pm
+%%SITE_PERL%%/Heap/Simple/String.pm
+%%SITE_PERL%%/Heap/Simple/StringReverse.pm
+%%SITE_PERL%%/Heap/Simple/Wrapper.pm
+%%SITE_PERL%%/auto/Heap/Simple/Perl/_absorb.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/_e_recover.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/_i_recover.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/_key_absorb.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/autosplit.ix
+%%SITE_PERL%%/auto/Heap/Simple/Perl/extract_first.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/extract_min.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/extract_top.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/extract_upto.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/first.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/first_key.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/infinity.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/insert.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/key.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/keys.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/min_key.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/top.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/top_key.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/user_data.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/values.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple/Perl/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple/Perl
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap 2>/dev/null || true
+@dirrm %%SITE_PERL%%/auto/Heap/Simple/Perl
+@unexec rmdir %D/%%SITE_PERL%%/auto/Heap/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/auto/Heap 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Heap/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Heap 2>/dev/null || true