aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-05-10 10:23:59 +0800
committermiwi <miwi@FreeBSD.org>2010-05-10 10:23:59 +0800
commit423e7cd510df7ab47355b56675448de2ce7b8d1b (patch)
tree53882a90f73138aec7256e803111810c396f6026 /devel
parent3dfabc2adbb01f14f7b4a3ae1a6a8a62064fb5a0 (diff)
downloadfreebsd-ports-gnome-423e7cd510df7ab47355b56675448de2ce7b8d1b.tar.gz
freebsd-ports-gnome-423e7cd510df7ab47355b56675448de2ce7b8d1b.tar.zst
freebsd-ports-gnome-423e7cd510df7ab47355b56675448de2ce7b8d1b.zip
API Sanity Autotest is a test generator for shared C/C++ libraries. It can
quickly generate simple ("sanity" or "shallow"-quality) tests for functions from the library API, using the signatures and data type definitions from the library header files. The tests can detect critical errors in simple use cases, and can be improved with highly reusable specialized types. API Sanity Autotest can execute generated tests and detect all kinds of emitted signals, early program exits, program hanging and specified requirement failures. API Sanity Autotest also supports tests in the Template2Code format, and has a random test generation mode and other useful features. WWW: http://ispras.linux-foundation.org/index.php/API_Sanity_Autotest PR: ports/146431 Submitted by: bf <bf1783 at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/api-sanity-autotest/Makefile44
-rw-r--r--devel/api-sanity-autotest/distinfo3
-rw-r--r--devel/api-sanity-autotest/pkg-descr11
4 files changed, 59 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d3b4b477e528..905cf5646c87 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -39,6 +39,7 @@
SUBDIR += antlr
SUBDIR += antlrworks
SUBDIR += apache-ant
+ SUBDIR += api-sanity-autotest
SUBDIR += apr
SUBDIR += arduino
SUBDIR += argouml
diff --git a/devel/api-sanity-autotest/Makefile b/devel/api-sanity-autotest/Makefile
new file mode 100644
index 000000000000..77a50c9fba13
--- /dev/null
+++ b/devel/api-sanity-autotest/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: api-sanity-autotest
+# Date created: February 16, 2009
+# Whom: bf <bf1783@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= api-sanity-autotest
+PORTVERSION= 1.8
+CATEGORIES= devel perl5
+MASTER_SITES= http://ispras.linux-foundation.org/images/e/e8/
+DISTFILES= ${PORTNAME:S/^a/A/}-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= bf1783@gmail.com
+COMMENT= Quickly generate sanity tests for the API of a C/C++ shared library
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+PLIST_FILES= bin/${PORTNAME}.pl
+
+CPPFILT?= c++filt
+READELF?= readelf
+
+post-patch:
+ ${REINPLACE_CMD} \
+ -e "\%my% { \
+ s%\"c++filt\"%\"${CPPFILT}\"%g; \
+ s%\"readelf\"%\"${READELF}\"%g; \
+ s%\"g++\"%\"${CXX}\"%g; \
+ s%\"gcc\"%\"${CC}\"%g; }" \
+ -e "\%search_for% { \
+ s%\"g++\"%\"${CXX}\"%g; \
+ s%\"gcc\"%\"${CC}\"%g; }" \
+ -e "s% -shared%& -fPIC%g" \
+ ${WRKSRC}/${PORTNAME}.pl
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin
+
+test: build
+ @(cd ${WRKSRC} && ./${PORTNAME}.pl -test )
+
+.include <bsd.port.mk>
diff --git a/devel/api-sanity-autotest/distinfo b/devel/api-sanity-autotest/distinfo
new file mode 100644
index 000000000000..899e09d0e3d3
--- /dev/null
+++ b/devel/api-sanity-autotest/distinfo
@@ -0,0 +1,3 @@
+MD5 (Api-sanity-autotest-1.8.tar.gz) = 9e51ede36fbad80ae753337778d24822
+SHA256 (Api-sanity-autotest-1.8.tar.gz) = 0675e7a7db12e6b830f80b32ffb56ddcb1469f77f07bd592bcce4686056adb51
+SIZE (Api-sanity-autotest-1.8.tar.gz) = 119979
diff --git a/devel/api-sanity-autotest/pkg-descr b/devel/api-sanity-autotest/pkg-descr
new file mode 100644
index 000000000000..c70a772d2c8d
--- /dev/null
+++ b/devel/api-sanity-autotest/pkg-descr
@@ -0,0 +1,11 @@
+API Sanity Autotest is a test generator for shared C/C++ libraries. It can
+quickly generate simple ("sanity" or "shallow"-quality) tests for functions from
+the library API, using the signatures and data type definitions from the library
+header files. The tests can detect critical errors in simple use cases, and can
+be improved with highly reusable specialized types. API Sanity Autotest can
+execute generated tests and detect all kinds of emitted signals, early program
+exits, program hanging and specified requirement failures. API Sanity Autotest
+also supports tests in the Template2Code format, and has a random test
+generation mode and other useful features.
+
+WWW: http://ispras.linux-foundation.org/index.php/API_Sanity_Autotest