aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2010-03-05 01:05:48 +0800
committeritetcu <itetcu@FreeBSD.org>2010-03-05 01:05:48 +0800
commit43f7b0d6f94bfe1f14ca76a29c4671f1c7df9db4 (patch)
treeb3b82312fe3fc19a8eb9109dd441bf00c46bac7c /devel
parent57d72fec1a2da1015894d9e04e4e7f40101a0ef4 (diff)
downloadfreebsd-ports-gnome-43f7b0d6f94bfe1f14ca76a29c4671f1c7df9db4.tar.gz
freebsd-ports-gnome-43f7b0d6f94bfe1f14ca76a29c4671f1c7df9db4.tar.zst
freebsd-ports-gnome-43f7b0d6f94bfe1f14ca76a29c4671f1c7df9db4.zip
Often Perl modules are written to wrap functionallity found in existing
C headers, libraries, or to use OS-specific features. It is useful in the Build.PL or Makefile.PL file to check for the existance of these requirements before attempting to actually build the module. Objects in this class provide an extension around ExtUtils::CBuilder to simplify the creation of a .c file, compiling, linking and running it, to test if a certain feature is present. WWW: http://search.cpan.org/~pevans/ExtUtils-CChecker-0.02/ PR: ports/144196 Submitted by: Sahil Tandon <sahil at tandon.net> Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-ExtUtils-CChecker/Makefile30
-rw-r--r--devel/p5-ExtUtils-CChecker/distinfo3
-rw-r--r--devel/p5-ExtUtils-CChecker/pkg-descr10
-rw-r--r--devel/p5-ExtUtils-CChecker/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 73806d248eec..460412f1d466 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1480,6 +1480,7 @@
SUBDIR += p5-Exporter-Tidy
SUBDIR += p5-ExtUtils-AutoInstall
SUBDIR += p5-ExtUtils-CBuilder
+ SUBDIR += p5-ExtUtils-CChecker
SUBDIR += p5-ExtUtils-Command
SUBDIR += p5-ExtUtils-Constant
SUBDIR += p5-ExtUtils-Depends
diff --git a/devel/p5-ExtUtils-CChecker/Makefile b/devel/p5-ExtUtils-CChecker/Makefile
new file mode 100644
index 000000000000..f010f5200664
--- /dev/null
+++ b/devel/p5-ExtUtils-CChecker/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: ExtUtils::CChecker
+# Date created: 21 Feb 2010
+# Whom: Sahil Tandon <sahil@tandon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ExtUtils-CChecker
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sahil@tandon.net
+COMMENT= Configure-time utilities for using C headers, libraries, OS features
+
+PERL_CONFIGURE= yes
+
+MAN3= ExtUtils::CChecker.3
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes README
+
+post-install:
+ @${INSTALL} -o ${DOCOWN} -g ${DOCGRP} -m 555 -d ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/p5-ExtUtils-CChecker/distinfo b/devel/p5-ExtUtils-CChecker/distinfo
new file mode 100644
index 000000000000..3ce8a67135f5
--- /dev/null
+++ b/devel/p5-ExtUtils-CChecker/distinfo
@@ -0,0 +1,3 @@
+MD5 (ExtUtils-CChecker-0.02.tar.gz) = 322edede12d0a085af20987e9e65d905
+SHA256 (ExtUtils-CChecker-0.02.tar.gz) = 7f026d59909730254672860dc0d52c9cf1ccd5beade52587a54c06f7fdc55337
+SIZE (ExtUtils-CChecker-0.02.tar.gz) = 13856
diff --git a/devel/p5-ExtUtils-CChecker/pkg-descr b/devel/p5-ExtUtils-CChecker/pkg-descr
new file mode 100644
index 000000000000..0088eaa617b7
--- /dev/null
+++ b/devel/p5-ExtUtils-CChecker/pkg-descr
@@ -0,0 +1,10 @@
+Often Perl modules are written to wrap functionallity found in existing
+C headers, libraries, or to use OS-specific features. It is useful in
+the Build.PL or Makefile.PL file to check for the existance of these
+requirements before attempting to actually build the module.
+
+Objects in this class provide an extension around ExtUtils::CBuilder to
+simplify the creation of a .c file, compiling, linking and running it,
+to test if a certain feature is present.
+
+WWW: http://search.cpan.org/~pevans/ExtUtils-CChecker-0.02/
diff --git a/devel/p5-ExtUtils-CChecker/pkg-plist b/devel/p5-ExtUtils-CChecker/pkg-plist
new file mode 100644
index 000000000000..2675062f5783
--- /dev/null
+++ b/devel/p5-ExtUtils-CChecker/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/ExtUtils/CChecker.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/CChecker/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/CChecker
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils
+@dirrmtry %%SITE_PERL%%/ExtUtils