aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2004-10-12 21:00:19 +0800
committerclsung <clsung@FreeBSD.org>2004-10-12 21:00:19 +0800
commit44b8c0b66d81b3285654550343e3a48d9d87b4f7 (patch)
treeeb90d2c1d06d48db7df953ac8643b52ec0c12ae0 /devel
parentb847c16670504718544a0b591ac8988333b241d0 (diff)
downloadfreebsd-ports-gnome-44b8c0b66d81b3285654550343e3a48d9d87b4f7.tar.gz
freebsd-ports-gnome-44b8c0b66d81b3285654550343e3a48d9d87b4f7.tar.zst
freebsd-ports-gnome-44b8c0b66d81b3285654550343e3a48d9d87b4f7.zip
- Add new port devel/p5-Data-Dumper-Simple
- This module allow the user to dump variables in a Data::Dumper format. PR: ports/71508 Submitted by: clsung Approved by: co-mentor (vanilla)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Dumper-Simple/Makefile32
-rw-r--r--devel/p5-Data-Dumper-Simple/distinfo2
-rw-r--r--devel/p5-Data-Dumper-Simple/pkg-descr17
-rw-r--r--devel/p5-Data-Dumper-Simple/pkg-plist7
5 files changed, 59 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 026fc853998d..50a7797c25aa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -678,6 +678,7 @@
SUBDIR += p5-Data-Dump-Streamer
SUBDIR += p5-Data-DumpXML
SUBDIR += p5-Data-Dumper
+ SUBDIR += p5-Data-Dumper-Simple
SUBDIR += p5-Data-Flow
SUBDIR += p5-Data-HexDump
SUBDIR += p5-Data-Hexdumper
diff --git a/devel/p5-Data-Dumper-Simple/Makefile b/devel/p5-Data-Dumper-Simple/Makefile
new file mode 100644
index 000000000000..d6b73200003d
--- /dev/null
+++ b/devel/p5-Data-Dumper-Simple/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Data-Dumper-Simple
+# Date created: Sep 9 2004
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Dumper-Simple
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Easily dump variables with names
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Dumper::Simple.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500805
+BUILD_DEPENDS+= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+.endif
+.if ${PERL_LEVEL} < 500601
+IGNORE="Need at least perl 5.6.1 to build"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-Dumper-Simple/distinfo b/devel/p5-Data-Dumper-Simple/distinfo
new file mode 100644
index 000000000000..8b9a3f915c5e
--- /dev/null
+++ b/devel/p5-Data-Dumper-Simple/distinfo
@@ -0,0 +1,2 @@
+MD5 (Data-Dumper-Simple-0.06.tar.gz) = cb2ab608bdbe289ad6db4baf4fa84ae7
+SIZE (Data-Dumper-Simple-0.06.tar.gz) = 6356
diff --git a/devel/p5-Data-Dumper-Simple/pkg-descr b/devel/p5-Data-Dumper-Simple/pkg-descr
new file mode 100644
index 000000000000..9aeb944ca20d
--- /dev/null
+++ b/devel/p5-Data-Dumper-Simple/pkg-descr
@@ -0,0 +1,17 @@
+This module allow the user to dump variables in a Data::Dumper format.
+
+Unlike the default behavior of Data::Dumper, the variables are named
+(instead of $VAR1, $VAR2, etc.) Data::Dumper provides an extended
+interface that allows the programmer to name the variables, but this
+interface requires a lot of typing and is prone to tyops (sic). This
+module fixes that.
+
+Data::Dumper::Simple is actually a source filter that replaces all
+instances of Dumper($some, @args) in your code with a call to
+Data::Dumper->Dump(). You can use the one function provided to make
+dumping variables for debugging a trivial task.
+
+Note that this is primarily a debugging tool. Data::Dumper offers a
+bit more than that, so don't expect this module to be more than it is.
+
+WWW: http://search.cpan.org/dist/Data-Dumper-Simple/
diff --git a/devel/p5-Data-Dumper-Simple/pkg-plist b/devel/p5-Data-Dumper-Simple/pkg-plist
new file mode 100644
index 000000000000..d4d87156d2bd
--- /dev/null
+++ b/devel/p5-Data-Dumper-Simple/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Data/Dumper/Simple.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dumper/Simple/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dumper/Simple
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dumper 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Data/Dumper 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Data 2>/dev/null || true