aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-01-25 16:58:02 +0800
committermiwi <miwi@FreeBSD.org>2010-01-25 16:58:02 +0800
commit4654e7f7f397903fd29fc813dfe6bbcc6891dc00 (patch)
tree391c3d49eefa2c9295dfd27d29a1b3402c190cdb /devel
parent052f1bbab20e38effec7cb14866d2d3eff2e7651 (diff)
downloadfreebsd-ports-gnome-4654e7f7f397903fd29fc813dfe6bbcc6891dc00.tar.gz
freebsd-ports-gnome-4654e7f7f397903fd29fc813dfe6bbcc6891dc00.tar.zst
freebsd-ports-gnome-4654e7f7f397903fd29fc813dfe6bbcc6891dc00.zip
JSON (JavaScript Object Notation) is a lightweight data-interchange
format. It can represent integers, real numbers, strings, an ordered sequence of values, and a collection of name/value pairs. QJson is a Qt-based library that maps JSON data to QVariant objects. JSON arrays will be mapped to QVariantList instances, while JSON's objects will be mapped to QVariantMap. WWW: http://qjson.sourceforge.net PR: ports/142307 Submitted by: Alberto Villa <villa.alberto at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/qjson/Makefile28
-rw-r--r--devel/qjson/distinfo3
-rw-r--r--devel/qjson/pkg-descr9
-rw-r--r--devel/qjson/pkg-plist15
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a386c04ccbb6..4587ef5742e8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2706,6 +2706,7 @@
SUBDIR += qct
SUBDIR += qdevelop
SUBDIR += qgit
+ SUBDIR += qjson
SUBDIR += qmake
SUBDIR += qmake4
SUBDIR += qprog
diff --git a/devel/qjson/Makefile b/devel/qjson/Makefile
new file mode 100644
index 000000000000..5dc058195f85
--- /dev/null
+++ b/devel/qjson/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: qjson
+# Date created: 19 December 2009
+# Whom: Alberto Villa <villa.alberto@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= qjson
+PORTVERSION= 0.7.1
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= villa.alberto@gmail.com
+COMMENT= Qt-based library that maps JSON data to QVariant objects
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib moc_build qmake_build rcc_build uic_build
+MAKE_JOBS_SAFE= yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+pre-configure:
+ @${REINPLACE_CMD} -e '/pkgconfig/ s/$${LIB_SUFFIX}/data/' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/devel/qjson/distinfo b/devel/qjson/distinfo
new file mode 100644
index 000000000000..0bd9a99daad1
--- /dev/null
+++ b/devel/qjson/distinfo
@@ -0,0 +1,3 @@
+MD5 (qjson-0.7.1.tar.bz2) = 5a833ad606c164ed8aa69f0873366ace
+SHA256 (qjson-0.7.1.tar.bz2) = 3b8e94345fe846171c4b4d7d3518891d5fc864fda1e0c10d935bdb77bd3db994
+SIZE (qjson-0.7.1.tar.bz2) = 38075
diff --git a/devel/qjson/pkg-descr b/devel/qjson/pkg-descr
new file mode 100644
index 000000000000..f13201aefed2
--- /dev/null
+++ b/devel/qjson/pkg-descr
@@ -0,0 +1,9 @@
+JSON (JavaScript Object Notation) is a lightweight data-interchange
+format. It can represent integers, real numbers, strings, an ordered
+sequence of values, and a collection of name/value pairs.
+
+QJson is a Qt-based library that maps JSON data to QVariant objects.
+JSON arrays will be mapped to QVariantList instances, while JSON's
+objects will be mapped to QVariantMap.
+
+WWW: http://qjson.sourceforge.net
diff --git a/devel/qjson/pkg-plist b/devel/qjson/pkg-plist
new file mode 100644
index 000000000000..591144e3ddad
--- /dev/null
+++ b/devel/qjson/pkg-plist
@@ -0,0 +1,15 @@
+include/qjson/parser.h
+include/qjson/parserrunnable.h
+include/qjson/qjson_export.h
+include/qjson/qobjecthelper.h
+include/qjson/serializer.h
+include/qjson/serializerrunnable.h
+lib/libqjson.so
+lib/libqjson.so.0
+lib/libqjson.so.0.7.1
+libdata/pkgconfig/QJson.pc
+share/apps/cmake/modules/FindQJSON.cmake
+@dirrmtry share/apps/cmake/modules
+@dirrmtry share/apps/cmake
+@dirrmtry share/apps
+@dirrm include/qjson