aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
committerpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
commit4682c2c61dcb7a63ae78f7c087ba5d0bda84f154 (patch)
treef00883f68004a81b9e525ad5cc94de309898b666 /devel
parent31dd4fd824aafa89c7f4eb95e23f32974c053110 (diff)
downloadfreebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.gz
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.zst
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.zip
Convert my ports to current standards
- Switch USE_GMAKE to USES=gmake - Define supported options so users can see them in config dialogs - Use OPTIONS_SUB for plist alteration - Convert to options macros for better readability - Use PORTDOCS where it makes sense
Diffstat (limited to 'devel')
-rw-r--r--devel/upnp/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/devel/upnp/Makefile b/devel/upnp/Makefile
index 7fd880eba5a9..2a31ae3bc84e 100644
--- a/devel/upnp/Makefile
+++ b/devel/upnp/Makefile
@@ -19,18 +19,13 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-CONFIGURE_ARGS+= --with-documentation=${DOCSDIR}
PORTDOCS= *
-.else
-CONFIGURE_ARGS+= --without-documentation
-.endif
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug
-.endif
+OPTIONS_DEFINE= DEBUG DOCS
+
+DEBUG_CONFIGURE_ON= --enable-debug
+DOCS_CONFIGURE_ON= --with-documentation=${DOCSDIR}
+DOCS_CONFIGURE_OFF= --without-documentation
post-patch: .SILENT
${REINPLACE_CMD} '/^pkgconfigexecdir/s|$$(libdir)|$$(prefix)/libdata|' \