aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-06-06 02:15:31 +0800
committerak <ak@FreeBSD.org>2012-06-06 02:15:31 +0800
commit468d7a6e727a41f0fa257ccb0d8be9d110c1af45 (patch)
treedb7ef370f45fffb5b3f2a1b446cdcb3c85a7e56b /devel
parentcce846ff674a2cde685b4281ef40210c8367ce0a (diff)
downloadfreebsd-ports-gnome-468d7a6e727a41f0fa257ccb0d8be9d110c1af45.tar.gz
freebsd-ports-gnome-468d7a6e727a41f0fa257ccb0d8be9d110c1af45.tar.zst
freebsd-ports-gnome-468d7a6e727a41f0fa257ccb0d8be9d110c1af45.zip
- Remove SITE_PERL from *_DEPENDS
Submitted by: az Approved by: eadler (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Agent/Makefile2
-rw-r--r--devel/p5-Algorithm-Annotate/Makefile2
-rw-r--r--devel/p5-Config-ApacheFormat/Makefile4
-rw-r--r--devel/p5-Curses-Forms/Makefile2
-rw-r--r--devel/p5-Devel-StealthDebug/Makefile2
-rw-r--r--devel/p5-Devel-ptkdb/Makefile2
-rw-r--r--devel/p5-File-Random/Makefile2
-rw-r--r--devel/p5-Heap-Simple-Perl/Makefile2
-rw-r--r--devel/p5-Heap-Simple-XS/Makefile2
-rw-r--r--devel/p5-IPC-Cache/Makefile2
-rw-r--r--devel/p5-POE-Component-IKC/Makefile16
-rw-r--r--devel/p5-PV/Makefile2
-rw-r--r--devel/p5-Penguin-Easy/Makefile2
-rw-r--r--devel/p5-Shell-Base/Makefile4
-rw-r--r--devel/p5-Tree-Parser/Makefile6
15 files changed, 26 insertions, 26 deletions
diff --git a/devel/p5-Agent/Makefile b/devel/p5-Agent/Makefile
index 58ddb7dc30cc..1623abf098db 100644
--- a/devel/p5-Agent/Makefile
+++ b/devel/p5-Agent/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module that provides a foundation for software agent developers
-BUILD_DEPENDS= ${SITE_PERL}/Class/Tom.pm:${PORTSDIR}/devel/p5-Class-Tom
+BUILD_DEPENDS= p5-Class-Tom>=0:${PORTSDIR}/devel/p5-Class-Tom
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Algorithm-Annotate/Makefile b/devel/p5-Algorithm-Annotate/Makefile
index 8068a31bd3f3..d4333d0401bf 100644
--- a/devel/p5-Algorithm-Annotate/Makefile
+++ b/devel/p5-Algorithm-Annotate/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Represent a series of changes in annotate form
-BUILD_DEPENDS= ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff
+BUILD_DEPENDS= p5-Algorithm-Diff>=0:${PORTSDIR}/devel/p5-Algorithm-Diff
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Config-ApacheFormat/Makefile b/devel/p5-Config-ApacheFormat/Makefile
index adbc69bf008c..8b7990ef03ff 100644
--- a/devel/p5-Config-ApacheFormat/Makefile
+++ b/devel/p5-Config-ApacheFormat/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Parse a configuration file in the same syntax as the Apache web server
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/auto/Class/MethodMaker/MethodMaker.so:${PORTSDIR}/devel/p5-Class-MethodMaker \
- ${SITE_PERL}/${PERL_ARCH}/auto/List/Util/Util.so:${PORTSDIR}/lang/p5-Scalar-List-Utils
+BUILD_DEPENDS= p5-Class-MethodMaker>=0:${PORTSDIR}/devel/p5-Class-MethodMaker \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
PERL_CONFIGURE= yes
MAN3= Config::ApacheFormat.3
diff --git a/devel/p5-Curses-Forms/Makefile b/devel/p5-Curses-Forms/Makefile
index e4a43b9c0f4f..47427e68a21a 100644
--- a/devel/p5-Curses-Forms/Makefile
+++ b/devel/p5-Curses-Forms/Makefile
@@ -16,7 +16,7 @@ DISTNAME= CursesForms-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Provide high level APIs for rapid UI design on the console
-BUILD_DEPENDS= ${SITE_PERL}/Curses/Widgets.pm:${PORTSDIR}/devel/p5-Curses-Widgets
+BUILD_DEPENDS= p5-Curses-Widgets>=0:${PORTSDIR}/devel/p5-Curses-Widgets
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Devel-StealthDebug/Makefile b/devel/p5-Devel-StealthDebug/Makefile
index 4df57f7bce45..174fb954ebad 100644
--- a/devel/p5-Devel-StealthDebug/Makefile
+++ b/devel/p5-Devel-StealthDebug/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple non-intrusive debug module
-BUILD_DEPENDS= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple
+BUILD_DEPENDS= p5-Filter-Simple>=0:${PORTSDIR}/textproc/p5-Filter-Simple
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Devel-ptkdb/Makefile b/devel/p5-Devel-ptkdb/Makefile
index 4a2842fd74de..4202950b2ecb 100644
--- a/devel/p5-Devel-ptkdb/Makefile
+++ b/devel/p5-Devel-ptkdb/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Tk debugger for Perl
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
+RUN_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk
PERL_CONFIGURE= yes
diff --git a/devel/p5-File-Random/Makefile b/devel/p5-File-Random/Makefile
index 49c7262ba48e..9fbf89cf2012 100644
--- a/devel/p5-File-Random/Makefile
+++ b/devel/p5-File-Random/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module for random selecting of a file
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Want.pm:${PORTSDIR}/devel/p5-Want \
+BUILD_DEPENDS= p5-Want>=0:${PORTSDIR}/devel/p5-Want \
p5-Set-Scalar>0:${PORTSDIR}/devel/p5-Set-Scalar
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Class>=0.03:${PORTSDIR}/devel/p5-Test-Class \
diff --git a/devel/p5-Heap-Simple-Perl/Makefile b/devel/p5-Heap-Simple-Perl/Makefile
index 632f1c6c56f6..ddd327b767ac 100644
--- a/devel/p5-Heap-Simple-Perl/Makefile
+++ b/devel/p5-Heap-Simple-Perl/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A pure perl implementation of the Heap::Simple interface
-BUILD_DEPENDS= ${SITE_PERL}/Heap/Simple.pm:${PORTSDIR}/devel/p5-Heap-Simple
+BUILD_DEPENDS= p5-Heap-Simple>=0:${PORTSDIR}/devel/p5-Heap-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Heap-Simple-XS/Makefile b/devel/p5-Heap-Simple-XS/Makefile
index 21d17a900ecb..2a179fb22249 100644
--- a/devel/p5-Heap-Simple-XS/Makefile
+++ b/devel/p5-Heap-Simple-XS/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= An XS implementation of the Heap::Simple interface
-BUILD_DEPENDS= ${SITE_PERL}/Heap/Simple.pm:${PORTSDIR}/devel/p5-Heap-Simple
+BUILD_DEPENDS= p5-Heap-Simple>=0:${PORTSDIR}/devel/p5-Heap-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-IPC-Cache/Makefile b/devel/p5-IPC-Cache/Makefile
index 6043b0bf5ed1..7c7643119044 100644
--- a/devel/p5-IPC-Cache/Makefile
+++ b/devel/p5-IPC-Cache/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Persist data across processes via shared memory
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IPC/ShareLite.pm:${PORTSDIR}/devel/p5-IPC-ShareLite
+BUILD_DEPENDS= p5-IPC-ShareLite>=0:${PORTSDIR}/devel/p5-IPC-ShareLite
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-POE-Component-IKC/Makefile b/devel/p5-POE-Component-IKC/Makefile
index e9334756f8b5..748217f9c44e 100644
--- a/devel/p5-POE-Component-IKC/Makefile
+++ b/devel/p5-POE-Component-IKC/Makefile
@@ -14,14 +14,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= POE Inter-Kernel Communication
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/POE/API/Peek.pm:${PORTSDIR}/devel/p5-POE-API-Peek \
- ${SITE_PERL}/POE/Component/Daemon.pm:${PORTSDIR}/devel/p5-POE-Component-Daemon \
- ${SITE_PERL}/${PERL_ARCH}/Proc/ProcessTable.pm:${PORTSDIR}/devel/p5-Proc-ProcessTable
-RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/POE/API/Peek.pm:${PORTSDIR}/devel/p5-POE-API-Peek \
- ${SITE_PERL}/POE/Component/Daemon.pm:${PORTSDIR}/devel/p5-POE-Component-Daemon \
- ${SITE_PERL}/${PERL_ARCH}/Proc/ProcessTable.pm:${PORTSDIR}/devel/p5-Proc-ProcessTable
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-API-Peek>=0:${PORTSDIR}/devel/p5-POE-API-Peek \
+ p5-POE-Component-Daemon>=0:${PORTSDIR}/devel/p5-POE-Component-Daemon \
+ p5-Proc-ProcessTable>=0:${PORTSDIR}/devel/p5-Proc-ProcessTable
+RUN_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-API-Peek>=0:${PORTSDIR}/devel/p5-POE-API-Peek \
+ p5-POE-Component-Daemon>=0:${PORTSDIR}/devel/p5-POE-Component-Daemon \
+ p5-Proc-ProcessTable>=0:${PORTSDIR}/devel/p5-Proc-ProcessTable
PERL_CONFIGURE= yes
diff --git a/devel/p5-PV/Makefile b/devel/p5-PV/Makefile
index bd47987e412d..afbe31d923b3 100644
--- a/devel/p5-PV/Makefile
+++ b/devel/p5-PV/Makefile
@@ -15,7 +15,7 @@ DISTNAME= PerlVision-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A perl5 library for text-mode user interface widgets
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Curses.pm:${PORTSDIR}/devel/p5-Curses
+RUN_DEPENDS= p5-Curses>=0:${PORTSDIR}/devel/p5-Curses
USE_PERL5= YES
diff --git a/devel/p5-Penguin-Easy/Makefile b/devel/p5-Penguin-Easy/Makefile
index 61d823d53bf7..bedf5e46c630 100644
--- a/devel/p5-Penguin-Easy/Makefile
+++ b/devel/p5-Penguin-Easy/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A quick and easy implementation of the p5-Penguin module
-BUILD_DEPENDS= ${SITE_PERL}/Penguin.pm:${PORTSDIR}/devel/p5-Penguin
+BUILD_DEPENDS= p5-Penguin>=0:${PORTSDIR}/devel/p5-Penguin
PERL_CONFIGURE= YES
diff --git a/devel/p5-Shell-Base/Makefile b/devel/p5-Shell-Base/Makefile
index c5c5103666fd..472bebfb7df1 100644
--- a/devel/p5-Shell-Base/Makefile
+++ b/devel/p5-Shell-Base/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module implementing a simple command shell
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/Size.pm:${PORTSDIR}/devel/p5-Term-Size \
- ${SITE_PERL}/Text/Shellwords.pm:${PORTSDIR}/textproc/p5-Text-Shellwords
+BUILD_DEPENDS= p5-Term-Size>=0:${PORTSDIR}/devel/p5-Term-Size \
+ p5-Text-Shellwords>=0:${PORTSDIR}/textproc/p5-Text-Shellwords
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Tree-Parser/Makefile b/devel/p5-Tree-Parser/Makefile
index a84e43ff9b24..1189d799dfa2 100644
--- a/devel/p5-Tree-Parser/Makefile
+++ b/devel/p5-Tree-Parser/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Module to parse formatted files into tree structures
-BUILD_DEPENDS= ${SITE_PERL}/Array/Iterator.pm:${PORTSDIR}/devel/p5-Array-Iterator \
- ${SITE_PERL}/Tree/Simple.pm:${PORTSDIR}/devel/p5-Tree-Simple \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+BUILD_DEPENDS= p5-Array-Iterator>=0:${PORTSDIR}/devel/p5-Array-Iterator \
+ p5-Tree-Simple>=0:${PORTSDIR}/devel/p5-Tree-Simple \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception