aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-18 21:09:48 +0800
committertijl <tijl@FreeBSD.org>2014-09-18 21:09:48 +0800
commit486069f70fc081b5d6b79472e25775ad9aedf75f (patch)
tree3330d0d2e4367193cb8e92e4fcd408cfa6c61bac /devel
parent96eb2c47b80f9a54c75ae4b5645ade3402058c9b (diff)
downloadfreebsd-ports-gnome-486069f70fc081b5d6b79472e25775ad9aedf75f.tar.gz
freebsd-ports-gnome-486069f70fc081b5d6b79472e25775ad9aedf75f.tar.zst
freebsd-ports-gnome-486069f70fc081b5d6b79472e25775ad9aedf75f.zip
- Remove old libtool patches and add INSTALL_TARGET=install-strip
- Auto-detect MMX support
Diffstat (limited to 'devel')
-rw-r--r--devel/libast/Makefile14
-rw-r--r--devel/libast/files/patch-configure10
2 files changed, 5 insertions, 19 deletions
diff --git a/devel/libast/Makefile b/devel/libast/Makefile
index 702961ee3a2a..8bcd356032ee 100644
--- a/devel/libast/Makefile
+++ b/devel/libast/Makefile
@@ -18,17 +18,13 @@ LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
USE_EFL= imlib2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USES= libtool pathfix
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_MMX) && (${ARCH} == "i386")
-CONFIGURE_ARGS= --enable-mmx
+.if defined(MACHINE_CPU) && ${MACHINE_CPU:Mmmx}
+CONFIGURE_ARGS+=--enable-mmx
.endif
-post-build:
- @${STRIP_CMD} ${WRKSRC}/src/.libs/libast.so.2
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libast/files/patch-configure b/devel/libast/files/patch-configure
deleted file mode 100644
index 3ef3efc664cf..000000000000
--- a/devel/libast/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Sun Feb 20 22:40:43 2005
-+++ configure Sun Feb 20 22:42:44 2005
-@@ -5696,6 +5696,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'