aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2013-10-30 15:13:02 +0800
committerGanael LAPLANCHE <martymac@FreeBSD.org>2013-10-30 15:13:02 +0800
commit4a37934f8aa55fe9307a03adeff1a807fdfdd285 (patch)
treefe1d2a1236a4ba0568dce4c4e613a5120172cbde /devel
parentdb47c51e977f7f490601fb195788f2678263873d (diff)
downloadfreebsd-ports-gnome-4a37934f8aa55fe9307a03adeff1a807fdfdd285.tar.gz
freebsd-ports-gnome-4a37934f8aa55fe9307a03adeff1a807fdfdd285.tar.zst
freebsd-ports-gnome-4a37934f8aa55fe9307a03adeff1a807fdfdd285.zip
- Update Simgear and Flightgear ports to 2.12.0
- Enable staging - Switch to new LIB_DEPENDS format - Refresh Simgear's pkg-descr
Diffstat (limited to 'devel')
-rw-r--r--devel/simgear/Makefile10
-rw-r--r--devel/simgear/distinfo4
-rw-r--r--devel/simgear/pkg-descr16
-rw-r--r--devel/simgear/pkg-plist227
4 files changed, 140 insertions, 117 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 89e259c39b93..94c910a943f6 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= simgear
-PORTVERSION= 2.10.0
+PORTVERSION= 2.12.0
CATEGORIES= devel games
MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/simgear/ftp/Source/ \
ftp://ftp.de.flightgear.org/pub/simgear/Source/ \
@@ -15,17 +15,15 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- osg:${PORTSDIR}/graphics/osg
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libosg.so:${PORTSDIR}/graphics/osg
USE_BZIP2= yes
-USE_GCC= any
USE_XORG= ice sm x11 xext xi xt xmu
USE_OPENAL= al alut
USE_GL= gl glu glut
USES= cmake
CMAKE_ARGS+= -DJPEG_FACTORY:BOOL=ON
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/simgear/distinfo b/devel/simgear/distinfo
index 0fee0e805290..d1b8d61ed72c 100644
--- a/devel/simgear/distinfo
+++ b/devel/simgear/distinfo
@@ -1,2 +1,2 @@
-SHA256 (simgear-2.10.0.tar.bz2) = 582c0d547a58f7dbe841a0ba9eba5a894aae2b65f14ef06361e196b12022615d
-SIZE (simgear-2.10.0.tar.bz2) = 879537
+SHA256 (simgear-2.12.0.tar.bz2) = 8e90c4b2f72f6459c6f5125bcd1f16b5d4604af1ff404ab436a966349d32f46a
+SIZE (simgear-2.12.0.tar.bz2) = 961978
diff --git a/devel/simgear/pkg-descr b/devel/simgear/pkg-descr
index 37194c083786..461c1d0f9f1d 100644
--- a/devel/simgear/pkg-descr
+++ b/devel/simgear/pkg-descr
@@ -1,12 +1,8 @@
-SimGear is a set of open-source libraries designed to be used as
-building blocks for quickly assembling 3d simulations, games, and
-visualization applications.
+SimGear is a set of open-source libraries designed to be used as building
+blocks for quickly assembling 3d simulations, games, and visualization
+applications.
-SimGear is a relatively new project, and while quite a bit of code has
-been written in conjunction with the FlightGear project, the final
-interface and arrangements are still evolving.
+SimGear is developed by the FlightGear project and also provides the base for
+the FlightGear Flight Simulator.
-The term "Simulation Kernel" is a bit presumptuous for us at this
-point, but this is the direction we are heading with SimGear.
-
-WWW: http://www.simgear.org/
+WWW: http://www.flightgear.org/
diff --git a/devel/simgear/pkg-plist b/devel/simgear/pkg-plist
index 225f4d3b5c3b..27c2db51bcca 100644
--- a/devel/simgear/pkg-plist
+++ b/devel/simgear/pkg-plist
@@ -1,53 +1,55 @@
-include/simgear/simgear_config.h
-include/simgear/compiler.h
-include/simgear/constants.h
-include/simgear/sg_inlines.h
-include/simgear/version.h
include/simgear/bucket/newbucket.hxx
-include/simgear/bvh/BVHPageNode.hxx
+include/simgear/bvh/BVHBoundingBoxVisitor.hxx
+include/simgear/bvh/BVHGroup.hxx
+include/simgear/bvh/BVHLineGeometry.hxx
+include/simgear/bvh/BVHLineSegmentVisitor.hxx
+include/simgear/bvh/BVHMaterial.hxx
+include/simgear/bvh/BVHMotionTransform.hxx
include/simgear/bvh/BVHNearestPointVisitor.hxx
+include/simgear/bvh/BVHNode.hxx
+include/simgear/bvh/BVHPageNode.hxx
+include/simgear/bvh/BVHPageRequest.hxx
+include/simgear/bvh/BVHPager.hxx
+include/simgear/bvh/BVHStaticBinary.hxx
+include/simgear/bvh/BVHStaticData.hxx
+include/simgear/bvh/BVHStaticGeometry.hxx
include/simgear/bvh/BVHStaticGeometryBuilder.hxx
include/simgear/bvh/BVHStaticLeaf.hxx
-include/simgear/bvh/BVHStaticData.hxx
-include/simgear/bvh/BVHPager.hxx
-include/simgear/bvh/BVHVisitor.hxx
-include/simgear/bvh/BVHBoundingBoxVisitor.hxx
-include/simgear/bvh/BVHTransform.hxx
-include/simgear/bvh/BVHStaticTriangle.hxx
include/simgear/bvh/BVHStaticNode.hxx
-include/simgear/bvh/BVHNode.hxx
-include/simgear/bvh/BVHMaterial.hxx
-include/simgear/bvh/BVHLineSegmentVisitor.hxx
+include/simgear/bvh/BVHStaticTriangle.hxx
include/simgear/bvh/BVHSubTreeCollector.hxx
-include/simgear/bvh/BVHPageRequest.hxx
-include/simgear/bvh/BVHStaticGeometry.hxx
-include/simgear/bvh/BVHGroup.hxx
-include/simgear/bvh/BVHMotionTransform.hxx
-include/simgear/bvh/BVHStaticBinary.hxx
-include/simgear/bvh/BVHLineGeometry.hxx
-include/simgear/canvas/CanvasMgr.hxx
+include/simgear/bvh/BVHTransform.hxx
+include/simgear/bvh/BVHVisitor.hxx
include/simgear/canvas/Canvas.hxx
-include/simgear/canvas/canvas_fwd.hxx
-include/simgear/canvas/ShivaVG/vgu.h
-include/simgear/canvas/ShivaVG/openvg.h
-include/simgear/canvas/elements/CanvasGroup.hxx
-include/simgear/canvas/elements/CanvasText.hxx
-include/simgear/canvas/elements/CanvasMap.hxx
-include/simgear/canvas/elements/CanvasImage.hxx
-include/simgear/canvas/elements/CanvasPath.hxx
-include/simgear/canvas/elements/CanvasElement.hxx
+include/simgear/canvas/CanvasEvent.hxx
+include/simgear/canvas/CanvasEventListener.hxx
+include/simgear/canvas/CanvasEventManager.hxx
+include/simgear/canvas/CanvasEventTypes.hxx
+include/simgear/canvas/CanvasEventVisitor.hxx
+include/simgear/canvas/CanvasMgr.hxx
+include/simgear/canvas/CanvasObjectPlacement.hxx
include/simgear/canvas/CanvasPlacement.hxx
-include/simgear/canvas/ODGauge.hxx
include/simgear/canvas/CanvasSystemAdapter.hxx
include/simgear/canvas/MouseEvent.hxx
-include/simgear/canvas/CanvasEventListener.hxx
-include/simgear/canvas/CanvasEventVisitor.hxx
-include/simgear/canvas/CanvasEventManager.hxx
+include/simgear/canvas/ODGauge.hxx
+include/simgear/canvas/ShivaVG/openvg.h
+include/simgear/canvas/ShivaVG/vgu.h
include/simgear/canvas/VGInitOperation.hxx
-include/simgear/canvas/CanvasEventTypes.hxx
-include/simgear/canvas/CanvasEvent.hxx
+include/simgear/canvas/canvas_fwd.hxx
+include/simgear/canvas/elements/CanvasElement.hxx
+include/simgear/canvas/elements/CanvasGroup.hxx
+include/simgear/canvas/elements/CanvasImage.hxx
+include/simgear/canvas/elements/CanvasMap.hxx
+include/simgear/canvas/elements/CanvasPath.hxx
+include/simgear/canvas/elements/CanvasText.hxx
+include/simgear/canvas/elements/detail/add_segment_variadic.hxx
+include/simgear/compiler.h
+include/simgear/constants.h
+include/simgear/debug/BufferedLogCallback.hxx
include/simgear/debug/debug_types.h
include/simgear/debug/logstream.hxx
+include/simgear/environment/metar.hxx
+include/simgear/environment/precipitation.hxx
include/simgear/ephemeris/celestialBody.hxx
include/simgear/ephemeris/ephemeris.hxx
include/simgear/ephemeris/jupiter.hxx
@@ -61,6 +63,12 @@ include/simgear/ephemeris/star.hxx
include/simgear/ephemeris/stardata.hxx
include/simgear/ephemeris/uranus.hxx
include/simgear/ephemeris/venus.hxx
+include/simgear/io/DAVMultiStatus.hxx
+include/simgear/io/HTTPClient.hxx
+include/simgear/io/HTTPRequest.hxx
+include/simgear/io/SVNDirectory.hxx
+include/simgear/io/SVNReportParser.hxx
+include/simgear/io/SVNRepository.hxx
include/simgear/io/iochannel.hxx
include/simgear/io/lowlevel.hxx
include/simgear/io/raw_socket.hxx
@@ -72,10 +80,8 @@ include/simgear/io/sg_netChat.hxx
include/simgear/io/sg_serial.hxx
include/simgear/io/sg_socket.hxx
include/simgear/io/sg_socket_udp.hxx
-include/simgear/io/HTTPClient.hxx
-include/simgear/io/HTTPRequest.hxx
-include/simgear/magvar/magvar.hxx
include/simgear/magvar/coremag.hxx
+include/simgear/magvar/magvar.hxx
include/simgear/math/SGBox.hxx
include/simgear/math/SGCMath.hxx
include/simgear/math/SGGeoc.hxx
@@ -86,6 +92,7 @@ include/simgear/math/SGGeometryFwd.hxx
include/simgear/math/SGIntersect.hxx
include/simgear/math/SGLimits.hxx
include/simgear/math/SGLineSegment.hxx
+include/simgear/math/SGLocation.hxx
include/simgear/math/SGMath.hxx
include/simgear/math/SGMathFwd.hxx
include/simgear/math/SGMatrix.hxx
@@ -93,6 +100,7 @@ include/simgear/math/SGMisc.hxx
include/simgear/math/SGPlane.hxx
include/simgear/math/SGQuat.hxx
include/simgear/math/SGRay.hxx
+include/simgear/math/SGRect.hxx
include/simgear/math/SGSphere.hxx
include/simgear/math/SGTriangle.hxx
include/simgear/math/SGVec2.hxx
@@ -102,12 +110,13 @@ include/simgear/math/beziercurve.hxx
include/simgear/math/interpolater.hxx
include/simgear/math/leastsqs.hxx
include/simgear/math/sg_geodesy.hxx
-include/simgear/math/sg_types.hxx
include/simgear/math/sg_random.h
-include/simgear/math/SGRect.hxx
-include/simgear/math/SGLocation.hxx
+include/simgear/math/sg_types.hxx
+include/simgear/misc/CSSBorder.hxx
include/simgear/misc/ResourceManager.hxx
+include/simgear/misc/gzcontainerfile.hxx
include/simgear/misc/interpolator.hxx
+include/simgear/misc/make_new.hxx
include/simgear/misc/sg_dir.hxx
include/simgear/misc/sg_path.hxx
include/simgear/misc/sgstream.hxx
@@ -117,63 +126,37 @@ include/simgear/misc/strutils.hxx
include/simgear/misc/tabbed_values.hxx
include/simgear/misc/texcoord.hxx
include/simgear/misc/zfstream.hxx
-include/simgear/misc/gzcontainerfile.hxx
-include/simgear/nasal/naref.h
-include/simgear/nasal/nasal.h
include/simgear/nasal/cppbind/Ghost.hxx
+include/simgear/nasal/cppbind/NasalCallContext.hxx
include/simgear/nasal/cppbind/NasalHash.hxx
-include/simgear/nasal/cppbind/to_nasal.hxx
-include/simgear/nasal/cppbind/from_nasal_detail.hxx
+include/simgear/nasal/cppbind/NasalString.hxx
+include/simgear/nasal/cppbind/detail/from_nasal_helper.hxx
+include/simgear/nasal/cppbind/detail/functor_templates.hxx
+include/simgear/nasal/cppbind/detail/nasal_traits.hxx
+include/simgear/nasal/cppbind/detail/to_nasal_helper.hxx
include/simgear/nasal/cppbind/from_nasal.hxx
-include/simgear/nasal/cppbind/nasal_traits.hxx
+include/simgear/nasal/cppbind/to_nasal.hxx
+include/simgear/nasal/naref.h
+include/simgear/nasal/nasal.h
+include/simgear/package/Catalog.hxx
+include/simgear/package/Delegate.hxx
+include/simgear/package/Install.hxx
+include/simgear/package/Package.hxx
+include/simgear/package/Root.hxx
include/simgear/props/AtomicChangeListener.hxx
include/simgear/props/ExtendedPropertyAdapter.hxx
+include/simgear/props/PropertyBasedElement.hxx
+include/simgear/props/PropertyBasedMgr.hxx
+include/simgear/props/PropertyInterpolationMgr.hxx
+include/simgear/props/PropertyInterpolator.hxx
include/simgear/props/condition.hxx
+include/simgear/props/easing_functions.hxx
include/simgear/props/propertyObject.hxx
include/simgear/props/props.hxx
include/simgear/props/props_io.hxx
include/simgear/props/propsfwd.hxx
include/simgear/props/tiedpropertylist.hxx
include/simgear/props/vectorPropTemplates.hxx
-include/simgear/props/PropertyBasedMgr.hxx
-include/simgear/props/PropertyBasedElement.hxx
-include/simgear/serial/serial.hxx
-include/simgear/structure/OSGUtils.hxx
-include/simgear/structure/OSGVersion.hxx
-include/simgear/structure/SGAtomic.hxx
-include/simgear/structure/SGBinding.hxx
-include/simgear/structure/SGExpression.hxx
-include/simgear/structure/SGReferenced.hxx
-include/simgear/structure/SGSharedPtr.hxx
-include/simgear/structure/SGSmplhist.hxx
-include/simgear/structure/SGSmplstat.hxx
-include/simgear/structure/SGWeakPtr.hxx
-include/simgear/structure/SGWeakReferenced.hxx
-include/simgear/structure/SGPerfMon.hxx
-include/simgear/structure/singleton.hpp
-include/simgear/structure/Singleton.hxx
-include/simgear/structure/StringTable.hxx
-include/simgear/structure/callback.hxx
-include/simgear/structure/commands.hxx
-include/simgear/structure/event_mgr.hxx
-include/simgear/structure/exception.hxx
-include/simgear/structure/intern.hxx
-include/simgear/structure/subsystem_mgr.hxx
-include/simgear/threads/SGGuard.hxx
-include/simgear/threads/SGQueue.hxx
-include/simgear/threads/SGThread.hxx
-include/simgear/timing/sg_time.hxx
-include/simgear/timing/timestamp.hxx
-include/simgear/timing/timezone.h
-include/simgear/timing/lowleveltime.h
-include/simgear/xml/easyxml.hxx
-include/simgear/environment/metar.hxx
-include/simgear/environment/precipitation.hxx
-include/simgear/screen/colors.hxx
-include/simgear/screen/extensions.hxx
-include/simgear/screen/screen-dump.hxx
-include/simgear/screen/tr.h
-include/simgear/screen/jpgfactory.hxx
include/simgear/scene/material/Effect.hxx
include/simgear/scene/material/EffectBuilder.hxx
include/simgear/scene/material/EffectCullVisitor.hxx
@@ -186,18 +169,24 @@ include/simgear/scene/material/mat.hxx
include/simgear/scene/material/matlib.hxx
include/simgear/scene/material/matmodel.hxx
include/simgear/scene/material/mipmap.hxx
+include/simgear/scene/material/parseBlendFunc.hxx
+include/simgear/scene/model/BVHDebugCollectVisitor.hxx
+include/simgear/scene/model/BVHPageNodeOSG.hxx
include/simgear/scene/model/BoundingVolumeBuildVisitor.hxx
include/simgear/scene/model/CheckSceneryVisitor.hxx
include/simgear/scene/model/ConditionNode.hxx
include/simgear/scene/model/ModelRegistry.hxx
+include/simgear/scene/model/PrimitiveCollector.hxx
include/simgear/scene/model/SGClipGroup.hxx
include/simgear/scene/model/SGInteractionAnimation.hxx
include/simgear/scene/model/SGMaterialAnimation.hxx
include/simgear/scene/model/SGOffsetTransform.hxx
+include/simgear/scene/model/SGPickAnimation.hxx
include/simgear/scene/model/SGReaderWriterXML.hxx
include/simgear/scene/model/SGRotateTransform.hxx
include/simgear/scene/model/SGScaleTransform.hxx
include/simgear/scene/model/SGText.hxx
+include/simgear/scene/model/SGTrackToAnimation.hxx
include/simgear/scene/model/SGTranslateTransform.hxx
include/simgear/scene/model/animation.hxx
include/simgear/scene/model/model.hxx
@@ -205,9 +194,6 @@ include/simgear/scene/model/modellib.hxx
include/simgear/scene/model/particles.hxx
include/simgear/scene/model/persparam.hxx
include/simgear/scene/model/placement.hxx
-include/simgear/scene/model/BVHDebugCollectVisitor.hxx
-include/simgear/scene/model/BVHPageNodeOSG.hxx
-include/simgear/scene/model/PrimitiveCollector.hxx
include/simgear/scene/sky/CloudShaderGeometry.hxx
include/simgear/scene/sky/cloud.hxx
include/simgear/scene/sky/cloudfield.hxx
@@ -221,6 +207,7 @@ include/simgear/scene/sky/stars.hxx
include/simgear/scene/tgdb/GroundLightManager.hxx
include/simgear/scene/tgdb/ReaderWriterSPT.hxx
include/simgear/scene/tgdb/ReaderWriterSTG.hxx
+include/simgear/scene/tgdb/SGBuildingBin.hxx
include/simgear/scene/tgdb/SGDirectionalLightBin.hxx
include/simgear/scene/tgdb/SGLightBin.hxx
include/simgear/scene/tgdb/SGModelBin.hxx
@@ -236,10 +223,13 @@ include/simgear/scene/tgdb/apt_signs.hxx
include/simgear/scene/tgdb/obj.hxx
include/simgear/scene/tgdb/pt_lights.hxx
include/simgear/scene/tgdb/userdata.hxx
-include/simgear/scene/tgdb/SGBuildingBin.hxx
+include/simgear/scene/tsync/terrasync.hxx
+include/simgear/scene/util/ColorInterpolator.hxx
include/simgear/scene/util/CopyOp.hxx
+include/simgear/scene/util/DeletionManager.hxx
include/simgear/scene/util/NodeAndDrawableVisitor.hxx
include/simgear/scene/util/Noise.hxx
+include/simgear/scene/util/OptionsReadFileCallback.hxx
include/simgear/scene/util/OsgMath.hxx
include/simgear/scene/util/OsgSingleton.hxx
include/simgear/scene/util/PrimitiveUtils.hxx
@@ -259,17 +249,55 @@ include/simgear/scene/util/SplicingVisitor.hxx
include/simgear/scene/util/StateAttributeFactory.hxx
include/simgear/scene/util/UpdateOnceCallback.hxx
include/simgear/scene/util/VectorArrayAdapter.hxx
-include/simgear/scene/util/project.hxx
-include/simgear/scene/util/DeletionManager.hxx
include/simgear/scene/util/parse_color.hxx
-include/simgear/scene/util/OptionsReadFileCallback.hxx
-include/simgear/scene/tsync/terrasync.hxx
+include/simgear/scene/util/project.hxx
+include/simgear/screen/colors.hxx
+include/simgear/screen/extensions.hxx
+include/simgear/screen/jpgfactory.hxx
+include/simgear/screen/screen-dump.hxx
+include/simgear/screen/tr.h
+include/simgear/serial/serial.hxx
+include/simgear/sg_inlines.h
+include/simgear/simgear_config.h
+include/simgear/sound/readwav.hxx
include/simgear/sound/sample_group.hxx
include/simgear/sound/sample_openal.hxx
include/simgear/sound/sample_queue.hxx
include/simgear/sound/soundmgr_openal.hxx
include/simgear/sound/xmlsound.hxx
-include/simgear/sound/readwav.hxx
+include/simgear/structure/OSGUtils.hxx
+include/simgear/structure/OSGVersion.hxx
+include/simgear/structure/SGAtomic.hxx
+include/simgear/structure/SGBinding.hxx
+include/simgear/structure/SGExpression.hxx
+include/simgear/structure/SGPerfMon.hxx
+include/simgear/structure/SGReferenced.hxx
+include/simgear/structure/SGSharedPtr.hxx
+include/simgear/structure/SGSmplhist.hxx
+include/simgear/structure/SGSmplstat.hxx
+include/simgear/structure/SGWeakPtr.hxx
+include/simgear/structure/SGWeakReferenced.hxx
+include/simgear/structure/Singleton.hxx
+include/simgear/structure/StateMachine.hxx
+include/simgear/structure/StringTable.hxx
+include/simgear/structure/callback.hxx
+include/simgear/structure/commands.hxx
+include/simgear/structure/event_mgr.hxx
+include/simgear/structure/exception.hxx
+include/simgear/structure/intern.hxx
+include/simgear/structure/singleton.hpp
+include/simgear/structure/subsystem_mgr.hxx
+include/simgear/threads/SGGuard.hxx
+include/simgear/threads/SGQueue.hxx
+include/simgear/threads/SGThread.hxx
+include/simgear/timing/lowleveltime.h
+include/simgear/timing/sg_time.hxx
+include/simgear/timing/timestamp.hxx
+include/simgear/timing/timezone.h
+include/simgear/version.h
+include/simgear/xml/easyxml.hxx
+lib/libSimGearCore.a
+lib/libSimGearScene.a
@dirrm include/simgear/xml
@dirrm include/simgear/timing
@dirrm include/simgear/threads
@@ -285,6 +313,8 @@ include/simgear/sound/readwav.hxx
@dirrm include/simgear/scene/material
@dirrm include/simgear/scene
@dirrm include/simgear/props
+@dirrm include/simgear/package
+@dirrm include/simgear/nasal/cppbind/detail
@dirrm include/simgear/nasal/cppbind
@dirrm include/simgear/nasal
@dirrm include/simgear/misc
@@ -294,11 +324,10 @@ include/simgear/sound/readwav.hxx
@dirrm include/simgear/ephemeris
@dirrm include/simgear/environment
@dirrm include/simgear/debug
+@dirrm include/simgear/canvas/elements/detail
@dirrm include/simgear/canvas/elements
@dirrm include/simgear/canvas/ShivaVG
@dirrm include/simgear/canvas
@dirrm include/simgear/bvh
@dirrm include/simgear/bucket
@dirrm include/simgear
-lib/libSimGearCore.a
-lib/libSimGearScene.a