aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2016-08-05 17:09:56 +0800
committerdanfe <danfe@FreeBSD.org>2016-08-05 17:09:56 +0800
commit4ae8221476ea52bf5177f1f083634a5ed200d78b (patch)
tree0acd9e3d0a3090c192464f09b3cff6da5f02a1bb /devel
parent1af2391fd3b0a2a7cad3f9614de3d70b8572720f (diff)
downloadfreebsd-ports-gnome-4ae8221476ea52bf5177f1f083634a5ed200d78b.tar.gz
freebsd-ports-gnome-4ae8221476ea52bf5177f1f083634a5ed200d78b.tar.zst
freebsd-ports-gnome-4ae8221476ea52bf5177f1f083634a5ed200d78b.zip
Add a port of Shed Skin, an experimental compiler that can translate pure,
but implicitly statically typed Python programs into optimized C++. While here, sort entries in `devel/Makefile' (once again). PR: 211572
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile7
-rw-r--r--devel/shedskin/Makefile39
-rw-r--r--devel/shedskin/distinfo2
-rw-r--r--devel/shedskin/pkg-descr11
4 files changed, 56 insertions, 3 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 70d4e3fa0d8c..f3288637cd13 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -56,9 +56,9 @@
SUBDIR += acsccid
SUBDIR += activitymail
SUBDIR += ada-util
- SUBDIR += adaid
SUBDIR += adabooch
SUBDIR += adacurses
+ SUBDIR += adaid
SUBDIR += adime
SUBDIR += aegis
SUBDIR += afay
@@ -4217,8 +4217,8 @@
SUBDIR += py-lock_file
SUBDIR += py-lockfile
SUBDIR += py-log4py
- SUBDIR += py-logbook
SUBDIR += py-logan
+ SUBDIR += py-logbook
SUBDIR += py-logilab-common
SUBDIR += py-louie
SUBDIR += py-lxml
@@ -5303,6 +5303,7 @@
SUBDIR += sfml1
SUBDIR += sgb
SUBDIR += shapelib
+ SUBDIR += shedskin
SUBDIR += shflags
SUBDIR += shiboken
SUBDIR += shmap
@@ -5317,8 +5318,8 @@
SUBDIR += simian
SUBDIR += simple_components
SUBDIR += skalibs
- SUBDIR += slibtool
SUBDIR += slf4j
+ SUBDIR += slibtool
SUBDIR += smack
SUBDIR += smake
SUBDIR += smc
diff --git a/devel/shedskin/Makefile b/devel/shedskin/Makefile
new file mode 100644
index 000000000000..e7bd5f6ee468
--- /dev/null
+++ b/devel/shedskin/Makefile
@@ -0,0 +1,39 @@
+# Created by: lightside <lightside@gmx.com>
+# $FreeBSD$
+
+PORTNAME= shedskin
+PORTVERSION= 0.9.4
+DISTVERSIONPREFIX= v
+CATEGORIES= devel python
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Experimental (restricted) Python-to-C++ compiler
+
+LICENSE= GPLv3 MIT BSD3CLAUSE
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv3= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${LOCALBASE}/lib/libgc.so:devel/boehm-gc \
+ ${LOCALBASE}/lib/libpcre.so:devel/pcre
+
+USE_GITHUB= yes
+
+USES= python:2
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CC/s|g++|$$(CXX)| ; \
+ /^CCFLAGS/s|-O2 -march=native|$$(CXXFLAGS) -I${LOCALBASE}/include| ; \
+ /^LFLAGS/s|=|&-L${LOCALBASE}/lib |' \
+ ${WRKSRC}/shedskin/FLAGS
+
+do-install-EXAMPLES-on:
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} "${PORTEXAMPLES}" \
+ ${STAGEDIR}${EXAMPLESDIR})
+
+.include <bsd.port.mk>
diff --git a/devel/shedskin/distinfo b/devel/shedskin/distinfo
new file mode 100644
index 000000000000..a8731a2c14b4
--- /dev/null
+++ b/devel/shedskin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (shedskin-shedskin-v0.9.4_GH0.tar.gz) = 955b4a4d33a2daa31ecd8dfe4e2ff610ae9101d90b6e484267d57d640d04d11d
+SIZE (shedskin-shedskin-v0.9.4_GH0.tar.gz) = 28241490
diff --git a/devel/shedskin/pkg-descr b/devel/shedskin/pkg-descr
new file mode 100644
index 000000000000..4eeae10319b5
--- /dev/null
+++ b/devel/shedskin/pkg-descr
@@ -0,0 +1,11 @@
+Shed Skin is an experimental compiler, that can translate pure, but implicitly
+statically typed Python (2.4-2.6) programs into optimized C++. It can generate
+stand-alone programs or extension modules that can be imported and used in
+larger Python programs.
+
+Besides the typing restriction, programs cannot freely use the Python standard
+library (although about 25 common modules, such as `random' and `re', are
+currently supported). Also, not all Python features, such as nested functions
+and variable numbers of arguments, are supported.
+
+WWW: http://shedskin.github.io/