aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-08 06:55:34 +0800
committerMartin Wilke <miwi@FreeBSD.org>2008-08-08 06:55:34 +0800
commit4b3512397eacc804608b0c9e6e92bf3d4ae4a647 (patch)
treee70f8f7334497445d648cd52d346145d488e7ffc /devel
parent95097a75f0a37f9c24030e845f66d5d0a54aaf77 (diff)
downloadfreebsd-ports-gnome-4b3512397eacc804608b0c9e6e92bf3d4ae4a647.tar.gz
freebsd-ports-gnome-4b3512397eacc804608b0c9e6e92bf3d4ae4a647.tar.zst
freebsd-ports-gnome-4b3512397eacc804608b0c9e6e92bf3d4ae4a647.zip
Warbler is a gem to make a .war file out of a Rails project. The intent is
to provide a minimal, flexible, ruby-like way to bundle up all of your application files for deployment to a Java application server. Warbler provides a sane set of out-of-the box defaults that should allow most Rails applications without external gem dependencies (aside from Rails itself) to assemble and Just Work. Warbler bundles JRuby and the JRuby-Rack servlet adapter for dispatching requests to your application inside the java application server, and assembles all jar files in WARBLER_HOME/lib/*.jar into your application. No external dependencies are downloaded. WWW: http://caldersphere.rubyforge.org/warbler/ PR: ports/126327 Submitted by: Alexander Logvinov <ports at logvinov,com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-warbler/Makefile31
-rw-r--r--devel/rubygem-warbler/distinfo3
-rw-r--r--devel/rubygem-warbler/pkg-descr14
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6e639187f0bd..c1b45439ab6d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2375,6 +2375,7 @@
SUBDIR += rubygem-stream
SUBDIR += rubygem-transactionsimple
SUBDIR += rubygem-tzinfo
+ SUBDIR += rubygem-warbler
SUBDIR += rubygem-zentest
SUBDIR += rudeconfig
SUBDIR += rudiments
diff --git a/devel/rubygem-warbler/Makefile b/devel/rubygem-warbler/Makefile
new file mode 100644
index 000000000000..5cbb9c145837
--- /dev/null
+++ b/devel/rubygem-warbler/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: rubygem-warbler
+# Date created: 23 July 2008
+# Whom: Alexander Logvinov <ports@logvinov,com>
+#
+# $FreeBSD$
+
+PORTNAME= warbler
+PORTVERSION= 0.9.10
+CATEGORIES= devel rubygems java
+MASTER_SITES= RF
+MASTER_SITE_SUBDIR= caldersphere
+
+MAINTAINER= ports@logvinov.com
+COMMENT= A constructor of .war files of Rails applications
+
+RUN_DEPENDS= jruby:${PORTSDIR}/lang/jruby
+
+USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
+
+post-install:
+ @${ECHO} bin/warble > ${TMPPLIST}
+ @${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-warbler/distinfo b/devel/rubygem-warbler/distinfo
new file mode 100644
index 000000000000..e9d6637ac609
--- /dev/null
+++ b/devel/rubygem-warbler/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/warbler-0.9.10.gem) = 40d54d1540dc8e48a60f4741af43d613
+SHA256 (rubygem/warbler-0.9.10.gem) = 43da34e57c672d875dea7f4cc73645cf70ca3c1ef73e8a2485a72b225cf9030d
+SIZE (rubygem/warbler-0.9.10.gem) = 6614528
diff --git a/devel/rubygem-warbler/pkg-descr b/devel/rubygem-warbler/pkg-descr
new file mode 100644
index 000000000000..fd0892e4f716
--- /dev/null
+++ b/devel/rubygem-warbler/pkg-descr
@@ -0,0 +1,14 @@
+Warbler is a gem to make a .war file out of a Rails project. The intent is
+to provide a minimal, flexible, ruby-like way to bundle up all of your
+application files for deployment to a Java application server.
+
+Warbler provides a sane set of out-of-the box defaults that should allow
+most Rails applications without external gem dependencies
+(aside from Rails itself) to assemble and Just Work.
+
+Warbler bundles JRuby and the JRuby-Rack servlet adapter for
+dispatching requests to your application inside the java application server,
+and assembles all jar files in WARBLER_HOME/lib/*.jar into your application.
+No external dependencies are downloaded.
+
+WWW: http://caldersphere.rubyforge.org/warbler/