aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-09 23:55:47 +0800
committeraz <az@FreeBSD.org>2013-09-09 23:55:47 +0800
commit4d8954e6f19e693ed343488dd97901f7954bfe17 (patch)
tree58d6f7182c1c35b5cf0cec260e020030eb4f45b1 /devel
parent3df8b88b03abc659e832d5b7ae106c1414b1156d (diff)
downloadfreebsd-ports-gnome-4d8954e6f19e693ed343488dd97901f7954bfe17.tar.gz
freebsd-ports-gnome-4d8954e6f19e693ed343488dd97901f7954bfe17.tar.zst
freebsd-ports-gnome-4d8954e6f19e693ed343488dd97901f7954bfe17.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'devel')
-rw-r--r--devel/cvs2cl/Makefile8
-rw-r--r--devel/p5-AnyEvent-DBus/Makefile9
-rw-r--r--devel/p5-B-Hooks-OP-Check-EntersubForCV/Makefile8
-rw-r--r--devel/p5-Dancer-Debug/Makefile9
-rw-r--r--devel/p5-Devel-CheckLib/Makefile3
-rw-r--r--devel/p5-Eval-Context/Makefile3
-rw-r--r--devel/p5-IO-HTML/Makefile3
-rw-r--r--devel/p5-List-Uniq/Makefile9
-rw-r--r--devel/p5-Metabase-Fact/Makefile9
-rw-r--r--devel/p5-MooseX-Types-JSON/Makefile9
-rw-r--r--devel/p5-MouseX-Types-Path-Class/Makefile9
-rw-r--r--devel/p5-Proc-WaitStat/Makefile9
-rw-r--r--devel/p5-SVN-Notify-Filter-AuthZMail/Makefile9
-rw-r--r--devel/p5-SVN-Notify-Filter-EmailFlatFileDB/Makefile9
-rw-r--r--devel/p5-Sub-Signatures/Makefile3
-rw-r--r--devel/p5-Test-Debugger/Makefile9
-rw-r--r--devel/p5-Test-YAML-Meta/Makefile3
-rw-r--r--devel/p5-Tie-Hash-Regex/Makefile9
-rw-r--r--devel/p5-Time-Stopwatch/Makefile9
19 files changed, 50 insertions, 89 deletions
diff --git a/devel/cvs2cl/Makefile b/devel/cvs2cl/Makefile
index f05014cf05c5..0c9c7159f3a3 100644
--- a/devel/cvs2cl/Makefile
+++ b/devel/cvs2cl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvs2cl
-# Date created: 6 June 2000
-# Whom: knu@FreeBSD.org
-#
+# Created by: knu@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= cvs2cl
PORTVERSION= 2.73
@@ -18,7 +14,7 @@ EXTRACT_ONLY= # none
MAINTAINER= mva@FreeBSD.org
COMMENT= CVS-log-message-to-ChangeLog conversion script
-USE_PERL5= yes
+USES= perl5
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/devel/p5-AnyEvent-DBus/Makefile b/devel/p5-AnyEvent-DBus/Makefile
index c49bc1e408fc..5730ffeba7fb 100644
--- a/devel/p5-AnyEvent-DBus/Makefile
+++ b/devel/p5-AnyEvent-DBus/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: AnyEvent::DBus
-# Date created: 2010-06-21
-# Whom: Sahil Tandon <sahil@FreeBSD.org>
-#
+# Created by: Sahil Tandon <sahil@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= AnyEvent-DBus
PORTVERSION= 0.31
@@ -23,6 +19,7 @@ RUN_DEPENDS= p5-AnyEvent>=5:${PORTSDIR}/devel/p5-AnyEvent \
MAN3= AnyEvent::DBus.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-B-Hooks-OP-Check-EntersubForCV/Makefile b/devel/p5-B-Hooks-OP-Check-EntersubForCV/Makefile
index f44acbdd2e46..7e004b8c1821 100644
--- a/devel/p5-B-Hooks-OP-Check-EntersubForCV/Makefile
+++ b/devel/p5-B-Hooks-OP-Check-EntersubForCV/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: B::Hooks::OP::Check::EntersubForCV
-# Date created: 22 Nov 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= B-Hooks-OP-Check-EntersubForCV
PORTVERSION= 0.09
@@ -22,7 +17,8 @@ BUILD_DEPENDS= \
p5-B-Utils>0:${PORTSDIR}/devel/p5-B-Utils \
p5-ExtUtils-Depends>0:${PORTSDIR}/devel/p5-ExtUtils-Depends
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= B::Hooks::OP::Check::EntersubForCV.3
diff --git a/devel/p5-Dancer-Debug/Makefile b/devel/p5-Dancer-Debug/Makefile
index 482abf56794f..341d710166d8 100644
--- a/devel/p5-Dancer-Debug/Makefile
+++ b/devel/p5-Dancer-Debug/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Dancer-Debug
-# Date created: 18 january 2011
-# Whom: Geistteufel <geistteufel@yahoo.fr>
-#
+# Created by: Geistteufel <geistteufel@yahoo.fr>
# $FreeBSD$
-#
PORTNAME= Dancer-Debug
PORTVERSION= 0.03
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-Class-Method-Modifiers>=0:${PORTSDIR}/devel/p5-Class-Method-Modi
p5-Dancer>=0:${PORTSDIR}/www/p5-Dancer \
p5-Plack-Middleware-Debug>=0:${PORTSDIR}/www/p5-Plack-Middleware-Debug
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Dancer::Debug.3 \
Plack::Middleware::Debug::Dancer::Logger.3 \
diff --git a/devel/p5-Devel-CheckLib/Makefile b/devel/p5-Devel-CheckLib/Makefile
index aa92e928c52a..5cfcf1fe9774 100644
--- a/devel/p5-Devel-CheckLib/Makefile
+++ b/devel/p5-Devel-CheckLib/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-IO-CaptureOutput>=1.08:${PORTSDIR}/devel/p5-IO-CaptureOutput
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= use-devel-checklib.1
MAN3= Devel::CheckLib.3
diff --git a/devel/p5-Eval-Context/Makefile b/devel/p5-Eval-Context/Makefile
index 4df728329e9b..2184914e56b2 100644
--- a/devel/p5-Eval-Context/Makefile
+++ b/devel/p5-Eval-Context/Makefile
@@ -28,7 +28,8 @@ BUILD_DEPENDS= p5-Test-Output>=0:${PORTSDIR}/devel/p5-Test-Output \
p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Eval::Context.3
diff --git a/devel/p5-IO-HTML/Makefile b/devel/p5-IO-HTML/Makefile
index 62b7fc814202..49c0c246133d 100644
--- a/devel/p5-IO-HTML/Makefile
+++ b/devel/p5-IO-HTML/Makefile
@@ -13,7 +13,8 @@ COMMENT= Open an HTML file with automatic charset detection
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IO::HTML.3
diff --git a/devel/p5-List-Uniq/Makefile b/devel/p5-List-Uniq/Makefile
index f98de688f9d5..22f9ef6b2740 100644
--- a/devel/p5-List-Uniq/Makefile
+++ b/devel/p5-List-Uniq/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-List-Uniq
-# Date created: 2009-01-09
-# Whom: Murilo Opsfelder <mopsfelder@gmail.com>
-#
+# Created by: Murilo Opsfelder <mopsfelder@gmail.com>
# $FreeBSD$
-#
PORTNAME= List-Uniq
PORTVERSION= 0.20
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mopsfelder@gmail.com
COMMENT= Extract the unique elements of a list
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= List::Uniq.3
diff --git a/devel/p5-Metabase-Fact/Makefile b/devel/p5-Metabase-Fact/Makefile
index 09bf0b3fb553..5f5977ee31d8 100644
--- a/devel/p5-Metabase-Fact/Makefile
+++ b/devel/p5-Metabase-Fact/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Metabase-Fact
-# Date created: 2011-02-05
-# Whom: Steve Wills <swills@FreeBSD.org>
-#
+# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Metabase-Fact
PORTVERSION= 0.021
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-JSON>=2.0:${PORTSDIR}/converters/p5-JSON \
p5-CPAN-DistnameInfo>0:${PORTSDIR}/devel/p5-CPAN-DistnameInfo
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= metabase-profile.1
MAN3= Metabase::Fact.3 Metabase::Resource::metabase.3 \
diff --git a/devel/p5-MooseX-Types-JSON/Makefile b/devel/p5-MooseX-Types-JSON/Makefile
index 437a4161e159..8c57161f5280 100644
--- a/devel/p5-MooseX-Types-JSON/Makefile
+++ b/devel/p5-MooseX-Types-JSON/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: MooseX-Types-JSON
-# Date created: 2011-02-17
-# Whom: milki <milki@rescomp.berkeley.edu>
-#
+# Created by: milki <milki@rescomp.berkeley.edu>
# $FreeBSD$
-#
PORTNAME= MooseX-Types-JSON
PORTVERSION= 0.02
@@ -24,7 +20,8 @@ RUN_DEPENDS= p5-Moose>=0.82:${PORTSDIR}/devel/p5-Moose \
TEST_DEPENDS= p5-Test-Pod>=1.00:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MooseX::Types::JSON.3
diff --git a/devel/p5-MouseX-Types-Path-Class/Makefile b/devel/p5-MouseX-Types-Path-Class/Makefile
index 638c0f778628..9fffb6ae09c7 100644
--- a/devel/p5-MouseX-Types-Path-Class/Makefile
+++ b/devel/p5-MouseX-Types-Path-Class/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-MouseX-Types-Path-Class
-# Date created: 2009-04-22
-# Whom: TERAMOTO Masahiro <markun@onohara.to>
-#
+# Created by: TERAMOTO Masahiro <markun@onohara.to>
# $FreeBSD$
-#
PORTNAME= MouseX-Types-Path-Class
PORTVERSION= 0.07
@@ -26,7 +22,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-UseAllModules>0:${PORTSDIR}/devel/p5-Test-UseAllModules
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MouseX::Types::Path::Class.3
diff --git a/devel/p5-Proc-WaitStat/Makefile b/devel/p5-Proc-WaitStat/Makefile
index 999cf4efce58..163093e9df5a 100644
--- a/devel/p5-Proc-WaitStat/Makefile
+++ b/devel/p5-Proc-WaitStat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Proc-WaitStat
-# Date created: Tue 02 Mar 2010
-# Whom: Alexey V. Degtyarev <alexey@renatasystems.org>
-#
+# Created by: Alexey V. Degtyarev <alexey@renatasystems.org>
# $FreeBSD$
-#
PORTNAME= Proc-WaitStat
PORTVERSION= 1.00
@@ -17,7 +13,8 @@ COMMENT= Interpret and act on wait() status values
BUILD_DEPENDS= p5-IPC-Signal>=0:${PORTSDIR}/devel/p5-IPC-Signal
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Proc::WaitStat.3
diff --git a/devel/p5-SVN-Notify-Filter-AuthZMail/Makefile b/devel/p5-SVN-Notify-Filter-AuthZMail/Makefile
index d2fe250dcf76..ffc398cbee9e 100644
--- a/devel/p5-SVN-Notify-Filter-AuthZMail/Makefile
+++ b/devel/p5-SVN-Notify-Filter-AuthZMail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: SVN-Notify-Filter-AuthZMail
-# Date created: 2008-07-21
-# Whom: glarkin@
-#
+# Created by: glarkin@
# $FreeBSD$
-#
PORTNAME= SVN-Notify-Filter-AuthZMail
PORTVERSION= 1.01
@@ -20,7 +16,8 @@ RUN_DEPENDS= p5-SVN-Notify>=2.72:${PORTSDIR}/devel/p5-SVN-Notify \
BUILD_DEPENDS= p5-SVN-Notify>=2.72:${PORTSDIR}/devel/p5-SVN-Notify \
p5-SVN-Access>=0:${PORTSDIR}/devel/p5-SVN-Access
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SVN::Notify::Filter::AuthZMail.3
diff --git a/devel/p5-SVN-Notify-Filter-EmailFlatFileDB/Makefile b/devel/p5-SVN-Notify-Filter-EmailFlatFileDB/Makefile
index 0ca9464054d9..3e452f30f500 100644
--- a/devel/p5-SVN-Notify-Filter-EmailFlatFileDB/Makefile
+++ b/devel/p5-SVN-Notify-Filter-EmailFlatFileDB/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: SVN-Notify-Filter-EmailFlatFileDB
-# Date created: 2008-07-21
-# Whom: Greg Larkin <glarkin@FreeBSD.org>
-#
+# Created by: Greg Larkin <glarkin@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= SVN-Notify-Filter-EmailFlatFileDB
PORTVERSION= 1.01
@@ -17,7 +13,8 @@ COMMENT= Converts account names to email address based on a flat-file database
RUN_DEPENDS= p5-SVN-Notify>=2.72:${PORTSDIR}/devel/p5-SVN-Notify
BUILD_DEPENDS= p5-SVN-Notify>=2.72:${PORTSDIR}/devel/p5-SVN-Notify
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SVN::Notify::Filter::EmailFlatFileDB.3
diff --git a/devel/p5-Sub-Signatures/Makefile b/devel/p5-Sub-Signatures/Makefile
index cc2bb24393c2..bb2c0b9fe7d1 100644
--- a/devel/p5-Sub-Signatures/Makefile
+++ b/devel/p5-Sub-Signatures/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Sub-Uplevel>=0.12:${PORTSDIR}/devel/p5-Sub-Uplevel
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sub::Signatures.3
diff --git a/devel/p5-Test-Debugger/Makefile b/devel/p5-Test-Debugger/Makefile
index fde094d5191a..ad96f0b38bfb 100644
--- a/devel/p5-Test-Debugger/Makefile
+++ b/devel/p5-Test-Debugger/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Test-Debugger
-# Date created: February 13, 2008
-# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
-#
+# Created by: Yen-Ming Lee <leeym@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Test-Debugger
PORTVERSION= 0.14
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= leeym@FreeBSD.org
COMMENT= Create Test Scripts which Generate Log Files
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Debugger.3
diff --git a/devel/p5-Test-YAML-Meta/Makefile b/devel/p5-Test-YAML-Meta/Makefile
index 04a8edd8b59d..1e8af7962b24 100644
--- a/devel/p5-Test-YAML-Meta/Makefile
+++ b/devel/p5-Test-YAML-Meta/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Test-YAML-Valid>=0:${PORTSDIR}/devel/p5-Test-YAML-Valid \
p5-Test-CPAN-Meta-YAML>=0.17:${PORTSDIR}/devel/p5-Test-CPAN-Meta-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::YAML::Meta.3
diff --git a/devel/p5-Tie-Hash-Regex/Makefile b/devel/p5-Tie-Hash-Regex/Makefile
index e7c587aedc1d..365ea91b66cf 100644
--- a/devel/p5-Tie-Hash-Regex/Makefile
+++ b/devel/p5-Tie-Hash-Regex/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Tie-Hash-Regex
-# Date created: 01 Jan 2007
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Tie-Hash-Regex
PORTVERSION= 1.02
@@ -19,6 +15,7 @@ RUN_DEPENDS= p5-Attribute-Handlers>=0.76:${PORTSDIR}/devel/p5-Attribute-Handlers
MAN3= Tie::Hash::Regex.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-Time-Stopwatch/Makefile b/devel/p5-Time-Stopwatch/Makefile
index 8968fe0d0694..1b3599ac2838 100644
--- a/devel/p5-Time-Stopwatch/Makefile
+++ b/devel/p5-Time-Stopwatch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Time::Stopwatch
-# Date created: 2006-11-18
-# Whom: Sulev-Madis Silber <madis555@hot.ee>
-#
+# Created by: Sulev-Madis Silber <madis555@hot.ee>
# $FreeBSD$
-#
PORTNAME= Time-Stopwatch
PORTVERSION= 1.00
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= madis555@hot.ee
COMMENT= Use tied scalars as timers
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Time::Stopwatch.3