aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-09 06:26:50 +0800
committermiwi <miwi@FreeBSD.org>2006-12-09 06:26:50 +0800
commit4e39eff6b45e9ac70da053ae2e2f0444d8dc91f2 (patch)
tree9628a9aacb0521e2da58e7b2ef6142956a2aa5dd /devel
parent8bd1b4b2f477392d4e068d69958f1fa5351b6be5 (diff)
downloadfreebsd-ports-gnome-4e39eff6b45e9ac70da053ae2e2f0444d8dc91f2.tar.gz
freebsd-ports-gnome-4e39eff6b45e9ac70da053ae2e2f0444d8dc91f2.tar.zst
freebsd-ports-gnome-4e39eff6b45e9ac70da053ae2e2f0444d8dc91f2.zip
- Pass maintainership to submitter
- Update to 1.0 - Set PHP to version 4 a default PR: ports/106478 Submitted by: Gerrit Beine<gerrit.beine@gmx.de>
Diffstat (limited to 'devel')
-rw-r--r--devel/simpletest/Makefile115
-rw-r--r--devel/simpletest/distinfo6
-rw-r--r--devel/simpletest/pkg-plist75
3 files changed, 37 insertions, 159 deletions
diff --git a/devel/simpletest/Makefile b/devel/simpletest/Makefile
index 05f5f34d5e15..62a5453d4cac 100644
--- a/devel/simpletest/Makefile
+++ b/devel/simpletest/Makefile
@@ -5,104 +5,57 @@
# $FreeBSD$
#
-PORTNAME= SimpleTest
-PORTVERSION= 1.0.r1
+PORTNAME= simpletest
+PORTVERSION= 1.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:L}/
-DISTNAME= php_simple_test_1.0RC1
+DISTNAME= ${PORTNAME:L}_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gerrit.beine@gmx.de
COMMENT= Unit testing, mock objects and web testing framework for PHP
USE_PHP= pcre
USE_PHP_BUILD= yes
+DEFAULT_PHP_VER=4
NO_BUILD= yes
-SIMPLETESTS?= unit
-
-.include <bsd.port.pre.mk>
-
-PHP_CONFIG?= ${LOCALBASE}/bin/php-config
-
-.if !defined(PEARDIR) && exists(${PHP_CONFIG})
-_PEARPREFIX!= ${PHP_CONFIG} --prefix
-_PEARDIR= share/pear
-PEARDIR= ${_PEARPREFIX}/${_PEARDIR}
-.endif
WRKSRC= ${WRKDIR}/${PORTNAME:L}
-PLIST_SUB+= PEARDIR="${_PEARDIR}"
+
.if !defined(NOPORTDOCS)
-DOCS= HELP_MY_TESTS_DONT_WORK_ANYMORE LICENSE README VERSION \
- docs/expectation_documentation.html \
- docs/form_testing_documentation.html \
- docs/group_test_documentation.html \
- docs/index.html \
- docs/mock_objects_documentation.html \
- docs/overview.html \
- docs/partial_mocks_documentation.html \
- docs/reporter_documentation.html \
- docs/server_stubs_documentation.html \
- docs/unit_test_documentation.html \
- docs/web_tester_documentation.html
+DOCFILES= HELP_MY_TESTS_DONT_WORK_ANYMORE README
+HTMLDOCFILES= docs/en/*
.endif
-TESTS= test/acceptance_test.php \
- test/adapter_test.php \
- test/all_tests.php \
- test/authentication_test.php \
- test/browser_test.php \
- test/dumper_test.php \
- test/errors_test.php \
- test/expectation_test.php \
- test/form_test.php \
- test/frames_test.php \
- test/http_test.php \
- test/live_test.php \
- test/options_test.php \
- test/page_test.php \
- test/parser_test.php \
- test/real_sites_test.php \
- test/remote_test.php \
- test/shell_test.php \
- test/shell_tester_test.php \
- test/simple_mock_test.php \
- test/socket_test.php \
- test/tag_test.php \
- test/unit_tests.php \
- test/url_test.php \
- test/user_agent_test.php \
- test/visual_test.php \
- test/web_tester_test.php \
- test/xml_test.php
-
-CLASSES= authentication.php browser.php dumper.php errors.php \
- expectation.php extensions/pear_test_case.php \
- extensions/phpunit_test_case.php form.php frames.php http.php \
- mock_objects.php options.php page.php parser.php remote.php \
- reporter.php scorer.php shell_tester.php simple_test.php \
- socket.php tag.php unit_tester.php url.php user_agent.php \
- web_tester.php xml.php
-
-pre-patch:
- ${CP} -r ${WRKSRC}/test ${WRKSRC}/test.beforeinstall
-
-#do-build:
-# cd ${WRKSRC}/test.beforeinstall && \
-# ${LOCALBASE}/bin/php -f ${SIMPLETESTS}_tests.php
+DATAFILES= *.php extensions test LICENSE VERSION
do-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/ \
+ && ${FIND} ${DATAFILES} -type d -exec ${MKDIR} ${DATADIR}/{} \; \
+ && ${FIND} ${DATAFILES} -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
+.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/html
+.for file in ${DOCFILES}
+ ${CP} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
- ${MKDIR} ${DATADIR}/test
-.for f in ${TESTS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}/${f}
-.endfor
- ${MKDIR} ${PEARDIR}/simpletest/extensions
-.for f in ${CLASSES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PEARDIR}/simpletest/${f}
+.for file in ${HTMLDOCFILES}
+ ${CP} ${WRKSRC}/${file} ${DOCSDIR}/html
.endfor
+.endif
+
+post-install:
+ @${FIND} -s ${DATAFILES:S,^,${WRKSRC}/,} -not -type d \
+ | ${SED} -ne 's,^${WRKSRC},${DATADIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${DATAFILES:S,^,${WRKSRC}/,} -type d \
+ | ${SED} -ne 's,^${WRKSRC},@dirrm ${DATADIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm ${DATADIR:S,^${PREFIX}/,,}" >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${FIND} -s ${DOCSDIR} -not -type d \
+ | ${SED} -ne 's,^${PREFIX}/,,p' >> ${TMPPLIST}
+ @${FIND} -s -d ${DOCSDIR} -type d \
+ | ${SED} -ne 's,^${PREFIX}/,@dirrm ,p' >> ${TMPPLIST}
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/simpletest/distinfo b/devel/simpletest/distinfo
index 7340229a6dbd..cf2336570fa3 100644
--- a/devel/simpletest/distinfo
+++ b/devel/simpletest/distinfo
@@ -1,3 +1,3 @@
-MD5 (php_simple_test_1.0RC1.tar.gz) = 00ec0a4c94e5480c15550039886248c1
-SHA256 (php_simple_test_1.0RC1.tar.gz) = 0890a10c7b0a51c675af9d6b9164d008c3e3e4c168c9472877e75fdb3fb61ebd
-SIZE (php_simple_test_1.0RC1.tar.gz) = 155315
+MD5 (simpletest_1.0.tar.gz) = 043457189beef64eaa7c3a2735a36b5d
+SHA256 (simpletest_1.0.tar.gz) = 905ecccf3a3505a3f676bb386665e4070cffb53f31fbf5eaa6b98816580e7a4d
+SIZE (simpletest_1.0.tar.gz) = 218460
diff --git a/devel/simpletest/pkg-plist b/devel/simpletest/pkg-plist
deleted file mode 100644
index f1b0b006bb1f..000000000000
--- a/devel/simpletest/pkg-plist
+++ /dev/null
@@ -1,75 +0,0 @@
-%%PEARDIR%%/simpletest/authentication.php
-%%PEARDIR%%/simpletest/browser.php
-%%PEARDIR%%/simpletest/dumper.php
-%%PEARDIR%%/simpletest/errors.php
-%%PEARDIR%%/simpletest/expectation.php
-%%PEARDIR%%/simpletest/extensions/pear_test_case.php
-%%PEARDIR%%/simpletest/extensions/phpunit_test_case.php
-%%PEARDIR%%/simpletest/form.php
-%%PEARDIR%%/simpletest/frames.php
-%%PEARDIR%%/simpletest/http.php
-%%PEARDIR%%/simpletest/mock_objects.php
-%%PEARDIR%%/simpletest/options.php
-%%PEARDIR%%/simpletest/page.php
-%%PEARDIR%%/simpletest/parser.php
-%%PEARDIR%%/simpletest/remote.php
-%%PEARDIR%%/simpletest/reporter.php
-%%PEARDIR%%/simpletest/scorer.php
-%%PEARDIR%%/simpletest/shell_tester.php
-%%PEARDIR%%/simpletest/simple_test.php
-%%PEARDIR%%/simpletest/socket.php
-%%PEARDIR%%/simpletest/tag.php
-%%PEARDIR%%/simpletest/unit_tester.php
-%%PEARDIR%%/simpletest/url.php
-%%PEARDIR%%/simpletest/user_agent.php
-%%PEARDIR%%/simpletest/web_tester.php
-%%PEARDIR%%/simpletest/xml.php
-%%PORTDOCS%%%%DOCSDIR%%/HELP_MY_TESTS_DONT_WORK_ANYMORE
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/VERSION
-%%PORTDOCS%%%%DOCSDIR%%/expectation_documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/form_testing_documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/group_test_documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/mock_objects_documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/overview.html
-%%PORTDOCS%%%%DOCSDIR%%/partial_mocks_documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/reporter_documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/server_stubs_documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/unit_test_documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/web_tester_documentation.html
-%%DATADIR%%/test/acceptance_test.php
-%%DATADIR%%/test/adapter_test.php
-%%DATADIR%%/test/all_tests.php
-%%DATADIR%%/test/authentication_test.php
-%%DATADIR%%/test/browser_test.php
-%%DATADIR%%/test/dumper_test.php
-%%DATADIR%%/test/errors_test.php
-%%DATADIR%%/test/expectation_test.php
-%%DATADIR%%/test/form_test.php
-%%DATADIR%%/test/frames_test.php
-%%DATADIR%%/test/http_test.php
-%%DATADIR%%/test/live_test.php
-%%DATADIR%%/test/options_test.php
-%%DATADIR%%/test/page_test.php
-%%DATADIR%%/test/parser_test.php
-%%DATADIR%%/test/real_sites_test.php
-%%DATADIR%%/test/remote_test.php
-%%DATADIR%%/test/shell_test.php
-%%DATADIR%%/test/shell_tester_test.php
-%%DATADIR%%/test/simple_mock_test.php
-%%DATADIR%%/test/socket_test.php
-%%DATADIR%%/test/tag_test.php
-%%DATADIR%%/test/unit_tests.php
-%%DATADIR%%/test/url_test.php
-%%DATADIR%%/test/user_agent_test.php
-%%DATADIR%%/test/visual_test.php
-%%DATADIR%%/test/web_tester_test.php
-%%DATADIR%%/test/xml_test.php
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/test
-@dirrm %%DATADIR%%
-@dirrm %%PEARDIR%%/simpletest/extensions
-@dirrm %%PEARDIR%%/simpletest
-@dirrmtry %%PEARDIR%%